

<!DOCTYPE html>
<!--[if lte IE 9]><html lang="en" class="lteIE9"><![endif]-->
<!--[if !IE]><!--><html lang="en"><!--<![endif]-->
    <head>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge">

        
        
            
                <link rel="preload" href="/assets_v4r/dist/combined/css/page_79a3c7.min.css" as="style" />
            
                <link rel="preload" href="/assets_v4r/dist/combined/js/page_772769.min.js" as="script" />
            
                <link rel="preload" href="https://cf-images.eu-west-1.prod.boltdns.net/v1/jit/6057949401001/ce589646-9e03-4cb3-b1e0-164274cc7ed0/main/640x360/29s557ms/match/image.jpg" as="image" />
            
                <link rel="preload" href="https://images.popbuzz.com/images/22393?crop=1_1&amp;width=200&amp;signature=yRrIbhZWfKVFjSn687blRMJ24jM=" as="image" />
            
                <link rel="preload" href="https://cf-images.eu-west-1.prod.boltdns.net/v1/jit/6057949401001/6fce287c-4951-4902-99c8-986e4c30d690/main/640x360/29s557ms/match/image.jpg" as="image" />
            
        

        
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-16x16.png" sizes="16x16" />
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-32x32.png" sizes="32x32" />
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-196x196.png" sizes="196x196" />
        <link rel="apple-touch-icon-precomposed" sizes="57x57" href="/assets_v4r/popbuzz/img/apple-touch-icon-57x57.png" />
        <link rel="apple-touch-icon-precomposed" sizes="60x60" href="/assets_v4r/popbuzz/img/apple-touch-icon-60x60.png" />
        <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/assets_v4r/popbuzz/img/apple-touch-icon-72x72.png" />
        <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/assets_v4r/popbuzz/img/apple-touch-icon-76x76.png" />
        <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/assets_v4r/popbuzz/img/apple-touch-icon-114x114.png" />
        <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/assets_v4r/popbuzz/img/apple-touch-icon-120x120.png" />
        <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/assets_v4r/popbuzz/img/apple-touch-icon-144x144.png" />
        <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/assets_v4r/popbuzz/img/apple-touch-icon-152x152.png" />

        
        
        <link rel="canonical" href="https://www.popbuzz.com/music/artists/lizzo/news/weight-loss-juice-detox-diet/" />
        

        
        <link rel="amphtml" href="https://amp.popbuzz.com/music/artists/lizzo/news/weight-loss-juice-detox-diet/" />
        

        
        <meta name="application-name" content=""/>

        <title>Lizzo addresses backlash surrounding her 10-day juice detox - PopBuzz</title>

        <meta content="width=device-width, initial-scale=1.0" name="viewport" />

        <meta content="https://www.popbuzz.com/music/artists/lizzo/news/weight-loss-juice-detox-diet/" name="parsely-link" />
<meta content="/music/artists/lizzo/news/" name="parsely-section" />
<meta content="17160" name="parsely-post-id" />
<meta content="2020-12-15T11:43:37+00:00" name="parsely-pub-date" />
<meta content="https://images.popbuzz.com/images/207561?width=680&crop=16_9&signature=R3-Fz4AaXMsbM1YQ0ULTFwX6Kn8=" name="parsely-image-url" />
<meta content="Jazmin Duribe" name="parsely-author" />
<meta content="Lizzo addresses backlash surrounding her 10-day juice detox" name="parsely-title" />
<meta content="https://www.popbuzz.com/music/artists/lizzo/news/weight-loss-juice-detox-diet/" property="og:url" />
<meta content="PopBuzz" property="og:site_name" />
<meta content="www.popbuzz.com" property="og:domain" />
<meta content="article" property="og:type" />
<meta content="https://images.popbuzz.com/images/207561?width=680&crop=16_9&signature=R3-Fz4AaXMsbM1YQ0ULTFwX6Kn8=" property="og:image" />
<meta content="383" property="og:image:height" />
<meta content="680" property="og:image:width" />
<meta content="Lizzo addresses weight loss backlash after doing juice cleanse detox diet." property="og:description" />
<meta content="Lizzo addresses backlash surrounding her 10-day juice detox" property="og:title" />
<meta content="2020-12-15T11:43:37" name="pubdate" itemprop="datePublished" />
<meta content="2020-12-15T11:43:37" name="modified" itemprop="dateModified" />
<meta content="post" name="parsely-type" />
<meta content="weight, loss, detox, product, lizzo, addresses, backlash, surrounding, 10-day, juice, body, positivity" name="keywords" />
<meta content="Lizzo addresses weight loss backlash after doing juice cleanse detox diet." name="description" />
<meta content="Jazmin Duribe" name="parsely-author" />
<meta content="@popbuzz" name="twitter:site" />
<meta content="https://www.popbuzz.com/music/artists/lizzo/news/weight-loss-juice-detox-diet/" name="twitter:url" />
<meta content="summary_large_image" name="twitter:card" />
<meta content="https://images.popbuzz.com/images/207561?width=680&crop=16_9&signature=R3-Fz4AaXMsbM1YQ0ULTFwX6Kn8=" name="twitter:image" />
<meta content="Lizzo addresses weight loss backlash after doing juice cleanse detox diet." name="twitter:description" />
<meta content="Lizzo addresses backlash surrounding her 10-day juice detox" name="twitter:title" />
<meta content="music, artists, lizzo, news, weight-loss-juice-detox-diet" name="sailthru.tags" />
<meta content="2020-12-15 11:43:37+00:00" name="sailthru.date" />
<meta content="627792841,551351399,716836285,1547481361,837890453,661531116" property="fb:admins" />
<meta content="1590232324531551" property="fb:app_id" />
<meta content="1488952944702289" property="fb:page_id" />
<meta content="1488952944702289" property="fb:pages" />
        

        



	
		<link rel="stylesheet" href="/assets_v4r/dist/combined/css/page_79a3c7.min.css" />
	




        <script>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</script>

        <!-- Promise Polyfill and WaitForIt race condition resolver -->
        <script src="/assets_v4r/dist/gusto/js/app/lib/promise-polyfill.js"></script>
        <script src="/assets_v4r/dist/gusto/js/app/lib/waitForIt.js"></script>

        <!-- Global DAC -->
        
            
<script>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</script>

        

        <!-- Global DAC Execution WITH SOURCEPOINT -->
        
            <script>
    // Enable Google Ad Services
    function googleAdManagerInit() {
        var isNonPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(gusto.sourcepoint.nonIabIds.vendors.googleAdManager) ? 0 : 1;
        googletag.cmd.push(function() {
            googletag.pubads()
                .setTargeting("section", String(window.GLOBALADVERTISING.section))
                .setTargeting("pageid", String(window.GLOBALADVERTISING.pageid))
                .setTargeting("contenttype", String(window.GLOBALADVERTISING.contenttype))
                .setTargeting("gdpr_consent", String(window.GLOBALADVERTISING.gdpr_consent))
                .setTargeting("adtest", String(window.GLOBALADVERTISING.adtest))
                .setTargeting("level", String(window.GLOBALADVERTISING.level))
                .setTargeting("at", String(window.GLOBALADVERTISING.at))
                .setTargeting("loginstate", String(window.GLOBALADVERTISING.loginstate))
                .setTargeting("pagecount", String(window.GLOBALADVERTISING.pagecount))
                .setTargeting("newslink", window.GLOBALADVERTISING.newslink ? String(window.GLOBALADVERTISING.newslink) : '')
                .setTargeting("sensitive", String(window.GLOBALADVERTISING.sensitive))
                .setTargeting("takeover", String(Math.floor(Math.random()*6) + 1));
            if(window.gusto.nielsen.segments) {
                googletag.pubads().setTargeting("nmc", String(window.gusto.nielsen.segments.split(":")));
            }
            googletag.pubads().setTargeting("npa", String(isNonPersonalisedAds));
    
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.pubads().disableInitialLoad();
            googletag.enableServices();

            // events
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot.getSlotElementId() === 'ad-banner') {
                    window.WaitForIt.trigger('ad_banner_rendered');
                }
            });
                
            googletag.pubads().refresh();
        });
    }
</script>

        
        
        <!-- SOURCEPOINT -->
        <script>
    gusto.sourcepoint = {
        'enabled': true,
        'gdprApplies': true,
        'baseEndpoint': "https://d.sourcepoint.popbuzz.com",
        'nonIabVendorConsents': [],
        'nonIabPurposeConsents': [],
        'iabVendorConsents': {},
        'iabPurposeConsents': {},

        'iabIds': {"vendors": {"outbrain": 164, "digiteka": 343, "adyoulike": 259, "nielsen": 373}, "purposes": {"accessInformationOnDevice": 1, "applyMarketResearch": 9, "measureAdPerformance": 7, "createPersonalisedAds": 3, "selectBasicAds": 2, "createPersonalisedContent": 5, "selectPersonalisedAds": 4, "selectPersonalisedContent": 6, "measureContentPerformance": 8, "developImproveProducts": 10}},
        'nonIabIds': {"vendors": {"googleAnalytics": "5e542b3a4cd8884eb41b5a72", "gigya": "5e945f26b8e05c1c467daad8", "fbAudienceNetwork": "5ee91b9593fc094b59242e26", "brightcove": "5ec796b4320b5a4efd764e0f", "googleAdManager": "5e74df5ff443bb795772df9c", "skimlinks": "5efb47d829507407f91c4d4e", "adobeAdvertising": "5ed7a9968c242d01c4a14072"}},

        'checkIabVendorConsentById': function (vendorId) {
            return this.iabVendorConsents[vendorId] == true;
        },

        'checkIabPurposeConsents': function (purposeId) {
            return this.iabPurposeConsents[purposeId] == true;
        },

        'checkNonIabVendorConsentById': function (vendorId) {
            for(var i=0; i<this.nonIabVendorConsents.length; i++) {
                if(this.nonIabVendorConsents[i]["_id"] === vendorId) {
                    return true;
                }
            }
            return false;
        },
    };
</script>

        
        <!-- Extra JS requested by cards (head) -->
        


        <!-- CMP -->
        
            <script type="text/javascript">
    !function () {
        var e = function () {
            var e, t = "__tcfapiLocator", a = [], n = window;
            for (; n;) {
                try {
                    if (n.frames[t]) {
                        e = n;
                        break
                    }
                } catch (e) {
                }
                if (n === window.top) break;
                n = n.parent
            }
            e || (!function e() {
                var a = n.document, r = !!n.frames[t];
                if (!r) if (a.body) {
                    var i = a.createElement("iframe");
                    i.style.cssText = "display:none", i.name = t, a.body.appendChild(i)
                } else setTimeout(e, 5);
                return !r
            }(), n.__tcfapi = function () {
                for (var e, t = arguments.length, n = new Array(t), r = 0; r < t; r++) n[r] = arguments[r];
                if (!n.length) return a;
                if ("setGdprApplies" === n[0]) n.length > 3 && 2 === parseInt(n[1], 10) && "boolean" == typeof n[3] && (e = n[3], "function" == typeof n[2] && n[2]("set", !0)); else if ("ping" === n[0]) {
                    var i = {gdprApplies: e, cmpLoaded: !1, cmpStatus: "stub"};
                    "function" == typeof n[2] && n[2](i)
                } else a.push(n)
            }, n.addEventListener("message", (function (e) {
                var t = "string" == typeof e.data, a = {};
                try {
                    a = t ? JSON.parse(e.data) : e.data
                } catch (e) {
                }
                var n = a.__tcfapiCall;
                n && window.__tcfapi(n.command, n.version, (function (a, r) {
                    var i = {__tcfapiReturn: {returnValue: a, success: r, callId: n.callId}};
                    t && (i = JSON.stringify(i)), e.source.postMessage(i, "*")
                }), n.parameter)
            }), !1))
        };
        "undefined" != typeof module ? module.exports = e : e()
    }();
</script>
<script type="text/javascript">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</script>
<script id="tcfV2Script"></script>
<script>
    document.getElementById('tcfV2Script').src = gusto.sourcepoint.baseEndpoint + '/wrapperMessagingWithoutDetection.js';
</script>

        

        <!-- Advertising -->
        
            <!-- DAC -->
            
                <script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
                <script>
                    window.googletag = window.googletag || {cmd: []};
                </script>
            
        

        
            <link rel="stylesheet" type="text/css" href="https://players.brightcove.net/videojs-ima3/3/videojs.ima3.min.css" />
        
        
    </head>
    <body class="no-js">
        <!-- Extra Js requested by cards (body) -->
        
            <script src="https://players.brightcove.net/6057949401001/default_default/index.min.js"></script>
        
            <script src="https://players.brightcove.net/videojs-ima3/3/videojs.ima3.min.js"></script>
        

        <!-- NIELSEN -->
        
            <!-- START Nielsen interchange script -->
<script type="text/javascript">
if(gusto.sourcepoint.enabled) {
    window.gusto.nielsen = {
        userId: null,
        segments: "",
        callbacks: [],
        init: function() {
            var isNielsenOn = gusto.sourcepoint.checkIabVendorConsentById(gusto.sourcepoint.iabIds.vendors.nielsen) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectPersonalisedContent) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectPersonalisedAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectBasicAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.createPersonalisedAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.createPersonalisedContent) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.measureAdPerformance) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.measureContentPerformance) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.applyMarketResearch) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.developImproveProducts) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.accessInformationOnDevice);

            if (!window.gusto.sourcepoint.gdprApplies || isNielsenOn) {
                if (window.localStorage) {
                    window.gusto.nielsen.userId = window.localStorage.getItem('nmcUserId') || null;
                    window.gusto.nielsen.segments = window.localStorage.getItem('nmcSegments') || "";
                }
                //Fires GTM Tags
                dataLayer.push({
                    'event': 'nielsen_gtm_fire',
                });
            } else {
                window.gusto.nielsen.userId = null;
                window.gusto.nielsen.segments = "";
                if (window.localStorage) {
                    window.localStorage.removeItem('nmcUserId');
                    window.localStorage.removeItem('nmcSegments'); 
                }
            }
        },
        receive: function(data) {
            if (data.user) {
                window.gusto.nielsen.userId = data.user.uid;
                window.gusto.nielsen.segments = data.user.segments.split(',').slice(0, 200).join(',');
            }
            for(var index=0; index < window.gusto.nielsen.callbacks.length; index++) {
                var callback = window.gusto.nielsen.callbacks[index];
                callback.call();
            }
            if (window.localStorage) {
                window.localStorage.setItem('nmcUserId', window.gusto.nielsen.userId);
                window.localStorage.setItem('nmcSegments', window.gusto.nielsen.segments);
            }
            window.WaitForIt.trigger('nielsen_data_ready');
        }
    };          
} else {
    window.gusto.nielsen = {
        userId: null,
        segments: "",
        callbacks: [],
        init: function() {
            if (window.localStorage) {
                window.gusto.nielsen.userId = window.localStorage.getItem('nmcUserId') || null;
                window.gusto.nielsen.segments = window.localStorage.getItem('nmcSegments') || "";
            }
        },
        receive: function(data) {
            if (data.user) {
                window.gusto.nielsen.userId = data.user.uid;
                window.gusto.nielsen.segments = data.user.segments.split(',').slice(0, 200).join(',');
            }
            for(var index=0; index < window.gusto.nielsen.callbacks.length; index++) {
                var callback = window.gusto.nielsen.callbacks[index];
                callback.call();
            }
            if (window.localStorage) {
                window.localStorage.setItem('nmcUserId', window.gusto.nielsen.userId);
                window.localStorage.setItem('nmcSegments', window.gusto.nielsen.segments);
            }
            window.WaitForIt.trigger('nielsen_data_ready');
        }
    };
    window.gusto.nielsen.init();
}
</script>
<!-- END Nielsen interchange script -->

        
        
        


<!-- Google Tag Manager - Data Layer -->
<script>dataLayer = [{"render_mode": "v4", "brand": "popbuzz", "ad_tools": {"digiteka_mdtk": "02018156"}, "content_type": "cadmus-article", "page": {"category1": "music", "category3": "music/artists/lizzo", "category2": "music/artists", "contentType": "cadmus-article", "cleanUrl": "https://www.popbuzz.com/music/artists/lizzo/news/weight-loss-juice-detox-diet/", "title": "Lizzo addresses backlash surrounding her 10-day juice detox", "brand": "popbuzz", "path": "/music/artists/lizzo/news/weight-loss-juice-detox-diet/", "platformType": "web"}, "full_path": "/music/artists/lizzo/news/weight-loss-juice-detox-diet/"}];</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N7KJ77&render_mode=v4&brand=popbuzz&ad_tools=%7B%27digiteka_mdtk%27%3A+%2702018156%27%7D&content_type=cadmus-article&page=%7B%27category1%27%3A+u%27music%27%2C+%27category3%27%3A+u%27music%2Fartists%2Flizzo%27%2C+%27category2%27%3A+u%27music%2Fartists%27%2C+%27contentType%27%3A+%27cadmus-article%27%2C+%27cleanUrl%27%3A+%27https%3A%2F%2Fwww.popbuzz.com%2Fmusic%2Fartists%2Flizzo%2Fnews%2Fweight-loss-juice-detox-diet%2F%27%2C+%27title%27%3A+u%27Lizzo+addresses+backlash+surrounding+her+10-day+juice+detox%27%2C+%27brand%27%3A+%27popbuzz%27%2C+%27path%27%3A+u%27%2Fmusic%2Fartists%2Flizzo%2Fnews%2Fweight-loss-juice-detox-diet%2F%27%2C+%27platformType%27%3A+%27web%27%7D&full_path=%2Fmusic%2Fartists%2Flizzo%2Fnews%2Fweight-loss-juice-detox-diet%2F"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N7KJ77');</script>
<!-- End Google Tag Manager -->



        <script type="text/javascript">document.body.className = document.body.className.replace('no-js', 'js');</script>

        <div id="fb-root"></div>

        
    <div id="ad-overlay" class="dac__overlay">
        <script>
            (function(){
                var ua_string = window.navigator.userAgent;
                var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                var ad_mapping =  window.GLOBALADVERTISING.mappings['overlay'];

                if(ad_mapping) {
                    if (disable_ads) {
                        document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                    }
                    else {
                        if(log_ads) {
                            console.log('Ad position defined', 'overlay');
                        }
                        
                            
                                window.GLOBALADVERTISING.push('overlay', ad_mapping, false);
                            
                        
                    }
                }
                else {
                    console.error('No mapping defined for overlay');
                }
            })();
        </script>
    </div>



        
            

<!-- BLOCK:0 ADS SECTION -->

<div class="dac__banner__wrapper dac__banner__wrapper--sticky" id="banner-wrapper">
    
    <div id="ad-banner" class="dac__banner">
        <script>
            (function(){
                var ua_string = window.navigator.userAgent;
                var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                var ad_mapping =  window.GLOBALADVERTISING.mappings['banner'];

                if(ad_mapping) {
                    if (disable_ads) {
                        document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                    }
                    else {
                        if(log_ads) {
                            console.log('Ad position defined', 'banner');
                        }
                        
                            
                                var valid_breakpoint = true;
                                if(gusto.breakpoints) {
                                    valid_breakpoint = gusto.breakpoints.check('large-up');
                                }
                                if(valid_breakpoint) {
                                    window.GLOBALADVERTISING.push('banner', ad_mapping, false);
                                }
                            
                        
                    }
                }
                else {
                    console.error('No mapping defined for banner');
                }
            })();
        </script>
    </div>


</div>


<header class="header " id="header">

    <!-- BLOCK:1 USER STATUS HEADER -->
    <div class="header__section header__section--primary-bg header__user-status">
        <div class="header__container">
            <ul id="user_status" class="header-user-status"></ul>
            
        </div>
    </div>

    <!-- BLOCK:2 HEADER MAIN -->
    <div class="header__section header__main js-header-main">
        <div class="header__container">
            <a href="#primary" class="skip-nav js-skip-nav"><span>skip to navigation</span></a>
            


<p class="header__logo ">
    <a class="header__logo__link" href="/">PopBuzz</a>
</p>





        </div>
    </div>

    <!-- BLOCK:3 PRIMARY NAV -->
    <div class="header__section" id="nav_wrapper" >
        <nav id="primary" class="header__container standard">
            <ul>
                
                <li  class="nav-home "
                    
                     >

                    
                    <a href="/">Home</a>
                    
                </li>
                
                <li  class="nav-news "
                    
                    
                        data-id="101"
                     >

                    
                    <a href="/news/">News</a>
                    
                </li>
                
                <li  class="nav-quizzes "
                    
                    
                        data-id="70"
                     >

                    
                    <a href="/quizzes/">Quizzes</a>
                    
                </li>
                
                <li  class="nav-video "
                    
                    
                        data-id="111"
                     >

                    
                    <a href="/exclusives/">Video</a>
                    
                </li>
                
                <li  class="nav-music "
                    
                    
                        data-id="72"
                     >

                    
                    <a href="/music/">Music</a>
                    
                </li>
                
                <li  class="nav-tv-film "
                    
                    
                        data-id="109"
                     >

                    
                    <a href="/tv-film/">TV &amp; Film</a>
                    
                </li>
                
                <li  class="nav-internet "
                    
                    
                        data-id="106"
                     >

                    
                    <a href="/internet/">Internet</a>
                    
                </li>
                
                <li  class="nav-life "
                    
                    
                        data-id="108"
                     >

                    
                    <a href="/life/">Life</a>
                    
                </li>
                
                <li  class="nav-style "
                    
                    
                        data-id="110"
                     >

                    
                    <a href="/style/">Style</a>
                    
                </li>
                
                <li  class="nav-celeb "
                    
                    
                        data-id="404"
                     >

                    
                    <a href="/celeb/">Celeb</a>
                    
                </li>
                
                <li id="members_nav_link" class="nav-a-z "
                    
                    
                        data-id="418"
                     >

                    
                    <a href="/index/">A-Z</a>
                    
                </li>
                
                


    <li class="social-links util--hidden-on-desktop">
        <em class="social-links__label">Follow us on:</em>
        <div class="social-links__container">
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--twitter" 
                href="https://twitter.com/popbuzz" 
                title="Follow PopBuzz on Twitter" 
                target="_blank">Follow PopBuzz on Twitter</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--facebook" 
                href="https://www.facebook.com/popbuzz" 
                title="Follow PopBuzz on Facebook" 
                target="_blank">Follow PopBuzz on Facebook</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--instagram" 
                href="https://instagram.com/popbuzz" 
                title="Follow PopBuzz on Instagram" 
                target="_blank">Follow PopBuzz on Instagram</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--youtube" 
                href="https://www.youtube.com/user/popbuzz" 
                title="Follow PopBuzz on Youtube" 
                target="_blank">Follow PopBuzz on Youtube</a>
        </div>
    
 </div>
    </li>

            </ul>
        </nav>
    </div>

    <!-- BLOCK:4 TRENDING BAR/CONTEXT NAV -->
    <div class="header__section">
        
            <div class="contextual-nav__wrapper ">
                <div class="contextual-nav js-contextual-nav">
                    
                    <p class="contextual-nav__section-parent">
                        <a href="/music/artists/lizzo/">Lizzo</a>
                    </p>
                    

                    
                        
                        <p class="contextual-nav__header">
                        
                            News
                            <a class="js-contextual-nav-toggle contextual-nav__nav-toggle" href="#" >
                                <span class="contextual-nav__nav-toggle__nav-button nav_button"></span>
                            </a>
                        
                        </p>
                        
                    

                    
                </div>
            </div>
        
    </div>

    <!-- BLOCK:5 MOBILE NOW PLAYING -->
    
</header>

        

        
        <script src="https://cdns.gigya.com/js/gigya.js?apiKey=3_WH4MJ8IycdfGXMMWMTfHVEjUZsdBQLJtL2U0PA52XGaD0oE7STlJggZPvup80Kbz" defer></script>
        <script src="/dynamic/userContent.js"></script>
        

        <section role="main">
            <div class="dac__banner__wrapper">
                
            </div>
            
<div class="row row21">

    
        <div class="level2_wrapper">
            
                <div class="

cardset
level2




">

    

    

        
            

<article id="cadmus-article_16261" class="editorial cadmus full article cadmus-article">
    <script type="application/ld+json">
        {"articleBody": "&quot;Can&#39;t believe Lizzo \u2013 whose biggest theme in her music is advocating for the body positivity movement, loving yourself no matter what size you are, especially if you\u2019re big \u2013 has promoted some weight loss detox product.&quot; Lizzo has responded to the backlash triggered by her documenting her recent smoothie detox.On Monday (Dec 14), Lizzo revealed that she had embarked on a 10-day detox after &quot;fucking her stomach up&quot; whilst in Mexico. The &#x27;Juice&#x27; singer shared her progress and what she ate each day, which included green juices packed with fruit and vegetables, supplements, nuts and litres of &quot;beauty water&quot;.Soon after sharing her health journey with fans, Lizzo was met with backlash for posting the detox process. Detoxes are notoriously a marketing myth and have no scientific basis. The human body is able to get rid of toxins itself without the need to drink only fruits and vegetables.READ MORE: Lizzo&#x27;s powerful response to body shamers on TikTok is going viral According to The British Dietetic Association, &quot;when you starve your body of calories your body will ultimately start to build up chemicals called ketones. These chemicals can result in nausea, dehydration, weakness, light-headedness and irritability. Further, a prolonged lack of protein causes your body to break down its own muscles and can compromise your immune system.&quot;Lizzo is often the poster girl for body positivity and loving yourself so she was criticised for seemingly changing her stance and possibly triggering those with eating disorders.&quot;Can\u2019t believe lizzo, who\u2019s biggest theme in her music is advocating for the body positivity movement, loving yourself no matter what size you are, especially if you\u2019re big, has promoted some weight loss detox product,&quot; one fan wrote. Another added: &quot;Lizzo doesn\u2019t owe us anything and she\u2019s absolutely free to do whatever she wants.  I think the disappointment lies in a lot of us (especially fat, black women) seeing ourselves in a woman who was so proud and confident in her body. It made us want to do the same to ours.&quot; Others defended Lizzo&#x27;s right to do what she wants with her body.  Lizzo has now explained why she started the detox on TikTok and, no, it had nothing to do with weight loss. &quot;I feel like people think as a big girl if you&#x27;re doing something for health you&#x27;re doing something for, like, a dramatic weight loss and that is not the case,&quot; she said. &quot;In reality, November stressed me the fuck out,&quot; she continued. &quot;I drank a lot, I ate a lot of spicy things and things that fucked my stomach up. I wanted to reverse it and get back to where I was. I\u2019m so proud of myself. I\u2019m proud of my results. My sleep has improved, my hydration, my inner peace, my mental stability, my fucking body, my fucking skin, the whites of my eyes, I feel and look like a bad bitch and that&#x27;s it.&quot;She continued: &quot;I&#x27;m a big girl who did a smoothie detox and I wanted to share it with you guys. I got exactly what I wanted to get out of it and every big girl should do whatever the fuck they want with their bodies.&quot; ", "description": "\"Can't believe Lizzo \u2013 whose biggest theme in her music is advocating for the body positivity movement, loving yourself no matter what size you are, especially if you\u2019re big \u2013 has promoted some weight loss detox product.\"", "creator": [{"@type": "Person", "name": "Jazmin Duribe"}], "image": {"url": "https://images.popbuzz.com/images/207561?width=700&crop=16_9&signature=vYuLV0LA0wGMjO30glYZzA6wy_U=", "width": 700, "@type": "ImageObject", "height": 394}, "datePublished": "2020-12-15T11:43:37+00:00", "publisher": {"logo": {"url": "", "@type": "ImageObject"}, "@type": "Organization", "name": "PopBuzz"}, "author": [{"@type": "Person", "name": "Jazmin Duribe"}], "headline": "Lizzo addresses backlash surrounding her 10-day juice detox", "dateModified": "2020-12-15T11:43:49+00:00", "mainEntityOfPage": {"@id": "https://www.popbuzz.com/music/artists/lizzo/news/weight-loss-juice-detox-diet/", "@type": "WebPage"}, "@context": "http://schema.org", "@type": "Article"}
    </script>

    
        <script>
            var gusto = window.gusto || {};
            gusto.article = {
                'title': 'Lizzo addresses backlash surrounding her 10-day juice detox',
                'publish_epoch': '1608032617',
                'slug': 'weight-loss-juice-detox-diet',
                'author': 'Jazmin Duribe',
                'category': 'News'
            };
            gusto.related_content = [{"absolute_url": "http://www.popbuzz.com/style/beauty/nikkietutorials-jaclyn-hill-morphe-palette-review/", "id": "14588", "title": "NikkieTutorials addresses backlash surrounding her Jaclyn Hill Morphe palette review"}, {"absolute_url": "http://www.popbuzz.com/music/news/lizzo-rolling-stone-magazine-cover-interview/", "id": "14425", "title": "Lizzo responds to criticism that her music is for white people"}, {"absolute_url": "http://www.popbuzz.com/music/artists/ariana-grande/news/lizzo-good-as-hell-remix-billboard-hot-100/", "id": "13930", "title": "Lizzo thanks Ariana Grande for Good as Hell remix following backlash from fans"}];
        </script>
    
     
    <h1>Lizzo addresses backlash surrounding her 10-day juice detox</h1>

    
        <p class="publish_date">15 December 2020, 11:43</p>
    

    <div style="position:relative;padding-top:56.25%; margin-bottom:10px;">
<video-js id="bc_player_6216349643001" data-video-id="6216349643001" data-account="6057949401001" data-player="default" data-embed="default" class="video-js" style="position:absolute;top:0;left:0;width:100%;height:100%;" controls="controls"></video-js>
</div>
<script>
    (function () {
            window.WaitForIt.wait_for(['nielsen_data_ready', 'sourcepoint_data_ready'], function() {
                var player = bc('bc_player_6216349643001');
                
                if (window.gusto.ad_switch.enable_ads_preroll === true) {
                    var isPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(
                            gusto.sourcepoint.nonIabIds.vendors.googleAdManager
                        ),
                        bc_tag_url = 'https://pubads.g.doubleclick.net/gampad/ads?iu=/21824617191/popbuzz/video/brightcove_player&description_url={window.location.href}&tfcd=0&npa=1&sz=400x300%7C640x480&cmsid=2527446&vid={mediainfo.id}&ad_rule=1&gdfp_req=1&output=xml_vast&unviewed_position_start=1&env=vp&impl=s&correlator={random}';

                    // npa means non-personalised ads
                    if (isPersonalisedAds) {
                        bc_tag_url = bc_tag_url.replace('npa=1', 'npa=0');
                    }

                    if (window.GLOBALADVERTISING) {
                        bc_tag_url +=
                            '&cust_params=' +
                            encodeURIComponent('kvplayer=' + 'brightcove') +
                            encodeURIComponent(
                                '&pageid=' + window.GLOBALADVERTISING.pageid
                            ) +
                            encodeURIComponent('&local=' + window.GLOBALADVERTISING.local) +
                            encodeURIComponent(
                                '&adtest=' + window.GLOBALADVERTISING.adtest
                            ) +
                            encodeURIComponent('&section=' + gusto.CATEGORY_PATH) +
                            encodeURIComponent('&at=' + window.GLOBALADVERTISING.at) +
                            encodeURIComponent(
                                '&sensitive=' + window.GLOBALADVERTISING.sensitive
                            ) +
                            encodeURIComponent('&gdpr=' + window.GLOBALADVERTISING.gdpr) +
                            encodeURIComponent(
                                '&gdpr_pd=' + window.GLOBALADVERTISING.gdpr_pd
                            ) +
                            encodeURIComponent(
                                '&gdpr_consent=' + window.GLOBALADVERTISING.gdpr_consent
                            ) +
                            encodeURIComponent('&nmc=' + gusto.nielsen.segments);
                    }

                    player.ima3({
                        serverUrl: bc_tag_url,
                        requestMode: "onplay",
                    });
                }
            }, 10000);
    })();
</script>
<div class="author-details author-details--has-avatar">
<img class="author-details__avatar" src="https://images.popbuzz.com/images/22393?crop=1_1&amp;width=200&amp;signature=yRrIbhZWfKVFjSn687blRMJ24jM=" alt="Jazmin Duribe" />
<p class="author-details__author">
        By Jazmin Duribe
    </p>
<a class="author-details__twitter_handle" href="https://twitter.com/jazminduribe" target="_blank" title="Follow Jazmin Duribe on Twitter" rel="author">
@jazminduribe</a>
</div>
<div class="gigya_share_wrapper">
<div class="gigya_share"></div>
</div>
<p class="standfirst">&quot;Can&#39;t believe Lizzo – whose biggest theme in her music is advocating for the body positivity movement, loving yourself no matter what size you are, especially if you’re big – has promoted some weight loss detox product.&quot;</p>
<p><a href="https://www.popbuzz.com/music/artists/lizzo/" rel="noopener" target="_blank">Lizzo</a> has responded to the backlash triggered by her documenting her recent smoothie detox.</p><div id="Teads_ad1"></div><p>On Monday (Dec 14), Lizzo revealed that she had embarked on a 10-day detox after &quot;fucking her stomach up&quot; whilst in Mexico. The &#x27;Juice&#x27; singer shared her progress and what she ate each day, which included green juices packed with fruit and vegetables, supplements, nuts and litres of &quot;beauty water&quot;.</p><p>Soon after sharing her health journey with fans, Lizzo was met with backlash for posting the detox process. Detoxes are notoriously a marketing myth and have no scientific basis. The human body is able to get rid of toxins itself without the need to drink only fruits and vegetables.</p><p><strong>READ MORE:</strong> <a href="https://www.popbuzz.com/music/artists/lizzo/news/workout-video-tiktok-body-positive/" rel="noopener" target="_blank">Lizzo&#x27;s powerful response to body shamers on TikTok is going viral</a></p><div class="adyoulike-article"></div>
<div style="position:relative;padding-top:56.25%; margin-bottom:10px;">
<video-js id="bc_player_6216347936001" data-video-id="6216347936001" data-account="6057949401001" data-player="default" data-embed="default" class="video-js" style="position:absolute;top:0;left:0;width:100%;height:100%;" controls="controls"></video-js>
</div>
<script>
    (function () {
            window.WaitForIt.wait_for(['nielsen_data_ready', 'sourcepoint_data_ready'], function() {
                var player = bc('bc_player_6216347936001');
                
                if (window.gusto.ad_switch.enable_ads_preroll === true) {
                    var isPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(
                            gusto.sourcepoint.nonIabIds.vendors.googleAdManager
                        ),
                        bc_tag_url = 'https://pubads.g.doubleclick.net/gampad/ads?iu=/21824617191/popbuzz/video/brightcove_player&description_url={window.location.href}&tfcd=0&npa=1&sz=400x300%7C640x480&cmsid=2527446&vid={mediainfo.id}&ad_rule=1&gdfp_req=1&output=xml_vast&unviewed_position_start=1&env=vp&impl=s&correlator={random}';

                    // npa means non-personalised ads
                    if (isPersonalisedAds) {
                        bc_tag_url = bc_tag_url.replace('npa=1', 'npa=0');
                    }

                    if (window.GLOBALADVERTISING) {
                        bc_tag_url +=
                            '&cust_params=' +
                            encodeURIComponent('kvplayer=' + 'brightcove') +
                            encodeURIComponent(
                                '&pageid=' + window.GLOBALADVERTISING.pageid
                            ) +
                            encodeURIComponent('&local=' + window.GLOBALADVERTISING.local) +
                            encodeURIComponent(
                                '&adtest=' + window.GLOBALADVERTISING.adtest
                            ) +
                            encodeURIComponent('&section=' + gusto.CATEGORY_PATH) +
                            encodeURIComponent('&at=' + window.GLOBALADVERTISING.at) +
                            encodeURIComponent(
                                '&sensitive=' + window.GLOBALADVERTISING.sensitive
                            ) +
                            encodeURIComponent('&gdpr=' + window.GLOBALADVERTISING.gdpr) +
                            encodeURIComponent(
                                '&gdpr_pd=' + window.GLOBALADVERTISING.gdpr_pd
                            ) +
                            encodeURIComponent(
                                '&gdpr_consent=' + window.GLOBALADVERTISING.gdpr_consent
                            ) +
                            encodeURIComponent('&nmc=' + gusto.nielsen.segments);
                    }

                    player.ima3({
                        serverUrl: bc_tag_url,
                        requestMode: "onplay",
                    });
                }
            }, 10000);
    })();
</script>
<p>According to <a href="https://www.nhs.uk/livewell/tiredness-and-fatigue/documents/truthdetoxdiets.pdf" rel="noopener" target="_blank">The British Dietetic Association</a>, &quot;when you starve your body of calories your body will ultimately start to build up chemicals called ketones. These chemicals can result in nausea, dehydration, weakness, light-headedness and irritability. Further, a prolonged lack of protein causes your body to break down its own muscles and can compromise your immune system.&quot;</p><p>Lizzo is often the poster girl for body positivity and loving yourself so she was criticised for seemingly changing her stance and possibly triggering those with eating disorders.</p><p>&quot;Can’t believe lizzo, who’s biggest theme in her music is advocating for the body positivity movement, loving yourself no matter what size you are, especially if you’re big, has promoted some weight loss detox product,&quot; one fan wrote. </p><p>Another added: &quot;Lizzo doesn’t owe us anything and she’s absolutely free to do whatever she wants.  I think the disappointment lies in a lot of us (especially fat, black women) seeing ourselves in a woman who was so proud and confident in her body. It made us want to do the same to ours.&quot;</p>
<div class="dac__article-mpu">
<div id="ad-mpu" class="dac__mpu">
<script>
            (function(){
                var ua_string = window.navigator.userAgent;
                var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                var ad_mapping =  window.GLOBALADVERTISING.mappings['mpu'];

                if(ad_mapping) {
                    if (disable_ads) {
                        document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                    }
                    else {
                        if(log_ads) {
                            console.log('Ad position defined', 'mpu');
                        }
                        
                            
                                var valid_breakpoint = true;
                                if(gusto.breakpoints) {
                                    valid_breakpoint = gusto.breakpoints.check('medium-down');
                                }
                                if(valid_breakpoint) {
                                    window.GLOBALADVERTISING.push('mpu', ad_mapping, false);
                                }
                            
                        
                    }
                }
                else {
                    console.error('No mapping defined for mpu');
                }
            })();
        </script>
</div>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Lizzo doesn’t owe us anything and she’s absolutely free to do whatever she wants. <br />I think the disappointment lies in a lot of us (especially fat, black women) seeing ourselves in a woman who was so proud and confident in her body.<br />It made us want to do the same to ours.</p>&mdash; Steph (@StephanieYeboah) <a href="https://twitter.com/StephanieYeboah/status/1338602212545728512?ref_src=twsrc%5Etfw">December 14, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">can’t believe lizzo, who’s biggest theme in her music is advocating for the body positivity movement, loving yourself no matter what size you are, especially if you’re big, has promoted some weight loss detox product.</p>&mdash; aoife ÷) (@djbigstinky) <a href="https://twitter.com/djbigstinky/status/1338778098725052416?ref_src=twsrc%5Etfw">December 15, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">This convo on fatphobia ain’t fair, y’all. We not actually mad at Lizzo.<br /><br />Our critiques are actually, literally abt systemic fatphobia + how we anticipate Lizzo’s actions will be exploited by that system, against us.<br /><br />Bringing our rage to her door like its for her? VIOLENT. Wild.</p>&mdash; THIS A DESZ STAN ACCT (@YesAurielle) <a href="https://twitter.com/YesAurielle/status/1338639947109191680?ref_src=twsrc%5Etfw">December 15, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">/tw diet mention<br /><br />lizzo promoted a smoothie detox diet and people are all “leave her alone she’s not bothering anyone” but detoxes like those are really bad and she really shouldn’t be promoting them especially when she has such a large platform, <a href="https://twitter.com/lizzo?ref_src=twsrc%5Etfw">@lizzo</a> ily but this isn’t good :( <a href="https://t.co/bTtkaUZkdQ">pic.twitter.com/bTtkaUZkdQ</a></p>&mdash; nate stans hoodie (BLM)📌 (@wellbutran) <a href="https://twitter.com/wellbutran/status/1338633731502911491?ref_src=twsrc%5Etfw">December 14, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">i love Lizzo, but as someone who lost weight and is recovering from an ED, she’s in the wrong. she absolutely should promote whatever she wants with her body — being large, small, or whatever she’s happiest with — but promoting a “detox” “juice cleanse” ties DIRECTLY into (1/?)</p>&mdash; jupiter // SECOND SINGING / RAP ERA LET’S GOOOO (@traumaqueer4eva) <a href="https://twitter.com/traumaqueer4eva/status/1338715887910653955?ref_src=twsrc%5Etfw">December 15, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2>Others defended Lizzo&#x27;s right to do what she wants with her body. </h2>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Those people screaming about people policing Lizzo body a few months ago just wanted to police it on their own terms.</p>&mdash; Ivy Park Beam (@ScottieBeam) <a href="https://twitter.com/ScottieBeam/status/1338644353682731008?ref_src=twsrc%5Etfw">December 15, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">not ya&#39;ll mad at lizzo bc she wants to make healthier decisions- <a href="https://twitter.com/hashtag/lizzo?src=hash&amp;ref_src=twsrc%5Etfw">#lizzo</a> <a href="https://t.co/iDD8hpYvlV">pic.twitter.com/iDD8hpYvlV</a></p>&mdash; ariana (@tylerscokewhore) <a href="https://twitter.com/tylerscokewhore/status/1338633114810191874?ref_src=twsrc%5Etfw">December 14, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Guess what <a href="https://twitter.com/hashtag/Lizzo?src=hash&amp;ref_src=twsrc%5Etfw">#Lizzo</a> can do what the fuck she want to do I know not any of y’all paying her bills boo If she want to lose weight let her <a href="https://t.co/IQI1aKJzcR">pic.twitter.com/IQI1aKJzcR</a></p>&mdash; Sip Slow With Kiy (@SipKiy) <a href="https://twitter.com/SipKiy/status/1338631289902075905?ref_src=twsrc%5Etfw">December 14, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">So, let y&#39;all tell it <a href="https://twitter.com/lizzo?ref_src=twsrc%5Etfw">@lizzo</a> can&#39;t be fat, so she changes her diet. Now, she can&#39;t be skinny! Damn, can she just be HAPPY?! However SHE defines it. <a href="https://twitter.com/hashtag/yallareannoying?src=hash&amp;ref_src=twsrc%5Etfw">#yallareannoying</a></p>&mdash; LaTonya Foster (@GirlGoneBoss) <a href="https://twitter.com/GirlGoneBoss/status/1338648222177366017?ref_src=twsrc%5Etfw">December 15, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Lizzo says she’s happy with her weight. Y’all = mad. Lizzo says she wants to lose weight and get healthy. Y’all = mad. When will you people leave her alone and let her do what she wants? <a href="https://t.co/W4ABmE3eMM">pic.twitter.com/W4ABmE3eMM</a></p>&mdash; nunyuhbusiness (@hijabimoon) <a href="https://twitter.com/hijabimoon/status/1338635831523860480?ref_src=twsrc%5Etfw">December 15, 2020</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<p>Lizzo has now explained why she started the detox on TikTok and, no, it had nothing to do with weight loss. &quot;I feel like people think as a big girl if you&#x27;re doing something for health you&#x27;re doing something for, like, a dramatic weight loss and that is not the case,&quot; she said. </p><p>&quot;In reality, November stressed me the fuck out,&quot; she continued. &quot;I drank a lot, I ate a lot of spicy things and things that fucked my stomach up. I wanted to reverse it and get back to where I was. I’m so proud of myself. I’m proud of my results. My sleep has improved, my hydration, my inner peace, my mental stability, my fucking body, my fucking skin, the whites of my eyes, I feel and look like a bad bitch and that&#x27;s it.&quot;</p><p>She continued: &quot;I&#x27;m a big girl who did a smoothie detox and I wanted to share it with you guys. I got exactly what I wanted to get out of it and every big girl should do whatever the fuck they want with their bodies.&quot; </p>
    
    
    
    

    
        
    <div id="ad-instream" class="dac__instream">
        <script>
            (function(){
                var ua_string = window.navigator.userAgent;
                var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                var ad_mapping =  window.GLOBALADVERTISING.mappings['instream'];

                if(ad_mapping) {
                    if (disable_ads) {
                        document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                    }
                    else {
                        if(log_ads) {
                            console.log('Ad position defined', 'instream');
                        }
                        
                            
                                window.GLOBALADVERTISING.push('instream', ad_mapping, false);
                            
                        
                    }
                }
                else {
                    console.error('No mapping defined for instream');
                }
            })();
        </script>
    </div>


    

    
        <div id="ultimedia_wrapper"></div>

    

    

</article>

        
        
    
</div>

            
        </div>
    
        <div class="level1_wrapper">
            
                <div class="

cardset
level1




">

    

    

        
            


    <div class="dac__mpu-card">
    <div id="ad-mpu-desktop" class="dac__mpu-desktop">
        <script>
            (function(){
                var ua_string = window.navigator.userAgent;
                var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                var ad_mapping =  window.GLOBALADVERTISING.mappings['mpu-desktop'];

                if(ad_mapping) {
                    if (disable_ads) {
                        document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                    }
                    else {
                        if(log_ads) {
                            console.log('Ad position defined', 'mpu-desktop');
                        }
                        
                            
                                var valid_breakpoint = true;
                                if(gusto.breakpoints) {
                                    valid_breakpoint = gusto.breakpoints.check('large-up');
                                }
                                if(valid_breakpoint) {
                                    window.GLOBALADVERTISING.push('mpu-desktop', ad_mapping, false);
                                }
                            
                        
                    }
                }
                else {
                    console.error('No mapping defined for mpu-desktop');
                }
            })();
        </script>
    </div>

</div>


        
        
    
</div>

            
                <div class="

cardset
level1




">

    
        <h2 class="cardset__title "><span>Trending on PopBuzz</span></h2>
        
    

    

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/music/artists/taylor-swift/news/woodvale-folklore-album-cover-theory/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://images.popbuzz.com/images/207566?crop=1_1&width=500&signature=xRbz8sxUBy0pENEOrcpKeBtMASw=" alt="Taylor Swift explains what Woodvale on the Folklore album cover means" /></div><h3>
        
            
            Taylor Swift addresses new Woodvale album theory
            
        
        </h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/music/artists/taylor-swift/news/woodvale-folklore-album-cover-theory/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/music/artists/taylor-swift/">Taylor Swift</a></p>


        </div>
    </div>
</div>

        
            
<div class="gallery editorial promo short-form landscape gallery pivot">

    

    <a href="/tv-film/features/tiny-pretty-things-cast/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://assets.popbuzz.com/2020/50/tiny-pretty-things-cast--1607972666-list-tablet-0.png" alt="Tiny Pretty Things cast " /></div><h3>
        
            
            Tiny Pretty Things cast: Who is in the Netflix cast?
            
        
        </h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/features/tiny-pretty-things-cast/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/tv-film/">TV &amp; Film</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/exclusives/interviews/gregory-dillon-my-life-in-20/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://images.popbuzz.com/images/207341?crop=1_1&width=500&signature=5nqqL4qJ5hFHNzDIfibJuzXzSec=" alt="Gregory Dillon" /></div><h3><span class="ellipsis">Gregory Dillon: ‘Describe myself in four words? Cries</span><span class="truncated"> after sex often’ | My Life in 20</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/exclusives/interviews/gregory-dillon-my-life-in-20/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/exclusives/interviews/">Interviews</a></p>


        </div>
    </div>
</div>

        
            
<div class="gallery editorial promo short-form landscape gallery pivot">

    

    <a href="/music/artists/little-mix/features/jesy-nelson/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://assets.popbuzz.com/2019/02/jesy-nelson-facts-1547410435-list-tablet-0.jpg" alt="Jesy Nelson facts" /></div><h3><span class="ellipsis">Jesy Nelson: 23 facts about the Little Mix star you</span><span class="truncated"> probably never knew </span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/music/artists/little-mix/features/jesy-nelson/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/music/artists/little-mix/">Little Mix</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/music/artists/little-mix/news/jesy-nelson-quits-leaves/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://images.popbuzz.com/images/207413?crop=1_1&width=500&signature=87zQctr7rXH3Jsae08CkWdsaKHs=" alt="Jesy Nelson leaves Little Mix" /></div><h3><span class="ellipsis">Jesy Nelson quits Little Mix: "Being in the band has</span><span class="truncated"> taken a toll on my mental health"</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/music/artists/little-mix/news/jesy-nelson-quits-leaves/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/music/artists/little-mix/">Little Mix</a></p>


        </div>
    </div>
</div>

        
        
    
</div>

            
        </div>
    

</div>


        </section>
        


<footer class="footer">
    <div class="footer__section footer-back-to-top">
        <a href="#" id="go_to_top" class="footer-back-to-top__link" title="Back to top">Back to top</a>
    </div>

    <div class="footer__section">
        <div class="grid-row">
            <div class="grid-row__col--3">
                
    <h3 class="footer__heading">Also on PopBuzz</h3>
    <ul class="footer-hot-links">
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/american-horror-story/" class="footer-hot-links__link">American Horror Story</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/euphoria/" class="footer-hot-links__link">Euphoria</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/chilling-adventures-of-sabrina/" class="footer-hot-links__link">Chilling Adventures of Sabrina</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/greys-anatomy/" class="footer-hot-links__link">Grey&#39;s Anatomy</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/top-nine-instagram-2019-app/" class="footer-hot-links__link">Instagram Top Nine</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/news/spotify-stats-top-artists-songs-most-played-how/" class="footer-hot-links__link">Spotify</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/timothee-chalamet/" class="footer-hot-links__link">Timothée Chalamet</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/tiktok/" class="footer-hot-links__link">TikTok</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/josephine-langford/" class="footer-hot-links__link">Josephine Langford</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/hero-fiennes-tiffin/" class="footer-hot-links__link">Hero Fiennes Tiffin</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/louis-partridge/" class="footer-hot-links__link">Louis Partridge</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/quizzes/" class="footer-hot-links__link">Quizzes</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/louis-partridge/" class="footer-hot-links__link">Louis Partridge</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/bella-poarch/" class="footer-hot-links__link">Bella Poarch</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/haunting-of-bly-manor/" class="footer-hot-links__link">The Haunting of Bly Manor</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/the-kissing-booth/" class="footer-hot-links__link">The Kissing Booth</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/best-memes-2020/" class="footer-hot-links__link">Memes</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/the-umbrella-academy/season-3-release-date-cast-trailer-netflix/" class="footer-hot-links__link">The Umbrella Academy 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/best-tiktok-songs-2020-popular/" class="footer-hot-links__link">TikTok Songs</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/lizzo/" class="footer-hot-links__link">Lizzo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/billie-eilish/" class="footer-hot-links__link">Billie Eilish</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/elite-netflix/season-4-release-date-cast-trailer-spoilers-news/" class="footer-hot-links__link">Elite season 4</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/on-my-block/" class="footer-hot-links__link">On My Block</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race/" class="footer-hot-links__link">RuPaul&#39;s Drag Race</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/snapchat/" class="footer-hot-links__link">Snapchat</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/stranger-things/stranger-things-season-4-release-date-cast-trailer/" class="footer-hot-links__link">Stranger Things 4</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/millie-bobby-brown/" class="footer-hot-links__link">Millie Bobby Brown</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/addison-rae/" class="footer-hot-links__link">Addison Rae</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/outer-banks/" class="footer-hot-links__link">Outer Banks</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/nick-robinson/" class="footer-hot-links__link">Nick Robinson</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/charli-damelio/" class="footer-hot-links__link">Charli D&#39;Amelio</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/harry-styles/" class="footer-hot-links__link">Harry Styles</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/sex-education/" class="footer-hot-links__link">Sex Education</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/features/doja-cat/" class="footer-hot-links__link">Doja Cat</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/bts/" class="footer-hot-links__link">BTS</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/to-all-the-boys-ive-loved-before/" class="footer-hot-links__link">To All The Boys I&#39;ve Loved Before</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/tv-film/netflix/" class="footer-hot-links__link">Netflix</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/twenty-one-pilots/" class="footer-hot-links__link">Twenty One Pilots</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/halsey/" class="footer-hot-links__link">Halsey</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/" class="footer-hot-links__link">New Music</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/panic-at-the-disco/" class="footer-hot-links__link">Panic! At The Disco</a>
            </li>
        
    </ul>


            </div>
        </div>
    </div>

    <div class="footer__section--shaded">
        <div class="grid-row">
            <div class="grid-row__col--1">
                <h3 class="footer__heading">Useful Links</h3>
                <ul class="footer-useful-links">
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/about-us/" target="_blank">About Us</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/contact-us/" target="_blank">Contact Us</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="https://global.com/cookies/" target="_blank">Cookies</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="https://global.com/privacy-policy/" target="_blank">Privacy</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/terms-conditions/" target="_blank">Terms &amp; Conditions</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/advertise/" target="_blank">Advertise</a>
                        
                    
                    </li>
                
                </ul>
            </div>

            <div class="grid-row__col--1">
                
                    <h3 class="footer__heading">Latest From Twitter</h3>
                    <ul class="twitter-tweets">
<p class="twitter-tweets__user">PopBuzz &dash; <a href="http://twitter.com/popbuzz/" class="twitter-tweets__link" target="_blank">@popbuzz</a></p>

    <li class="twitter-tweets__item">
    	<p class="twitter-tweets__tweet">10 absolutely iconic mullets that defined 2020 ✨

<a href="https://popbuzz.co/386Firc" class="twitter-tweets__link" target="_blank">popbuzz.co/386Firc</a> <a href="https://twitter.com/popbuzz/status/1338574613404585985/photo/1" class="twitter-tweets__link" target="_blank">pic.twitter.com/f5BFkWXdiY</a></p>
    </li>

</ul>

                
            </div>

            <div class="grid-row__col--1">
                <h3 class="footer__heading">Follow Us</h3>
                <div class="social-links__container">
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--twitter" 
                href="https://twitter.com/popbuzz" 
                title="Follow PopBuzz on Twitter" 
                target="_blank">Follow PopBuzz on Twitter</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--facebook" 
                href="https://www.facebook.com/popbuzz" 
                title="Follow PopBuzz on Facebook" 
                target="_blank">Follow PopBuzz on Facebook</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--instagram" 
                href="https://instagram.com/popbuzz" 
                title="Follow PopBuzz on Instagram" 
                target="_blank">Follow PopBuzz on Instagram</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--youtube" 
                href="https://www.youtube.com/user/popbuzz" 
                title="Follow PopBuzz on Youtube" 
                target="_blank">Follow PopBuzz on Youtube</a>
        </div>
    
 </div>
            </div>
        </div>
    </div>

    <div class="footer__section">
        <div class="grid-row" itemscope itemtype="http://schema.org/Organization">
            <div class="grid-row__col--3 footer-footnote-section">
                &copy; <span itemprop="legalName">Global</span> 2020
            </div>
            <div class="grid-row__col--3 footer-footnote-section footer-footnote-section--end" itemprop="address">
                30 Leicester Square, London, WC2H 7LA
            </div>
            
                <a class="footer__section__privacy_manager_button" id="privacy_manager__button" href="#">
                    Privacy Manager
                </a>
            
        </div>
    </div>
</footer>
<script>
    var privacy_manager__button = document.getElementById('privacy_manager__button');
    if(privacy_manager__button) {
        privacy_manager__button.onclick = function(e) {
            e.preventDefault();
            if (window._sp_) {
                window._sp_.loadPrivacyManagerModal(
                    "173688"
                );
            }
        };
    }
</script>


        
        


    
        
            <script src="/assets_v4r/dist/combined/js/page_772769.min.js" defer></script>
        
    



        <!-- Global DAC Execution -->
        
            <script>
    // Enable Google Ad Services
    function googleAdManagerInit() {
        var isNonPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(gusto.sourcepoint.nonIabIds.vendors.googleAdManager) ? 0 : 1;
        googletag.cmd.push(function() {
            googletag.pubads()
                .setTargeting("section", String(window.GLOBALADVERTISING.section))
                .setTargeting("pageid", String(window.GLOBALADVERTISING.pageid))
                .setTargeting("contenttype", String(window.GLOBALADVERTISING.contenttype))
                .setTargeting("gdpr_consent", String(window.GLOBALADVERTISING.gdpr_consent))
                .setTargeting("adtest", String(window.GLOBALADVERTISING.adtest))
                .setTargeting("level", String(window.GLOBALADVERTISING.level))
                .setTargeting("at", String(window.GLOBALADVERTISING.at))
                .setTargeting("loginstate", String(window.GLOBALADVERTISING.loginstate))
                .setTargeting("pagecount", String(window.GLOBALADVERTISING.pagecount))
                .setTargeting("newslink", window.GLOBALADVERTISING.newslink ? String(window.GLOBALADVERTISING.newslink) : '')
                .setTargeting("sensitive", String(window.GLOBALADVERTISING.sensitive))
                .setTargeting("takeover", String(Math.floor(Math.random()*6) + 1));
            if(window.gusto.nielsen.segments) {
                googletag.pubads().setTargeting("nmc", String(window.gusto.nielsen.segments.split(":")));
            }
            googletag.pubads().setTargeting("npa", String(isNonPersonalisedAds));
    
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.pubads().disableInitialLoad();
            googletag.enableServices();

            // events
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot.getSlotElementId() === 'ad-banner') {
                    window.WaitForIt.trigger('ad_banner_rendered');
                }
            });
                
            googletag.pubads().refresh();
        });
    }
</script>

        
    </body>
</html>
