

<!DOCTYPE html>
<!--[if lte IE 9]><html lang="en" class="lteIE9"><![endif]-->
<!--[if !IE]><!--><html lang="en"><!--<![endif]-->
    <head>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge">

        
        
            
                <link rel="preload" href="/assets_v4r/dist/combined/css/page_ae6cf2.min.css" as="style" />
            
                <link rel="preload" href="/assets_v4r/dist/combined/js/page_a80bed.min.js" as="script" />
            
                <link rel="preload" href="https://cf-images.eu-west-1.prod.boltdns.net/v1/jit/6057949401001/e937255d-1266-4374-b4ab-26ea021df2e5/main/640x360/39s578ms/match/image.jpg" as="image" />
            
                <link rel="preload" href="https://images.popbuzz.com/images/22393?crop=1_1&amp;width=200&amp;signature=yRrIbhZWfKVFjSn687blRMJ24jM=" as="image" />
            
                <link rel="preload" href="https://images.popbuzz.com/images/246497?crop=16_9&amp;width=660&amp;relax=1&amp;signature=uMUJuBQ-_D_z9QI5R07v11tQOl8=" as="image" />
            
        
        
            <link rel="preload" href="/assets_v4r/dist/combined/fonts/chevrons.woff" as="font" type="font/woff" crossorigin/>
        

        
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-16x16.png" sizes="16x16" />
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-32x32.png" sizes="32x32" />
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-196x196.png" sizes="196x196" />
        <link rel="apple-touch-icon-precomposed" sizes="57x57" href="/assets_v4r/popbuzz/img/apple-touch-icon-57x57.png" />
        <link rel="apple-touch-icon-precomposed" sizes="60x60" href="/assets_v4r/popbuzz/img/apple-touch-icon-60x60.png" />
        <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/assets_v4r/popbuzz/img/apple-touch-icon-72x72.png" />
        <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/assets_v4r/popbuzz/img/apple-touch-icon-76x76.png" />
        <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/assets_v4r/popbuzz/img/apple-touch-icon-114x114.png" />
        <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/assets_v4r/popbuzz/img/apple-touch-icon-120x120.png" />
        <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/assets_v4r/popbuzz/img/apple-touch-icon-144x144.png" />
        <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/assets_v4r/popbuzz/img/apple-touch-icon-152x152.png" />

        
        <link rel="canonical" href="https://www.popbuzz.com/tv-film/news/sexy-beasts-netflix-dating-show-trailer/" />
        

        
        <link rel="amphtml" href="https://amp.popbuzz.com/tv-film/news/sexy-beasts-netflix-dating-show-trailer/" />
        

        <title>Netflix&#39;s new dating show Sexy Beasts is giving the internet nightmares - PopBuzz</title>

        <meta content="width=device-width, initial-scale=1.0" name="viewport" />

        <meta content="https://www.popbuzz.com/tv-film/news/sexy-beasts-netflix-dating-show-trailer/" name="parsely-link" />
<meta content="/tv-film/news/" name="parsely-section" />
<meta content="Netflix&#39;s new dating show Sexy Beasts is giving the internet nightmares" name="parsely-title" />
<meta content="18175" name="parsely-post-id" />
<meta content="2021-06-24T11:30:02+01:00" name="parsely-pub-date" />
<meta content="https://images.popbuzz.com/images/246497?width=680&crop=16_9&signature=iTDYXNSxb1cC9orD6ki7hA6QeZA=" name="parsely-image-url" />
<meta content="Jazmin Duribe" name="parsely-author" />
<meta content="https://www.popbuzz.com/tv-film/news/sexy-beasts-netflix-dating-show-trailer/" property="og:url" />
<meta content="PopBuzz" property="og:site_name" />
<meta content="www.popbuzz.com" property="og:domain" />
<meta content="article" property="og:type" />
<meta content="https://images.popbuzz.com/images/246497?width=680&crop=16_9&signature=iTDYXNSxb1cC9orD6ki7hA6QeZA=" property="og:image" />
<meta content="383" property="og:image:height" />
<meta content="680" property="og:image:width" />
<meta content="Netflix&#39;s Sexy Beasts is the new dating show giving the internet nightmares." property="og:description" />
<meta content="Netflix&#39;s new dating show Sexy Beasts is giving the internet nightmares" property="og:title" />
<meta content="2021-06-24T11:30:02" name="pubdate" itemprop="datePublished" />
<meta content="2021-06-24T11:30:01" name="modified" itemprop="dateModified" />
<meta content="post" name="parsely-type" />
<meta content="dating, show, sexy, beasts, internet, nightmares, netflix, giving, coming, july, radio, fm" name="keywords" />
<meta content="Netflix&#39;s Sexy Beasts is the new dating show giving the internet nightmares." name="description" />
<meta content="Jazmin Duribe" name="parsely-author" />
<meta content="@popbuzz" name="twitter:site" />
<meta content="https://www.popbuzz.com/tv-film/news/sexy-beasts-netflix-dating-show-trailer/" name="twitter:url" />
<meta content="summary_large_image" name="twitter:card" />
<meta content="https://images.popbuzz.com/images/246497?width=680&crop=16_9&signature=iTDYXNSxb1cC9orD6ki7hA6QeZA=" name="twitter:image" />
<meta content="Netflix&#39;s Sexy Beasts is the new dating show giving the internet nightmares." name="twitter:description" />
<meta content="Netflix&#39;s new dating show Sexy Beasts is giving the internet nightmares" name="twitter:title" />
<meta content="tv-film, news, sexy-beasts-netflix-dating-show-trailer" name="sailthru.tags" />
<meta content="2021-06-24 11:30:02+01:00" name="sailthru.date" />
<meta content="627792841,551351399,716836285,1547481361,837890453,661531116" property="fb:admins" />
<meta content="1590232324531551" property="fb:app_id" />
<meta content="1488952944702289" property="fb:page_id" />
<meta content="1488952944702289" property="fb:pages" />
        

        



	
		<link rel="stylesheet" href="/assets_v4r/dist/combined/css/page_ae6cf2.min.css" />
	




        <script>
            var gusto = window.gusto || {};
            gusto.MAIN_CONTENT_TYPE = "cadmus-article";
            gusto.ROOT_URL = "https://www.popbuzz.com";
            gusto.SITE_NAME = "PopBuzz";
            gusto.STATIC_URL = "/assets_v4r/";
            gusto.STATIC_BRAND_URL = "/assets_v4r/popbuzz/";
            gusto.CATEGORY_PATH = "/tv-film/news/";
            gusto.PROJECT_NAME = "popbuzz";
            gusto.PLAYER_INFO = {"localise_url": "/localise/", "play_overlay": false, "player_url_ukrp": null, "is_localised": true, "twin_stations": null, "player_url": null, "global_player_enabled": false, "localisation_light_enabled": false, "localisations_enabled": false, "player_url_template": ""};
            gusto.DEBUG = false;
            gusto.SETTINGS = {
                'COOKIE_STATION_MAX_AGE_SECONDS': 63072000
            };
            gusto.ad_settings = {
                'banner_visibility_delay': 3000,
            };
            gusto.ad_switch = {
                'enable_ads_dac': true,
                'enable_ads_related': false,
                'enable_ads_ukrp': true,
                'enable_ads_preroll': true,
                'enable_ads_related_videos': true,

            };
            gusto.STATION = {
                'name': "PopBuzz",
                'slug': ""
            };
            gusto.breakpoints = {
                limits: {
                    'small': [0, 640],
                    'medium': [641, 1023],
                    'large': [1024, 1440],
                    'xlarge': [1441, 1920],
                    'xxlarge': [1921, 9001]
                },
                check: function(target) {
                    
                    var target_bits = target.split('-'),
                        brkpoint = target_bits[0],
                        dir = target_bits[1],
                        win = window.innerWidth,
                        ref = this.limits[brkpoint];
                    if (!ref) return false;
                    if (dir == 'up') return (win >= ref[0]);
                    else if (dir == 'down') return (win <= ref[1]);
                    else return (win >= ref[0] && win <= ref[1]);
                }
            };

            gusto.ABSOLUTE_URL = "/tv-film/news/sexy-beasts-netflix-dating-show-trailer/";
            gusto.station_twitter = 'popbuzz';
            gusto.FACEBOOK_APP_ID = '1590232324531551';
            gusto.category_tree = {"1": {"full_slug": "/", "name": "popbuzz.com", "parent": null, "children": [101, 70, 111, 72, 109, 106, 108, 110, 404, 418]}, "418": {"full_slug": "/index/", "name": "A-Z", "parent": 1}, "101": {"full_slug": "/news/", "name": "News", "parent": 1}, "70": {"full_slug": "/quizzes/", "name": "Quizzes", "parent": 1}, "231": {"full_slug": "/music/quizzes/", "name": "Quizzes", "parent": 72}, "72": {"full_slug": "/music/", "name": "Music", "parent": 1, "children": [105, 119, 239, 231, 102]}, "105": {"full_slug": "/music/artists/", "name": "Artists", "parent": 72}, "106": {"full_slug": "/internet/", "name": "Internet", "parent": 1}, "108": {"full_slug": "/life/", "name": "Life", "parent": 1}, "109": {"full_slug": "/tv-film/", "name": "TV & Film", "parent": 1}, "110": {"full_slug": "/style/", "name": "Style", "parent": 1, "children": [361, 362, 230]}, "111": {"full_slug": "/exclusives/", "name": "Video", "parent": 1}, "102": {"full_slug": "/music/playlists/", "name": "Playlists", "parent": 72}, "404": {"full_slug": "/celeb/", "name": "Celeb", "parent": 1}, "119": {"full_slug": "/music/news/", "name": "News", "parent": 72}, "239": {"full_slug": "/music/features/", "name": "Features", "parent": 72}, "361": {"full_slug": "/style/beauty/", "name": "Beauty", "parent": 110}, "362": {"full_slug": "/style/fashion/", "name": "Fashion", "parent": 110}, "230": {"full_slug": "/style/quizzes/", "name": "Quizzes", "parent": 110}};
            gusto.APP_INFO = {
                'android_download_url': "",
                'ios_download_url': "https://itunes.apple.com/gb/app/popbuzz/id1078206186?mt=8",
                'android_launch_url': ""
            };
            gusto.page_id = "18175";
            gusto.render_mode = "v4";
            gusto.lazy_ads = [];
            gusto.ooyala = {
                player_google_ad_tag: "https://pubads.g.doubleclick.net/gampad/ads?iu=/21824617191/",
                requireIsReady: false,
                ooyalaIsReady: false,
                initOoyalaVideos: function(){},
                // 
                initOoyalaPlayer: function () {
                    gusto.ooyala.ooyalaIsReady = true;
                    if (gusto.ooyala.requireIsReady) {
                        gusto.ooyala.initOoyalaVideos();
                    }
                }
            };
            gusto.udb_user = {
                'grid': null
            };
        </script>

        <!-- Promise Polyfill and WaitForIt race condition resolver -->
        <script src="/assets_v4r/dist/gusto/js/app/lib/promise-polyfill.js"></script>
        <script src="/assets_v4r/dist/gusto/js/app/lib/waitForIt.js"></script>

        <!-- Global DAC -->
        
            
<script>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</script>

        

        <!-- Global DAC Execution WITH SOURCEPOINT -->
        
            <script>
    // Enable Google Ad Services
    function googleAdManagerInit() {
        var isNonPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(gusto.sourcepoint.nonIabIds.vendors.googleAdManager) ? 0 : 1;
        googletag.cmd.push(function() {
            googletag.pubads()
                .setTargeting("section", String(window.GLOBALADVERTISING.section))
                .setTargeting("pageid", String(window.GLOBALADVERTISING.pageid))
                .setTargeting("contenttype", String(window.GLOBALADVERTISING.contenttype))
                .setTargeting("gdpr_consent", String(window.GLOBALADVERTISING.gdpr_consent))
                .setTargeting("adtest", String(window.GLOBALADVERTISING.adtest))
                .setTargeting("level", String(window.GLOBALADVERTISING.level))
                .setTargeting("at", String(window.GLOBALADVERTISING.at))
                .setTargeting("loginstate", String(window.GLOBALADVERTISING.loginstate))
                .setTargeting("pagecount", String(window.GLOBALADVERTISING.pagecount))
                .setTargeting("newslink", window.GLOBALADVERTISING.newslink ? String(window.GLOBALADVERTISING.newslink) : '')
                .setTargeting("sensitive", String(window.GLOBALADVERTISING.sensitive))
                .setTargeting("takeover", String(Math.floor(Math.random()*6) + 1));
            if(window.gusto.nielsen.segments) {
                googletag.pubads().setTargeting("nmc", String(window.gusto.nielsen.segments.split(":")));
            }
            googletag.pubads().setTargeting("npa", String(isNonPersonalisedAds));
    
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.pubads().disableInitialLoad();
            googletag.enableServices();

            // events
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot.getSlotElementId() === 'ad-banner') {
                    window.WaitForIt.trigger('ad_banner_rendered');
                }
            });
                
            googletag.pubads().refresh();
        });
    }
</script>

        
        
        <!-- SOURCEPOINT -->
        <script>
    gusto.sourcepoint = {
        'enabled': true,
        'gdprApplies': true,
        'baseEndpoint': "https://d.sourcepoint.popbuzz.com",
        'nonIabVendorConsents': [],
        'nonIabPurposeConsents': [],
        'iabVendorConsents': {},
        'iabPurposeConsents': {},

        'iabIds': {"vendors": {"googleAnalytics": 755, "nielsen": 373, "outbrain": 164, "adyoulike": 259, "remixd": 886, "digiteka": 343}, "purposes": {"accessInformationOnDevice": 1, "applyMarketResearch": 9, "measureAdPerformance": 7, "createPersonalisedAds": 3, "selectBasicAds": 2, "createPersonalisedContent": 5, "selectPersonalisedAds": 4, "selectPersonalisedContent": 6, "measureContentPerformance": 8, "developImproveProducts": 10}},
        'nonIabIds': {"vendors": {"gigya": "5e945f26b8e05c1c467daad8", "fbAudienceNetwork": "5ee91b9593fc094b59242e26", "parsely": "5efb47c3a86ed40d775a6693", "brightcove": "5ec796b4320b5a4efd764e0f", "googleAdManager": "5e74df5ff443bb795772df9c", "skimlinks": "5efb47d829507407f91c4d4e", "adobeAdvertising": "5ed7a9968c242d01c4a14072"}},

        'checkIabVendorConsentById': function (vendorId) {
            return this.iabVendorConsents[vendorId] == true;
        },

        'checkIabPurposeConsents': function (purposeId) {
            return this.iabPurposeConsents[purposeId] == true;
        },

        'checkNonIabVendorConsentById': function (vendorId) {
            for(var i=0; i<this.nonIabVendorConsents.length; i++) {
                if(this.nonIabVendorConsents[i]["_id"] === vendorId) {
                    return true;
                }
            }
            return false;
        },
    };
</script>

        
        <!-- Extra JS requested by cards (head) -->
        


        <!-- CMP -->
        
            <script type="text/javascript">
    !function () {
        var e = function () {
            var e, t = "__tcfapiLocator", a = [], n = window;
            for (; n;) {
                try {
                    if (n.frames[t]) {
                        e = n;
                        break
                    }
                } catch (e) {
                }
                if (n === window.top) break;
                n = n.parent
            }
            e || (!function e() {
                var a = n.document, r = !!n.frames[t];
                if (!r) if (a.body) {
                    var i = a.createElement("iframe");
                    i.style.cssText = "display:none", i.name = t, a.body.appendChild(i)
                } else setTimeout(e, 5);
                return !r
            }(), n.__tcfapi = function () {
                for (var e, t = arguments.length, n = new Array(t), r = 0; r < t; r++) n[r] = arguments[r];
                if (!n.length) return a;
                if ("setGdprApplies" === n[0]) n.length > 3 && 2 === parseInt(n[1], 10) && "boolean" == typeof n[3] && (e = n[3], "function" == typeof n[2] && n[2]("set", !0)); else if ("ping" === n[0]) {
                    var i = {gdprApplies: e, cmpLoaded: !1, cmpStatus: "stub"};
                    "function" == typeof n[2] && n[2](i)
                } else a.push(n)
            }, n.addEventListener("message", (function (e) {
                var t = "string" == typeof e.data, a = {};
                try {
                    a = t ? JSON.parse(e.data) : e.data
                } catch (e) {
                }
                var n = a.__tcfapiCall;
                n && window.__tcfapi(n.command, n.version, (function (a, r) {
                    var i = {__tcfapiReturn: {returnValue: a, success: r, callId: n.callId}};
                    t && (i = JSON.stringify(i)), e.source.postMessage(i, "*")
                }), n.parameter)
            }), !1))
        };
        "undefined" != typeof module ? module.exports = e : e()
    }();
</script>
<script type="text/javascript">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</script>
<script id="tcfV2Script"></script>
<script>
    document.getElementById('tcfV2Script').src = gusto.sourcepoint.baseEndpoint + '/wrapperMessagingWithoutDetection.js';
</script>

        

        <!-- Advertising -->
        
            <!-- DAC -->
            <script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
            <script>
                window.googletag = window.googletag || {cmd: []};
            </script>
        

        
            <link rel="stylesheet" type="text/css" href="https://players.brightcove.net/videojs-ima3/3/videojs.ima3.min.css" />
        
        
    </head>
    <body class="no-js">
        <!-- Extra Js requested by cards (body) -->
        
            <script src="https://players.brightcove.net/6057949401001/default_default/index.min.js"></script>
        
            <script src="https://players.brightcove.net/videojs-ima3/3/videojs.ima3.min.js"></script>
        

        


<!-- Google Tag Manager - Data Layer -->
<script>dataLayer = [{"render_mode": "v4", "brand": "popbuzz", "ad_tools": {"digiteka_mdtk": "02018156"}, "content_type": "cadmus-article", "page": {"category1": "tv film", "category3": "tv film/news/sexy beasts netflix dating show trailer", "category2": "tv film/news", "contentType": "cadmus-article", "cleanUrl": "https://www.popbuzz.com/tv-film/news/sexy-beasts-netflix-dating-show-trailer/", "title": "Netflix's new dating show Sexy Beasts is giving the internet nightmares", "brand": "popbuzz", "path": "/tv-film/news/sexy-beasts-netflix-dating-show-trailer/", "platformType": "web"}, "full_path": "/tv-film/news/sexy-beasts-netflix-dating-show-trailer/"}];</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N7KJ77&render_mode=v4&brand=popbuzz&ad_tools=%7B%27digiteka_mdtk%27%3A+%2702018156%27%7D&content_type=cadmus-article&page=%7B%27category1%27%3A+u%27tv+film%27%2C+%27category3%27%3A+u%27tv+film%2Fnews%2Fsexy+beasts+netflix+dating+show+trailer%27%2C+%27category2%27%3A+u%27tv+film%2Fnews%27%2C+%27contentType%27%3A+%27cadmus-article%27%2C+%27cleanUrl%27%3A+%27https%3A%2F%2Fwww.popbuzz.com%2Ftv-film%2Fnews%2Fsexy-beasts-netflix-dating-show-trailer%2F%27%2C+%27title%27%3A+u%22Netflix%27s+new+dating+show+Sexy+Beasts+is+giving+the+internet+nightmares%22%2C+%27brand%27%3A+%27popbuzz%27%2C+%27path%27%3A+u%27%2Ftv-film%2Fnews%2Fsexy-beasts-netflix-dating-show-trailer%2F%27%2C+%27platformType%27%3A+%27web%27%7D&full_path=%2Ftv-film%2Fnews%2Fsexy-beasts-netflix-dating-show-trailer%2F"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N7KJ77');</script>
<!-- End Google Tag Manager -->



        <script type="text/javascript">document.body.className = document.body.className.replace('no-js', 'js');</script>

        <div id="fb-root"></div>
        
            
    
        <div id="ad-overlay" class="dac__overlay">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['overlay'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'overlay');
                            }
                            
                                
                                    window.GLOBALADVERTISING.push('overlay', ad_mapping, false);
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for overlay');
                    }
                })();
            </script>
        </div>
    


        
        
            


<header class="header header--with-contextual" id="header">

    <!-- BLOCK:0 USER STATUS HEADER -->
    <div class="header__section header__section--primary-bg header__user-status">
        <div class="header__container">
            <ul id="user_status" class="header-user-status"></ul>
        </div>
    </div>

    <!-- BLOCK:1 HEADER MAIN -->
    <div class="header__section header__main js-header-main">
        <div class="header__container">
            <a href="#primary" class="skip-nav js-skip-nav"><span>skip to navigation</span></a>
            


<p class="header__logo ">
    <a class="header__logo__link" href="/">PopBuzz</a>
</p>





        </div>
    </div>

    <!-- BLOCK:2 PRIMARY NAV -->
    <div class="header__section" id="nav_wrapper" >
        <nav id="primary" class="header__container standard">
            <ul>
                
                <li  class="nav-home "
                    
                     >

                    
                    <a href="/">Home</a>
                    
                </li>
                
                <li  class="nav-news "
                    
                    
                        data-id="101"
                     >

                    
                    <a href="/news/">News</a>
                    
                </li>
                
                <li  class="nav-quizzes "
                    
                    
                        data-id="70"
                     >

                    
                    <a href="/quizzes/">Quizzes</a>
                    
                </li>
                
                <li  class="nav-video "
                    
                    
                        data-id="111"
                     >

                    
                    <a href="/exclusives/">Video</a>
                    
                </li>
                
                <li  class="nav-music "
                    
                    
                        data-id="72"
                     >

                    
                    <a href="/music/">Music</a>
                    
                </li>
                
                <li  class="nav-tv-film "
                    
                    
                        data-id="109"
                     >

                    
                    <a href="/tv-film/">TV &amp; Film</a>
                    
                </li>
                
                <li  class="nav-internet "
                    
                    
                        data-id="106"
                     >

                    
                    <a href="/internet/">Internet</a>
                    
                </li>
                
                <li  class="nav-life "
                    
                    
                        data-id="108"
                     >

                    
                    <a href="/life/">Life</a>
                    
                </li>
                
                <li  class="nav-style "
                    
                    
                        data-id="110"
                     >

                    
                    <a href="/style/">Style</a>
                    
                </li>
                
                <li  class="nav-celeb "
                    
                    
                        data-id="404"
                     >

                    
                    <a href="/celeb/">Celeb</a>
                    
                </li>
                
                <li id="members_nav_link" class="nav-a-z "
                    
                    
                        data-id="418"
                     >

                    
                    <a href="/index/">A-Z</a>
                    
                </li>
                
                


    <li class="social-links util--hidden-on-desktop">
        <em class="social-links__label">Follow us on:</em>
        <div class="social-links__container">
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--twitter" 
                href="https://twitter.com/popbuzz" 
                title="Follow PopBuzz on Twitter" 
                target="_blank">Follow PopBuzz on Twitter</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--facebook" 
                href="https://www.facebook.com/popbuzz" 
                title="Follow PopBuzz on Facebook" 
                target="_blank">Follow PopBuzz on Facebook</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--instagram" 
                href="https://instagram.com/popbuzz" 
                title="Follow PopBuzz on Instagram" 
                target="_blank">Follow PopBuzz on Instagram</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--youtube" 
                href="https://www.youtube.com/user/popbuzz" 
                title="Follow PopBuzz on Youtube" 
                target="_blank">Follow PopBuzz on Youtube</a>
        </div>
    
 </div>
    </li>

            </ul>
        </nav>
    </div>

    <!-- BLOCK:3 TRENDING BAR/CONTEXT NAV -->
    <div class="header__section">
        
            <div class="contextual-nav__wrapper contextual-nav--pivot-available">
                <div class="contextual-nav js-contextual-nav">
                    

                    
                        
                        <p class="contextual-nav__header">
                        
                            TV &amp; Film
                            <a class="js-contextual-nav-toggle contextual-nav__nav-toggle" href="#" >
                                <span class="contextual-nav__nav-toggle__nav-button nav_button"></span>
                            </a>
                        
                        </p>
                        
                    

                    
                        <nav class="contextual-nav__nav">
                            <ul class="contextual-nav__nav__list">
                            
                                
                                    <li class="contextual-nav__nav__item" data-id=""><a href="/tv-film/">
            TV &amp; Film Home
        </a></li>

                                
                            
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="236"><a href="/tv-film/news/">
            News
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="227"><a href="/tv-film/quizzes/">
            Quizzes
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="317"><a href="/tv-film/american-horror-story/">
            American Horror Story
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="318"><a href="/tv-film/stranger-things/">
            Stranger Things
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="320"><a href="/tv-film/riverdale/">
            Riverdale
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="321"><a href="/tv-film/rupauls-drag-race/">
            RuPaul&#39;s Drag Race
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="357"><a href="/tv-film/elite-netflix/">
            Elite
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="381"><a href="/tv-film/sex-education/">
            Sex Education
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="401"><a href="/tv-film/marvel/">
            Marvel
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="431"><a href="/tv-film/after/">
            After
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="438"><a href="/tv-film/euphoria/">
            Euphoria
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="441"><a href="/tv-film/bridgerton/">
            Bridgerton
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="371"><a href="/tv-film/the-umbrella-academy/">
            The Umbrella Academy
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="406"><a href="/tv-film/netflix-you/">
            You
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="417"><a href="/tv-film/outer-banks/">
            Outer Banks
        </a></li>

                                
                            
                                
                                <li class="contextual-nav__nav__item contextual-nav__nav__contextual-parent">
                                    <a href="/">
                                        
                                            More PopBuzz
                                        
                                    </a>
                                </li>
                                
                            </ul>
                        </nav>
                    
                </div>
            </div>
        
    </div>

    <!-- BLOCK:4 MOBILE NOW PLAYING -->
    
</header>

        

        <script src="/dynamic/userContent.js"></script>

         <!-- NIELSEN (needs to be executed after userContent.js) -->
        
            <!-- START Nielsen interchange script -->
<script type="text/javascript">
if(gusto.sourcepoint.enabled) {
    window.gusto.nielsen = {
        userId: null,
        segments: "",
        callbacks: [],
        init: function() {
            var isNielsenOn = gusto.sourcepoint.checkIabVendorConsentById(gusto.sourcepoint.iabIds.vendors.nielsen) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectPersonalisedContent) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectPersonalisedAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectBasicAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.createPersonalisedAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.createPersonalisedContent) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.measureAdPerformance) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.measureContentPerformance) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.applyMarketResearch) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.developImproveProducts) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.accessInformationOnDevice);

            if (!window.gusto.sourcepoint.gdprApplies || isNielsenOn) {
                if (window.localStorage) {
                    window.gusto.nielsen.userId = window.localStorage.getItem('nmcUserId') || null;
                    window.gusto.nielsen.segments = window.localStorage.getItem('nmcSegments') || "";
                }
                //Fires GTM Tags
                dataLayer.push({
                    'event': 'nielsen_gtm_fire',
                });
            } else {
                window.gusto.nielsen.userId = null;
                window.gusto.nielsen.segments = "";
                if (window.localStorage) {
                    window.localStorage.removeItem('nmcUserId');
                    window.localStorage.removeItem('nmcSegments'); 
                }
            }
        },
        receive: function(data) {
            if (data.user) {
                window.gusto.nielsen.userId = data.user.uid;
                window.gusto.nielsen.segments = data.user.segments.split(',').slice(0, 200).join(',');
            }
            for(var index=0; index < window.gusto.nielsen.callbacks.length; index++) {
                var callback = window.gusto.nielsen.callbacks[index];
                callback.call();
            }
            if (window.localStorage) {
                window.localStorage.setItem('nmcUserId', window.gusto.nielsen.userId);
                window.localStorage.setItem('nmcSegments', window.gusto.nielsen.segments);
            }
            window.WaitForIt.trigger('nielsen_data_ready');
        }
    };          
} else {
    window.gusto.nielsen = {
        userId: null,
        segments: "",
        callbacks: [],
        init: function() {
            if (window.localStorage) {
                window.gusto.nielsen.userId = window.localStorage.getItem('nmcUserId') || null;
                window.gusto.nielsen.segments = window.localStorage.getItem('nmcSegments') || "";
            }
        },
        receive: function(data) {
            if (data.user) {
                window.gusto.nielsen.userId = data.user.uid;
                window.gusto.nielsen.segments = data.user.segments.split(',').slice(0, 200).join(',');
            }
            for(var index=0; index < window.gusto.nielsen.callbacks.length; index++) {
                var callback = window.gusto.nielsen.callbacks[index];
                callback.call();
            }
            if (window.localStorage) {
                window.localStorage.setItem('nmcUserId', window.gusto.nielsen.userId);
                window.localStorage.setItem('nmcSegments', window.gusto.nielsen.segments);
            }
            window.WaitForIt.trigger('nielsen_data_ready');
        }
    };
    window.gusto.nielsen.init();
}
</script>
<!-- END Nielsen interchange script -->

        
        
        <section role="main">
            
            
                <div class="dac__banner__wrapper">
                    
    
        <div id="ad-banner" class="dac__banner">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['banner'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'banner');
                            }
                            
                                
                                    var valid_breakpoint = true;
                                    if(gusto.breakpoints) {
                                        valid_breakpoint = gusto.breakpoints.check('large-up');
                                    }
                                    if(valid_breakpoint) {
                                        window.GLOBALADVERTISING.push('banner', ad_mapping, false);
                                    }
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for banner');
                    }
                })();
            </script>
        </div>
    


                </div>
            
            
<div class="row row21">

    
        <div class="level2_wrapper">
            
                <div class="

cardset
level2




">

    

    

        
            

<article id="cadmus-article_17194" class="editorial cadmus full article cadmus-article">
    <script type="application/ld+json">
        {"articleBody": "Sexy Beasts is coming to Netflix in July. Are you tired of seeing the same conventionally hot people on the likes of Love Island and Too Hot To Handle? Well, Netflix have the show for you. The streaming platform have just dropped the trailer for their new dating show Sexy Beasts and it&#x27;s the stuff of nightmares.Basically, the premise of the show is that the daters choose each other based on personality rather than looks. It sounds simple enough, however, each dater is dressed in some horrifying prosthetics. Think the Masked Singer meets First Dates. The six part series, which is narrated by comedian and\u00a0Catastrophe\u00a0actor Rob Delaney, is actually a reboot of a 2014 BBC Three programme of the same name and is supposed to take away the superficial element of dating.In the trailer, we see a number of contestants go on blind dates while wearing some incredibly terrifying disguises. The daters attempt to get to know each other while casually dressed as some truly bizarre creatures. A man dressed as beaver mask even says: &quot;Ass first, personality second.&quot; Honestly, it&#x27;s cursed.READ MORE: Every Netflix show cancelled or ending in 2021 (so far) As you can imagine, the internet is both obsessed and horrified by the show already. Good news! You won&#x27;t have to wait long to see the chaos of Sexy Beasts. The show\u00a0is coming to Netflix on July 21. ", "description": "Sexy Beasts is coming to Netflix in July.", "creator": [{"@type": "Person", "name": "Jazmin Duribe"}], "image": {"url": "https://images.popbuzz.com/images/246497?width=700&crop=16_9&signature=P4xm3WCfka7dhPwv10zmoP9QLtg=", "width": 700, "@type": "ImageObject", "height": 394}, "datePublished": "2021-06-24T11:30:02+01:00", "publisher": {"logo": {"url": "", "@type": "ImageObject"}, "@type": "Organization", "name": "PopBuzz"}, "author": [{"@type": "Person", "name": "Jazmin Duribe"}], "headline": "Netflix's new dating show Sexy Beasts is giving the internet nightmares", "dateModified": "2021-06-24T11:30:13+01:00", "mainEntityOfPage": {"@id": "https://www.popbuzz.com/tv-film/news/sexy-beasts-netflix-dating-show-trailer/", "@type": "WebPage"}, "@context": "http://schema.org", "@type": "Article"}
    </script>

    
        <script>
            var gusto = window.gusto || {};
            gusto.article = {
                'title': 'Netflix&#39;s new dating show Sexy Beasts is giving the internet nightmares',
                'publish_epoch': '1624530602',
                'slug': 'sexy-beasts-netflix-dating-show-trailer',
                'author': 'Jazmin Duribe',
                'category': 'News'
            };
            gusto.related_content = [{"absolute_url": "http://www.popbuzz.com/tv-film/news/netflix-the-oa-stranger-things-sequel/", "id": "6236", "title": "Is Netflix's New Show Actually A \"Stranger Things\" Sequel?!"}, {"absolute_url": "http://www.popbuzz.com/tv-film/stranger-things/gaten-matarazzo-prank-show-netflix-new/", "id": "12888", "title": "Netflix's new prank show with Stranger Things' Gaten Matarazzo is getting backlash"}, {"absolute_url": "http://www.popbuzz.com/tv-film/news/netflix-flinch-torture-viewer-reactions/", "id": "12622", "title": "Netflix's new \"torture\" game show Flinch is dividing viewers"}];
        </script>
    
     
    <h1>Netflix&#39;s new dating show Sexy Beasts is giving the internet nightmares</h1>
    
    
        <p class="publish_date">24 June 2021, 11:30</p>
    

    <div style="position:relative;padding-top:56.25%; margin-bottom:10px;">
<video-js id="bc_player_6260651668001" data-video-id="6260651668001" data-account="6057949401001" data-player="default" data-embed="default" class="video-js" style="position:absolute;top:0;left:0;width:100%;height:100%;" controls="controls"></video-js>
</div>
<script>
    (function () {
            window.WaitForIt.wait_for(['nielsen_data_ready', 'sourcepoint_data_ready'], function() {
                var player = bc('bc_player_6260651668001');
                
                if (window.gusto.ad_switch.enable_ads_preroll === true) {
                    var isPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(
                            gusto.sourcepoint.nonIabIds.vendors.googleAdManager
                        ),
                        bc_tag_url = 'https://pubads.g.doubleclick.net/gampad/ads?iu=/21824617191/popbuzz/video/brightcove_player&description_url={window.location.href}&tfcd=0&npa=1&sz=400x300%7C640x480&cmsid=2527446&vid={mediainfo.id}&ad_rule=1&gdfp_req=1&output=xml_vast&unviewed_position_start=1&env=vp&impl=s&correlator={random}';

                    // npa means non-personalised ads
                    if (isPersonalisedAds) {
                        bc_tag_url = bc_tag_url.replace('npa=1', 'npa=0');
                    }

                    if (window.GLOBALADVERTISING) {
                        bc_tag_url +=
                            '&cust_params=' +
                            encodeURIComponent('kvplayer=' + 'brightcove') +
                            encodeURIComponent(
                                '&pageid=' + window.GLOBALADVERTISING.pageid
                            ) +
                            encodeURIComponent('&local=' + window.GLOBALADVERTISING.local) +
                            encodeURIComponent(
                                '&adtest=' + window.GLOBALADVERTISING.adtest
                            ) +
                            encodeURIComponent('&section=' + gusto.CATEGORY_PATH) +
                            encodeURIComponent('&at=' + window.GLOBALADVERTISING.at) +
                            encodeURIComponent(
                                '&sensitive=' + window.GLOBALADVERTISING.sensitive
                            ) +
                            encodeURIComponent('&gdpr=' + window.GLOBALADVERTISING.gdpr) +
                            encodeURIComponent(
                                '&gdpr_pd=' + window.GLOBALADVERTISING.gdpr_pd
                            ) +
                            encodeURIComponent(
                                '&gdpr_consent=' + window.GLOBALADVERTISING.gdpr_consent
                            ) +
                            encodeURIComponent('&nmc=' + gusto.nielsen.segments);
                    }

                    player.ima3({
                        serverUrl: bc_tag_url,
                        requestMode: "onplay",
                    });
                }
            }, 10000);
    })();
</script>
<div class="author-details author-details--has-avatar">
<img class="author-details__avatar" src="https://images.popbuzz.com/images/22393?crop=1_1&amp;width=200&amp;signature=yRrIbhZWfKVFjSn687blRMJ24jM=" alt="Jazmin Duribe" />
<p class="author-details__author">
        By Jazmin Duribe
    </p>
<a class="author-details__twitter_handle" href="https://twitter.com/jazminduribe" target="_blank" title="Follow Jazmin Duribe on Twitter" rel="author">
@jazminduribe</a>
</div>
<div class="social-share">
<a href="https://www.facebook.com/dialog/share?href=www.popbuzz.com%2Ftv-film%2Fnews%2Fsexy-beasts-netflix-dating-show-trailer%2F&amp;app_id=1590232324531551" target="_blank" onclick="gusto.tracking.social('facebook', 'share')">
<img alt="Facebook share" src="/assets_v4r/gusto/img/facebook-share.png" />
</a>
<a href="https://twitter.com/intent/tweet?url=www.popbuzz.com%2Ftv-film%2Fnews%2Fsexy-beasts-netflix-dating-show-trailer%2F&amp;text=Netflix%27s+new+dating+show+Sexy+Beasts+is+giving+the+internet+nightmares+%40popbuzz" target="_blank" onclick="gusto.tracking.social('twitter', 'share')">
<img alt="Twitter share" src="/assets_v4r/gusto/img/twitter-share.png" />
</a>
</div>
<p class="standfirst">Sexy Beasts is coming to Netflix in July.</p>
<p>Are you tired of seeing the same conventionally hot people on the likes of <a href="https://www.popbuzz.com/tv-film/love-island/" rel="noopener" target="_blank"><em>Love Island</em></a> and<em> </em><a href="https://www.popbuzz.com/tv-film/news/too-hot-to-handle-season-2-episodes-5-10-release-time/" rel="noopener" target="_blank"><em>Too Hot To Handle</em></a>? Well, <a href="https://www.popbuzz.com/tv-film/netflix/" rel="noopener" target="_blank">Netflix</a> have the show for you. The streaming platform have just dropped the trailer for their new dating show <em>Sexy Beasts</em> and it&#x27;s the stuff of nightmares.</p><div id="Teads_ad1"></div><p>Basically, the premise of the show is that the daters choose each other based on personality rather than looks. It sounds simple enough, however, each dater is dressed in some horrifying prosthetics. Think the <em>Masked Singer</em> meets <em>First Dates</em>. The six part series, which is narrated by comedian and <em>Catastrophe</em> actor Rob Delaney, is actually a reboot of a 2014 BBC Three programme of the same name and is supposed to take away the superficial element of dating.</p><p>In the trailer, we see a number of contestants go on blind dates while wearing some incredibly terrifying disguises. The daters attempt to get to know each other while casually dressed as some truly bizarre creatures. A man dressed as beaver mask even says: &quot;Ass first, personality second.&quot; Honestly, it&#x27;s cursed.</p><p><strong>READ MORE:</strong> <a href="https://www.popbuzz.com/tv-film/features/netflix-cancelled-shows-2021/" rel="noopener" target="_blank">Every Netflix show cancelled or ending in 2021 (so far)</a></p><div class="adyoulike-article"></div>
<figure>
<img alt="Netflix's new dating show Sexy Beasts" class="content-image" data-image-catalogue-id="246497" width="660" height="370" loading="lazy" src="https://images.popbuzz.com/images/246497?crop=16_9&amp;width=660&amp;relax=1&amp;signature=uMUJuBQ-_D_z9QI5R07v11tQOl8=" srcset="
            https://images.popbuzz.com/images/246497?crop=16_9&amp;width=375&amp;relax=1&amp;signature=F3XdA4zf76JsBPadgwIIzqI7_D8= 375w,
            https://images.popbuzz.com/images/246497?crop=16_9&amp;width=420&amp;relax=1&amp;signature=kBtmiqZ64jaCfgSwS9CTlAT_7DQ= 420w,
            https://images.popbuzz.com/images/246497?crop=16_9&amp;width=660&amp;relax=1&amp;signature=uMUJuBQ-_D_z9QI5R07v11tQOl8= 660w" sizes="
            (max-width: 375px) 375px,
            (max-width: 420px) 420px,
            660px" />
<figcaption>
    Netflix&#39;s new dating show Sexy Beasts.
    <span class="attribution">
        Picture: 
Netflix


    </span>
</figcaption>
</figure>
<h2>As you can imagine, the internet is both obsessed and horrified by the show already.</h2>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet" data-conversation="none"><p lang="en" dir="ltr">Am I on drugs <a href="https://t.co/W0yjxu8WTn">pic.twitter.com/W0yjxu8WTn</a></p>&mdash; Sibley The Best (@Goldfishwars) <a href="https://twitter.com/Goldfishwars/status/1407673765530673154?ref_src=twsrc%5Etfw">June 23, 2021</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">this is like love is blind but with my sleep paralysis demons <a href="https://t.co/htwt313xCB">https://t.co/htwt313xCB</a></p>&mdash; anna⁷ (@reofba) <a href="https://twitter.com/reofba/status/1407705496157667329?ref_src=twsrc%5Etfw">June 23, 2021</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">This is so infuriatingly up my alley <a href="https://t.co/tqZUkrmBcc">https://t.co/tqZUkrmBcc</a></p>&mdash; Aviv Or 🇪🇺 (@AvivOr) <a href="https://twitter.com/AvivOr/status/1407687580817166337?ref_src=twsrc%5Etfw">June 23, 2021</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet" data-conversation="none"><p lang="und" dir="ltr"> <a href="https://t.co/QuLeJL6IMJ">pic.twitter.com/QuLeJL6IMJ</a></p>&mdash; 𝐌𝐚𝐭𝐢𝐤 (@matik_guy) <a href="https://twitter.com/matik_guy/status/1407676483255083014?ref_src=twsrc%5Etfw">June 23, 2021</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet" data-conversation="none"><p lang="und" dir="ltr"> <a href="https://t.co/NyTBOHkbHK">pic.twitter.com/NyTBOHkbHK</a></p>&mdash; Dayzee Hyena (@DayzeeHyena) <a href="https://twitter.com/DayzeeHyena/status/1407711388940832771?ref_src=twsrc%5Etfw">June 23, 2021</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class="responsive_block_parent">
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Hey guys excited to announce that I&#39;ll be featuring in Netflix&#39;s Sexy Beasts. Keep an eye out for me! <a href="https://t.co/N7KTNU1A11">pic.twitter.com/N7KTNU1A11</a></p>&mdash; Seán Ó Baoill (@SeanOhBoyle) <a href="https://twitter.com/SeanOhBoyle/status/1407699047666884609?ref_src=twsrc%5Etfw">June 23, 2021</a></blockquote>
<script async="async" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<p>Good news! You won&#x27;t have to wait long to see the chaos of <em>Sexy Beasts. </em>The show is coming to Netflix on July 21. </p>
    
        
    
        <div id="ad-instream" class="dac__instream">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['instream'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'instream');
                            }
                            
                                
                                    window.GLOBALADVERTISING.push('instream', ad_mapping, false);
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for instream');
                    }
                })();
            </script>
        </div>
    


    

    
        <div id="ultimedia_wrapper"></div>

    

    

</article>

        
        
    
</div>

            
        </div>
    
        <div class="level1_wrapper">
            
                <div class="

cardset
level1




">

    

    

        
            

    <div class="dac__mpu-card">
    
        <div id="ad-mpu-desktop" class="dac__mpu-desktop">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['mpu-desktop'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'mpu-desktop');
                            }
                            
                                
                                    var valid_breakpoint = true;
                                    if(gusto.breakpoints) {
                                        valid_breakpoint = gusto.breakpoints.check('large-up');
                                    }
                                    if(valid_breakpoint) {
                                        window.GLOBALADVERTISING.push('mpu-desktop', ad_mapping, false);
                                    }
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for mpu-desktop');
                    }
                })();
            </script>
        </div>
    

</div>


        
        
    
</div>

            
                <div class="

cardset
level1


seemore

">

    
        <h2 class="cardset__title cardset__title--seemore">
            
                <a aria-label="Latest TV &amp; Film" href="/tv-film/news/">Latest TV &amp; Film</a>
            
        </h2>
        
            <p class="seemore"><a rel="nofollow" aria-label="More Latest TV &amp; Film" href="/tv-film/news/">See more<span> Latest TV &amp; Film</span></a></p>
        
    

    

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/internet/tiktok/peter-vigilante-onlyfans-too-hot-to-handle/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/246148?width=105&amp;crop=1_1&amp;signature=_huH-pLIvgdEYrctGLbzs_wG2rU="
    width="105"
    height="105"
    alt="What is Peter Vigilante&#39;s TikTok username? Too Hot To Handle star posts thirst traps"
    srcset="https://images.popbuzz.com/images/246148?width=105&amp;crop=1_1&amp;signature=_huH-pLIvgdEYrctGLbzs_wG2rU= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Too Hot To Handle: Peter Vigilante's TikTok is one</span><span class="truncated"> massive thirst trap</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/internet/tiktok/peter-vigilante-onlyfans-too-hot-to-handle/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/internet/tiktok/">TikTok</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/elite-netflix/season-5-cast-leaving-season-4-new-characters/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/245327?width=105&amp;crop=1_1&amp;signature=GJo8-wcJPdCW0Ooe73pG-IhE85I="
    width="105"
    height="105"
    alt="Elite season 5 cast: Who is leaving Elite after season 4 and who is joining?"
    srcset="https://images.popbuzz.com/images/245327?width=105&amp;crop=1_1&amp;signature=GJo8-wcJPdCW0Ooe73pG-IhE85I= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Elite season 5 cast: Who is leaving Elite after season 4</span><span class="truncated"> and who is joining?</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/elite-netflix/season-5-cast-leaving-season-4-new-characters/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/tv-film/elite-netflix/">Elite</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/elite-netflix/season-5-release-date-cast-trailer-news/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/222040?width=105&amp;crop=1_1&amp;signature=df_oigLw9MF61X3Fst0anGNtB-I="
    width="105"
    height="105"
    alt="Elite season 5: Release date, cast, spoilers and news about the Netflix series"
    srcset="https://images.popbuzz.com/images/222040?width=105&amp;crop=1_1&amp;signature=df_oigLw9MF61X3Fst0anGNtB-I= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Elite season 5: Release date, cast, spoilers and news</span><span class="truncated"> about the Netflix series</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/elite-netflix/season-5-release-date-cast-trailer-news/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/tv-film/elite-netflix/">Elite</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/elite-netflix/season-5-unanswered-questions-season-4/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/246390?width=105&amp;crop=1_1&amp;signature=AYCLfclXNyCmLhOb6Qp3TlpEQX8="
    width="105"
    height="105"
    alt="Elite season 5: All the questions from season 4 that need answers"
    srcset="https://images.popbuzz.com/images/246390?width=105&amp;crop=1_1&amp;signature=AYCLfclXNyCmLhOb6Qp3TlpEQX8= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Elite season 5: All the questions from season 4 that need</span><span class="truncated"> answers</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/elite-netflix/season-5-unanswered-questions-season-4/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/tv-film/elite-netflix/">Elite</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/news/loki-bisexual-marvel-mcu-confirmed/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/246329?width=105&amp;crop=1_1&amp;signature=-GoPb7Ke9-PlI5hr63Xb8s-lamk="
    width="105"
    height="105"
    alt="Marvel confirms Loki is bisexual in episode 3 of Disney+ series"
    srcset="https://images.popbuzz.com/images/246329?width=105&amp;crop=1_1&amp;signature=-GoPb7Ke9-PlI5hr63Xb8s-lamk= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Marvel confirms Loki is bisexual in episode 3 of Disney</span><span class="truncated">+ series</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/news/loki-bisexual-marvel-mcu-confirmed/"></a>
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
        
    
</div>

            
                <div class="

cardset
level1




">

    
        <h2 class="cardset__title ">
            
                <span>Trending on PopBuzz</span>
            
        </h2>
        
    

    

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/internet/viral/spotify-picture-trend-tiktok-instagram/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/246372?width=105&amp;crop=1_1&amp;signature=LnJOFEBsI7WxrMQwhMXqhPMAgyg="
    width="105"
    height="105"
    alt="How to do the Spotify picture trend on TikTok"
    srcset="https://images.popbuzz.com/images/246372?width=105&amp;crop=1_1&amp;signature=LnJOFEBsI7WxrMQwhMXqhPMAgyg= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3>
        
            
            How to do the Spotify picture trend on TikTok
            
        
        </h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/internet/viral/spotify-picture-trend-tiktok-instagram/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/internet/viral/">Viral</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/news/too-hot-to-handle-season-2-episodes-5-10-release-time/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/246330?width=105&amp;crop=1_1&amp;signature=owrXdvAPfpuWoboIS-U4c7gMaFU="
    width="105"
    height="105"
    alt="What time does Too Hot To Handle Season 2 come out on Netflix?"
    srcset="https://images.popbuzz.com/images/246330?width=105&amp;crop=1_1&amp;signature=owrXdvAPfpuWoboIS-U4c7gMaFU= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Too Hot To Handle season 2 release time: Here's when</span><span class="truncated"> episodes 5-10 come out on Netflix</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/news/too-hot-to-handle-season-2-episodes-5-10-release-time/"></a>
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/rupauls-drag-race/kita-mean-art-simone-interview/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/246306?width=105&amp;crop=1_1&amp;signature=ca6E69OGn0TfMWubL1Af_vPLyr0="
    width="105"
    height="105"
    alt="Drag Race Down Under Kita Mean"
    srcset="https://images.popbuzz.com/images/246306?width=105&amp;crop=1_1&amp;signature=ca6E69OGn0TfMWubL1Af_vPLyr0= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Drag Race Down Under’s Kita Mean defends RuPaul's shock</span><span class="truncated"> decision bring Art Simone back</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/rupauls-drag-race/kita-mean-art-simone-interview/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/tv-film/rupauls-drag-race/">RuPaul&#39;s Drag Race</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/music/artists/olivia-rodrigo/news/brutal-sour-single-prom-promposals-video/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/246259?width=105&amp;crop=1_1&amp;signature=_pY4MhhhQjKhr7Octik7YgwgbVk="
    width="105"
    height="105"
    alt="Olivia Rodrigo fans think her promposals prove Brutal is the next Sour single"
    srcset="https://images.popbuzz.com/images/246259?width=105&amp;crop=1_1&amp;signature=_pY4MhhhQjKhr7Octik7YgwgbVk= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Olivia Rodrigo fans think her Brutal fan promposals hint</span><span class="truncated"> at next Sour single</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/music/artists/olivia-rodrigo/news/brutal-sour-single-prom-promposals-video/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/music/artists/olivia-rodrigo/">Olivia Rodrigo</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/internet/youtubers/shane-dawson-ryland-adams-baby-video/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/246235?width=105&amp;crop=1_1&amp;signature=qih6h2cKebQ8AIB1ZKmYDT7y78Q="
    width="105"
    height="105"
    alt="Shane Dawson and Ryland Adams are working on having a baby together."
    srcset="https://images.popbuzz.com/images/246235?width=105&amp;crop=1_1&amp;signature=qih6h2cKebQ8AIB1ZKmYDT7y78Q= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3>
        
            
            Shane Dawson and Ryland Adams are working on having a baby
            
        
        </h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/internet/youtubers/shane-dawson-ryland-adams-baby-video/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/internet/youtubers/">YouTubers</a></p>


        </div>
    </div>
</div>

        
        
    
</div>

            
                <div class="

cardset
level1




">

    
        <h2 class="cardset__title ">
            
                <span>More TV &amp; Film</span>
            
        </h2>
        
    

    

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/the-umbrella-academy/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2019/03/the-umbrella-academy-logo-1548338060-editorial-short-form-0.jpg" alt="The Umbrella Academy" />
            
        </div>
        
            
        
        <h3>
            
                The Umbrella Academy
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/stranger-things/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2016/30/stranger-things-1469531493-editorial-short-form-0.png" alt="Stranger Things" />
            
        </div>
        
            
        
        <h3>
            
                Stranger Things
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/american-horror-story/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2018/41/american-horror-story-apocalypse-1539875977-editorial-short-form-0.png" alt="American Horror Story" />
            
        </div>
        
            
        
        <h3>
            
                American Horror Story
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/netflix-you/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2019/51/penn-badgley-as-joe-goldberg-in-netflixs-you-1577133905-editorial-short-form-0.jpg" alt="You" />
            
        </div>
        
            
        
        <h3>
            
                You
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/sex-education/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2019/01/otis---asa-butterfield---sex-education-neflix-1547203161-editorial-short-form-0.png" alt="Sex Education" />
            
        </div>
        
            
        
        <h3>
            
                Sex Education
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2018/41/rupauls-drag-race-1539874808-editorial-short-form-0.jpg" alt="RuPaul&#39;s Drag Race" />
            
        </div>
        
            
        
        <h3>
            
                RuPaul&#39;s Drag Race
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/on-my-block/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2018/12/netflix-on-my-block-season-2--1522164988-editorial-short-form-0.jpg" alt="On My Block" />
            
        </div>
        
            
        
        <h3>
            
                On My Block
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/riverdale/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2017/29/betty-riverdale--1500461450-editorial-short-form-0.jpg" alt="Riverdale" />
            
        </div>
        
            
        
        <h3>
            
                Riverdale
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
        
    
</div>

            
        </div>
    

</div>


        </section>
        


<footer class="footer">
    <div class="footer__section footer-back-to-top">
        <a href="#" id="go_to_top" class="footer-back-to-top__link" onclick="backToTop(e)" title="Back to top">Back to top</a>
    </div>
    <script type="application/javascript">
        function backToTop(e) {
            e.preventDefault();
            window.scrollTo(0, 0);
        }
    </script>
    <div class="footer__section">
        <div class="grid-row">
            <div class="grid-row__col--3">
                
    <h3 class="footer__heading">Also on PopBuzz</h3>
    <ul class="footer-hot-links">
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/quizzes/cheugy-quiz/" class="footer-hot-links__link">Cheugy</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/bella-poarch/" class="footer-hot-links__link">Bella Poarch</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/olivia-rodrigo/" class="footer-hot-links__link">Olivia Rodrigo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/high-school-musical-the-series/" class="footer-hot-links__link">High School Music: The Musical: The Series</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/taylor-swift/" class="footer-hot-links__link">Taylor Swift</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/dispo-invite-how-to-find/" class="footer-hot-links__link">Dispo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/to-all-the-boys-ive-loved-before/3-release-date-cast-always-and-forever-lara-jean/" class="footer-hot-links__link">To All the Boys 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race" class="footer-hot-links__link">Drag Race UK</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/american-horror-story/" class="footer-hot-links__link">American Horror Story</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/euphoria/" class="footer-hot-links__link">Euphoria</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/chilling-adventures-of-sabrina/" class="footer-hot-links__link">Chilling Adventures of Sabrina</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/greys-anatomy/" class="footer-hot-links__link">Grey&#39;s Anatomy</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/top-nine-instagram-2019-app/" class="footer-hot-links__link">Instagram Top Nine</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/news/spotify-stats-top-artists-songs-most-played-how/" class="footer-hot-links__link">Spotify</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/timothee-chalamet/" class="footer-hot-links__link">Timothée Chalamet</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/tiktok/" class="footer-hot-links__link">TikTok</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/josephine-langford/" class="footer-hot-links__link">Josephine Langford</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/hero-fiennes-tiffin/" class="footer-hot-links__link">Hero Fiennes Tiffin</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/louis-partridge/" class="footer-hot-links__link">Louis Partridge</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/quizzes/" class="footer-hot-links__link">Quizzes</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/louis-partridge/" class="footer-hot-links__link">Louis Partridge</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/bella-poarch/" class="footer-hot-links__link">Bella Poarch</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/haunting-of-bly-manor/" class="footer-hot-links__link">The Haunting of Bly Manor</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/the-kissing-booth/" class="footer-hot-links__link">The Kissing Booth</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/best-memes-2020/" class="footer-hot-links__link">Memes</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/the-umbrella-academy/season-3-release-date-cast-trailer-netflix/" class="footer-hot-links__link">The Umbrella Academy 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/best-tiktok-songs-2020-popular/" class="footer-hot-links__link">TikTok Songs</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/lizzo/" class="footer-hot-links__link">Lizzo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/billie-eilish/" class="footer-hot-links__link">Billie Eilish</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/elite-netflix/season-4-release-date-cast-trailer-spoilers-news/" class="footer-hot-links__link">Elite season 4</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/on-my-block/" class="footer-hot-links__link">On My Block</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race/" class="footer-hot-links__link">RuPaul&#39;s Drag Race</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/snapchat/" class="footer-hot-links__link">Snapchat</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/stranger-things/stranger-things-season-4-release-date-cast-trailer/" class="footer-hot-links__link">Stranger Things 4</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/millie-bobby-brown/" class="footer-hot-links__link">Millie Bobby Brown</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/addison-rae/" class="footer-hot-links__link">Addison Rae</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/outer-banks/" class="footer-hot-links__link">Outer Banks</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/nick-robinson/" class="footer-hot-links__link">Nick Robinson</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/charli-damelio/" class="footer-hot-links__link">Charli D&#39;Amelio</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/harry-styles/" class="footer-hot-links__link">Harry Styles</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/sex-education/" class="footer-hot-links__link">Sex Education</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/features/doja-cat/" class="footer-hot-links__link">Doja Cat</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/bts/" class="footer-hot-links__link">BTS</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/to-all-the-boys-ive-loved-before/" class="footer-hot-links__link">To All The Boys I&#39;ve Loved Before</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/tv-film/netflix/" class="footer-hot-links__link">Netflix</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/twenty-one-pilots/" class="footer-hot-links__link">Twenty One Pilots</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/halsey/" class="footer-hot-links__link">Halsey</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/" class="footer-hot-links__link">New Music</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/panic-at-the-disco/" class="footer-hot-links__link">Panic! At The Disco</a>
            </li>
        
    </ul>


            </div>
        </div>
    </div>

    <div class="footer__section--shaded">
        <div class="grid-row">
            <div class="grid-row__col--1">
                <h3 class="footer__heading">Useful Links</h3>
                <ul class="footer-useful-links">
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/about-us/" target="_blank">About Us</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/contact-us/" target="_blank">Contact Us</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="https://global.com/cookies/" target="_blank">Cookies</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="https://global.com/privacy-policy/" target="_blank">Privacy</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/terms-conditions/" target="_blank">Terms &amp; Conditions</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/advertise/" target="_blank">Advertise</a>
                        
                    
                    </li>
                
                </ul>
            </div>

            <div class="grid-row__col--1">
                
                    <h3 class="footer__heading">Latest From Twitter</h3>
                    <ul class="twitter-tweets">
<p class="twitter-tweets__user">PopBuzz &dash; <a href="http://twitter.com/popbuzz/" class="twitter-tweets__link" target="_blank">@popbuzz</a></p>

    <li class="twitter-tweets__item">
    	<p class="twitter-tweets__tweet">Sending lots of love to Mark and his family🤍 <a href="https://twitter.com/markhoppus/status/1407822798190383109" class="twitter-tweets__link" target="_blank">twitter.com/markhoppus/sta…</a></p>
    </li>

</ul>

                
            </div>

            <div class="grid-row__col--1">
                <h3 class="footer__heading">Follow Us</h3>
                <div class="social-links__container">
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--twitter" 
                href="https://twitter.com/popbuzz" 
                title="Follow PopBuzz on Twitter" 
                target="_blank">Follow PopBuzz on Twitter</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--facebook" 
                href="https://www.facebook.com/popbuzz" 
                title="Follow PopBuzz on Facebook" 
                target="_blank">Follow PopBuzz on Facebook</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--instagram" 
                href="https://instagram.com/popbuzz" 
                title="Follow PopBuzz on Instagram" 
                target="_blank">Follow PopBuzz on Instagram</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--youtube" 
                href="https://www.youtube.com/user/popbuzz" 
                title="Follow PopBuzz on Youtube" 
                target="_blank">Follow PopBuzz on Youtube</a>
        </div>
    
 </div>
            </div>
        </div>
    </div>

    <div class="footer__section">
        <div class="grid-row" itemscope itemtype="http://schema.org/Organization">
            <div class="grid-row__col--3 footer-footnote-section">
                &copy; <span itemprop="legalName">Global</span> 2021
            </div>
            <div class="grid-row__col--3 footer-footnote-section footer-footnote-section--end" itemprop="address">
                30 Leicester Square, London, WC2H 7LA
            </div>
            
                <a class="footer__section__privacy_manager_button" id="privacy_manager__button" href="#">
                    Privacy Manager
                </a>
            
        </div>
    </div>
</footer>
<script>
    var privacy_manager__button = document.getElementById('privacy_manager__button');
    if(privacy_manager__button) {
        privacy_manager__button.onclick = function(e) {
            e.preventDefault();
            if (window._sp_) {
                window._sp_.loadPrivacyManagerModal(
                    "173688"
                );
            }
        };
    }
</script>


        
        


    
        
            <script src="/assets_v4r/dist/combined/js/page_a80bed.min.js" defer></script>
        
    



        <!-- Global DAC Execution -->
        
            <script>
    // Enable Google Ad Services
    function googleAdManagerInit() {
        var isNonPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(gusto.sourcepoint.nonIabIds.vendors.googleAdManager) ? 0 : 1;
        googletag.cmd.push(function() {
            googletag.pubads()
                .setTargeting("section", String(window.GLOBALADVERTISING.section))
                .setTargeting("pageid", String(window.GLOBALADVERTISING.pageid))
                .setTargeting("contenttype", String(window.GLOBALADVERTISING.contenttype))
                .setTargeting("gdpr_consent", String(window.GLOBALADVERTISING.gdpr_consent))
                .setTargeting("adtest", String(window.GLOBALADVERTISING.adtest))
                .setTargeting("level", String(window.GLOBALADVERTISING.level))
                .setTargeting("at", String(window.GLOBALADVERTISING.at))
                .setTargeting("loginstate", String(window.GLOBALADVERTISING.loginstate))
                .setTargeting("pagecount", String(window.GLOBALADVERTISING.pagecount))
                .setTargeting("newslink", window.GLOBALADVERTISING.newslink ? String(window.GLOBALADVERTISING.newslink) : '')
                .setTargeting("sensitive", String(window.GLOBALADVERTISING.sensitive))
                .setTargeting("takeover", String(Math.floor(Math.random()*6) + 1));
            if(window.gusto.nielsen.segments) {
                googletag.pubads().setTargeting("nmc", String(window.gusto.nielsen.segments.split(":")));
            }
            googletag.pubads().setTargeting("npa", String(isNonPersonalisedAds));
    
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.pubads().disableInitialLoad();
            googletag.enableServices();

            // events
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot.getSlotElementId() === 'ad-banner') {
                    window.WaitForIt.trigger('ad_banner_rendered');
                }
            });
                
            googletag.pubads().refresh();
        });
    }
</script>

        
    </body>
</html>
