

<!DOCTYPE html>
<!--[if lte IE 9]><html lang="en" class="lteIE9"><![endif]-->
<!--[if !IE]><!--><html lang="en"><!--<![endif]-->
    <head>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge">

        
        
            
                <link rel="preload" href="/assets_v4r/dist/combined/css/page_5bbdd7.min.css" as="style" />
            
                <link rel="preload" href="/assets_v4r/dist/combined/js/page_151299.min.js" as="script" />
            
                <link rel="preload" href="https://cf-images.eu-west-1.prod.boltdns.net/v1/static/6057949401001/5e475ae0-9071-45f4-afad-e4949401afab/8ea28463-7367-43ee-8412-79aaa1e46c6c/640x360/match/image.jpg" as="image" />
            
                <link rel="preload" href="https://images.popbuzz.com/images/250290?crop=16_9&amp;width=660&amp;relax=1&amp;signature=qLiO-J77xUYOnvYqIO2NahBs-fU=" as="image" />
            
                <link rel="preload" href="https://cf-images.eu-west-1.prod.boltdns.net/v1/jit/6057949401001/81fa91b5-8894-482b-9159-48ac6e0e9ca4/main/640x360/27s797ms/match/image.jpg" as="image" />
            
        
        
            <link rel="preload" href="/assets_v4r/dist/combined/fonts/chevrons.woff" as="font" type="font/woff" crossorigin/>
        

        
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-16x16.png" sizes="16x16" />
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-32x32.png" sizes="32x32" />
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-196x196.png" sizes="196x196" />
        <link rel="apple-touch-icon-precomposed" sizes="57x57" href="/assets_v4r/popbuzz/img/apple-touch-icon-57x57.png" />
        <link rel="apple-touch-icon-precomposed" sizes="60x60" href="/assets_v4r/popbuzz/img/apple-touch-icon-60x60.png" />
        <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/assets_v4r/popbuzz/img/apple-touch-icon-72x72.png" />
        <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/assets_v4r/popbuzz/img/apple-touch-icon-76x76.png" />
        <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/assets_v4r/popbuzz/img/apple-touch-icon-114x114.png" />
        <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/assets_v4r/popbuzz/img/apple-touch-icon-120x120.png" />
        <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/assets_v4r/popbuzz/img/apple-touch-icon-144x144.png" />
        <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/assets_v4r/popbuzz/img/apple-touch-icon-152x152.png" />

        
        <link rel="canonical" href="https://www.popbuzz.com/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/" />
        

        
        <link rel="amphtml" href="https://amp.popbuzz.com/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/" />
        

        <title>Never Have I Ever season 2: Does Devi choose Ben or Paxton? The ending explained - PopBuzz</title>

        <meta content="width=device-width, initial-scale=1.0" name="viewport" />

        <meta content="https://www.popbuzz.com/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/" name="parsely-link" />
<meta content="/tv-film/never-have-i-ever/" name="parsely-section" />
<meta content="Does Devi end up with Paxton or Ben? Never Have I Ever season 2 ending explained" name="parsely-title" />
<meta content="18289" name="parsely-post-id" />
<meta content="2021-07-15T17:48:48+01:00" name="parsely-pub-date" />
<meta content="https://images.popbuzz.com/images/250290?width=660&crop=16_9&signature=t3fggRDMqt_eQt-GvEGr-PFICEY=" name="parsely-image-url" />
<meta content="Sam  Prance" name="parsely-author" />
<meta content="https://www.popbuzz.com/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/" property="og:url" />
<meta content="PopBuzz" property="og:site_name" />
<meta content="www.popbuzz.com" property="og:domain" />
<meta content="article" property="og:type" />
<meta content="https://images.popbuzz.com/images/250290?width=660&crop=16_9&signature=t3fggRDMqt_eQt-GvEGr-PFICEY=" property="og:image" />
<meta content="371" property="og:image:height" />
<meta content="660" property="og:image:width" />
<meta content="Does Devi end up with Paxton or Ben? Never Have I Ever season 2 ending explained" property="og:title" />
<meta content="Who does Devi end up with in Never Have I Ever season 2?" property="og:description" />
<meta content="2021-07-15T17:48:48" name="pubdate" itemprop="datePublished" />
<meta content="2021-07-15T17:48:57" name="modified" itemprop="dateModified" />
<meta content="post" name="parsely-type" />
<meta content="season, ending, explained, explores, devi, end, relationships, ben, choose, paxton, radio, fm" name="keywords" />
<meta content="Who does Devi end up with in Never Have I Ever season 2?" name="description" />
<meta content="Sam  Prance" name="parsely-author" />
<meta content="@popbuzz" name="twitter:site" />
<meta content="https://www.popbuzz.com/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/" name="twitter:url" />
<meta content="summary_large_image" name="twitter:card" />
<meta content="https://images.popbuzz.com/images/250290?width=660&crop=16_9&signature=t3fggRDMqt_eQt-GvEGr-PFICEY=" name="twitter:image" />
<meta content="Does Devi end up with Paxton or Ben? Never Have I Ever season 2 ending explained" name="twitter:title" />
<meta content="Who does Devi end up with in Never Have I Ever season 2?" name="twitter:description" />
<meta content="tv-film, never-have-i-ever, season-2-devi-paxton-ben-ending-who" name="sailthru.tags" />
<meta content="2021-07-15 17:48:48+01:00" name="sailthru.date" />
<meta content="627792841,551351399,716836285,1547481361,837890453,661531116" property="fb:admins" />
<meta content="1590232324531551" property="fb:app_id" />
<meta content="1488952944702289" property="fb:page_id" />
<meta content="1488952944702289" property="fb:pages" />
        

        



	
		<link rel="stylesheet" href="/assets_v4r/dist/combined/css/page_5bbdd7.min.css" />
	




        <script>
            var gusto = window.gusto || {};
            gusto.MAIN_CONTENT_TYPE = "cadmus-article";
            gusto.ROOT_URL = "https://www.popbuzz.com";
            gusto.SITE_NAME = "PopBuzz";
            gusto.STATIC_URL = "/assets_v4r/";
            gusto.STATIC_BRAND_URL = "/assets_v4r/popbuzz/";
            gusto.CATEGORY_PATH = "/tv-film/never-have-i-ever/";
            gusto.PROJECT_NAME = "popbuzz";
            gusto.PLAYER_INFO = {"localise_url": "/localise/", "play_overlay": false, "player_url_ukrp": null, "is_localised": true, "twin_stations": null, "player_url": null, "global_player_enabled": false, "localisation_light_enabled": false, "localisations_enabled": false, "player_url_template": ""};
            gusto.DEBUG = false;
            gusto.SETTINGS = {
                'COOKIE_STATION_MAX_AGE_SECONDS': 63072000
            };
            gusto.ad_settings = {
                'banner_visibility_delay': 3000,
            };
            gusto.ad_switch = {
                'enable_ads_dac': true,
                'enable_ads_related': false,
                'enable_ads_ukrp': true,
                'enable_ads_preroll': true,
                'enable_ads_related_videos': true,

            };
            gusto.STATION = {
                'name': "PopBuzz",
                'slug': ""
            };
            gusto.breakpoints = {
                limits: {
                    'small': [0, 640],
                    'medium': [641, 1023],
                    'large': [1024, 1440],
                    'xlarge': [1441, 1920],
                    'xxlarge': [1921, 9001]
                },
                check: function(target) {
                    
                    var target_bits = target.split('-'),
                        brkpoint = target_bits[0],
                        dir = target_bits[1],
                        win = window.innerWidth,
                        ref = this.limits[brkpoint];
                    if (!ref) return false;
                    if (dir == 'up') return (win >= ref[0]);
                    else if (dir == 'down') return (win <= ref[1]);
                    else return (win >= ref[0] && win <= ref[1]);
                }
            };

            gusto.ABSOLUTE_URL = "/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/";
            gusto.station_twitter = 'popbuzz';
            gusto.FACEBOOK_APP_ID = '1590232324531551';
            gusto.category_tree = {"1": {"full_slug": "/", "name": "popbuzz.com", "parent": null, "children": [101, 70, 111, 72, 109, 106, 108, 110, 404, 418]}, "418": {"full_slug": "/index/", "name": "A-Z", "parent": 1}, "101": {"full_slug": "/news/", "name": "News", "parent": 1}, "70": {"full_slug": "/quizzes/", "name": "Quizzes", "parent": 1}, "231": {"full_slug": "/music/quizzes/", "name": "Quizzes", "parent": 72}, "72": {"full_slug": "/music/", "name": "Music", "parent": 1, "children": [105, 119, 239, 231, 102]}, "105": {"full_slug": "/music/artists/", "name": "Artists", "parent": 72}, "106": {"full_slug": "/internet/", "name": "Internet", "parent": 1}, "108": {"full_slug": "/life/", "name": "Life", "parent": 1}, "109": {"full_slug": "/tv-film/", "name": "TV & Film", "parent": 1}, "110": {"full_slug": "/style/", "name": "Style", "parent": 1, "children": [361, 362, 230]}, "111": {"full_slug": "/exclusives/", "name": "Video", "parent": 1}, "102": {"full_slug": "/music/playlists/", "name": "Playlists", "parent": 72}, "404": {"full_slug": "/celeb/", "name": "Celeb", "parent": 1}, "119": {"full_slug": "/music/news/", "name": "News", "parent": 72}, "239": {"full_slug": "/music/features/", "name": "Features", "parent": 72}, "361": {"full_slug": "/style/beauty/", "name": "Beauty", "parent": 110}, "362": {"full_slug": "/style/fashion/", "name": "Fashion", "parent": 110}, "230": {"full_slug": "/style/quizzes/", "name": "Quizzes", "parent": 110}};
            gusto.APP_INFO = {
                'android_download_url': "",
                'ios_download_url': "https://itunes.apple.com/gb/app/popbuzz/id1078206186?mt=8",
                'android_launch_url': ""
            };
            gusto.page_id = "18289";
            gusto.render_mode = "v4";
            gusto.lazy_ads = [];
            gusto.ooyala = {
                player_google_ad_tag: "https://pubads.g.doubleclick.net/gampad/ads?iu=/21824617191/",
                requireIsReady: false,
                ooyalaIsReady: false,
                initOoyalaVideos: function(){},
                // 
                initOoyalaPlayer: function () {
                    gusto.ooyala.ooyalaIsReady = true;
                    if (gusto.ooyala.requireIsReady) {
                        gusto.ooyala.initOoyalaVideos();
                    }
                }
            };
            gusto.udb_user = {
                'grid': null
            };
        </script>

        <!-- Promise Polyfill and WaitForIt race condition resolver -->
        <script src="/assets_v4r/dist/gusto/js/app/lib/promise-polyfill.js"></script>
        <script src="/assets_v4r/dist/gusto/js/app/lib/waitForIt.js"></script>

        <!-- Global DAC -->
        
            
<script>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</script>

        

        <!-- Global DAC Execution WITH SOURCEPOINT -->
        
            <script>
    // Enable Google Ad Services
    function googleAdManagerInit() {
        var isNonPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(gusto.sourcepoint.nonIabIds.vendors.googleAdManager) ? 0 : 1;
        googletag.cmd.push(function() {
            googletag.pubads()
                .setTargeting("section", String(window.GLOBALADVERTISING.section))
                .setTargeting("pageid", String(window.GLOBALADVERTISING.pageid))
                .setTargeting("contenttype", String(window.GLOBALADVERTISING.contenttype))
                .setTargeting("gdpr_consent", String(window.GLOBALADVERTISING.gdpr_consent))
                .setTargeting("adtest", String(window.GLOBALADVERTISING.adtest))
                .setTargeting("level", String(window.GLOBALADVERTISING.level))
                .setTargeting("at", String(window.GLOBALADVERTISING.at))
                .setTargeting("loginstate", String(window.GLOBALADVERTISING.loginstate))
                .setTargeting("pagecount", String(window.GLOBALADVERTISING.pagecount))
                .setTargeting("newslink", window.GLOBALADVERTISING.newslink ? String(window.GLOBALADVERTISING.newslink) : '')
                .setTargeting("sensitive", String(window.GLOBALADVERTISING.sensitive))
                .setTargeting("takeover", String(Math.floor(Math.random()*6) + 1));
            if(window.gusto.nielsen.segments) {
                googletag.pubads().setTargeting("nmc", String(window.gusto.nielsen.segments.split(":")));
            }
            googletag.pubads().setTargeting("npa", String(isNonPersonalisedAds));
    
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.pubads().disableInitialLoad();
            googletag.enableServices();

            // events
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot.getSlotElementId() === 'ad-banner') {
                    window.WaitForIt.trigger('ad_banner_rendered');
                }
            });
                
            googletag.pubads().refresh();
        });
    }
</script>

        
        
        <!-- SOURCEPOINT -->
        <script>
    gusto.sourcepoint = {
        'enabled': true,
        'gdprApplies': true,
        'baseEndpoint': "https://d.sourcepoint.popbuzz.com",
        'nonIabVendorConsents': [],
        'nonIabPurposeConsents': [],
        'iabVendorConsents': {},
        'iabPurposeConsents': {},

        'iabIds': {"vendors": {"googleAnalytics": 755, "nielsen": 373, "outbrain": 164, "adyoulike": 259, "remixd": 886, "digiteka": 343}, "purposes": {"accessInformationOnDevice": 1, "applyMarketResearch": 9, "measureAdPerformance": 7, "createPersonalisedAds": 3, "selectBasicAds": 2, "createPersonalisedContent": 5, "selectPersonalisedAds": 4, "selectPersonalisedContent": 6, "measureContentPerformance": 8, "developImproveProducts": 10}},
        'nonIabIds': {"vendors": {"gigya": "5e945f26b8e05c1c467daad8", "fbAudienceNetwork": "5ee91b9593fc094b59242e26", "parsely": "5efb47c3a86ed40d775a6693", "brightcove": "5ec796b4320b5a4efd764e0f", "googleAdManager": "5e74df5ff443bb795772df9c", "skimlinks": "5efb47d829507407f91c4d4e", "adobeAdvertising": "5ed7a9968c242d01c4a14072"}},

        'checkIabVendorConsentById': function (vendorId) {
            return this.iabVendorConsents[vendorId] == true;
        },

        'checkIabPurposeConsents': function (purposeId) {
            return this.iabPurposeConsents[purposeId] == true;
        },

        'checkNonIabVendorConsentById': function (vendorId) {
            for(var i=0; i<this.nonIabVendorConsents.length; i++) {
                if(this.nonIabVendorConsents[i]["_id"] === vendorId) {
                    return true;
                }
            }
            return false;
        },
    };
</script>

        
        <!-- Extra JS requested by cards (head) -->
        


        <!-- CMP -->
        
            <script type="text/javascript">
    !function () {
        var e = function () {
            var e, t = "__tcfapiLocator", a = [], n = window;
            for (; n;) {
                try {
                    if (n.frames[t]) {
                        e = n;
                        break
                    }
                } catch (e) {
                }
                if (n === window.top) break;
                n = n.parent
            }
            e || (!function e() {
                var a = n.document, r = !!n.frames[t];
                if (!r) if (a.body) {
                    var i = a.createElement("iframe");
                    i.style.cssText = "display:none", i.name = t, a.body.appendChild(i)
                } else setTimeout(e, 5);
                return !r
            }(), n.__tcfapi = function () {
                for (var e, t = arguments.length, n = new Array(t), r = 0; r < t; r++) n[r] = arguments[r];
                if (!n.length) return a;
                if ("setGdprApplies" === n[0]) n.length > 3 && 2 === parseInt(n[1], 10) && "boolean" == typeof n[3] && (e = n[3], "function" == typeof n[2] && n[2]("set", !0)); else if ("ping" === n[0]) {
                    var i = {gdprApplies: e, cmpLoaded: !1, cmpStatus: "stub"};
                    "function" == typeof n[2] && n[2](i)
                } else a.push(n)
            }, n.addEventListener("message", (function (e) {
                var t = "string" == typeof e.data, a = {};
                try {
                    a = t ? JSON.parse(e.data) : e.data
                } catch (e) {
                }
                var n = a.__tcfapiCall;
                n && window.__tcfapi(n.command, n.version, (function (a, r) {
                    var i = {__tcfapiReturn: {returnValue: a, success: r, callId: n.callId}};
                    t && (i = JSON.stringify(i)), e.source.postMessage(i, "*")
                }), n.parameter)
            }), !1))
        };
        "undefined" != typeof module ? module.exports = e : e()
    }();
</script>
<script type="text/javascript">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</script>
<script id="tcfV2Script"></script>
<script>
    document.getElementById('tcfV2Script').src = gusto.sourcepoint.baseEndpoint + '/wrapperMessagingWithoutDetection.js';
</script>

        

        <!-- Advertising -->
        
            <!-- DAC -->
            <script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
            <script>
                window.googletag = window.googletag || {cmd: []};
            </script>
        

        
            <link rel="stylesheet" type="text/css" href="https://players.brightcove.net/videojs-ima3/3/videojs.ima3.min.css" />
        
        
    </head>
    <body class="no-js">
        <!-- Extra Js requested by cards (body) -->
        
            <script src="https://players.brightcove.net/6057949401001/default_default/index.min.js"></script>
        
            <script src="https://players.brightcove.net/videojs-ima3/3/videojs.ima3.min.js"></script>
        

        


<!-- Google Tag Manager - Data Layer -->
<script>dataLayer = [{"render_mode": "v4", "brand": "popbuzz", "ad_tools": {"digiteka_mdtk": "02018156"}, "content_type": "cadmus-article", "page": {"category1": "tv film", "category3": "tv film/never have i ever/season 2 devi paxton ben ending who", "category2": "tv film/never have i ever", "contentType": "cadmus-article", "cleanUrl": "https://www.popbuzz.com/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/", "title": "Does Devi end up with Paxton or Ben? Never Have I Ever season 2 ending explained", "brand": "popbuzz", "path": "/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/", "platformType": "web"}, "full_path": "/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/"}];</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N7KJ77&render_mode=v4&brand=popbuzz&ad_tools=%7B%27digiteka_mdtk%27%3A+%2702018156%27%7D&content_type=cadmus-article&page=%7B%27category1%27%3A+u%27tv+film%27%2C+%27category3%27%3A+u%27tv+film%2Fnever+have+i+ever%2Fseason+2+devi+paxton+ben+ending+who%27%2C+%27category2%27%3A+u%27tv+film%2Fnever+have+i+ever%27%2C+%27contentType%27%3A+%27cadmus-article%27%2C+%27cleanUrl%27%3A+%27https%3A%2F%2Fwww.popbuzz.com%2Ftv-film%2Fnever-have-i-ever%2Fseason-2-devi-paxton-ben-ending-who%2F%27%2C+%27title%27%3A+u%27Does+Devi+end+up+with+Paxton+or+Ben%3F+Never+Have+I+Ever+season+2+ending+explained%27%2C+%27brand%27%3A+%27popbuzz%27%2C+%27path%27%3A+u%27%2Ftv-film%2Fnever-have-i-ever%2Fseason-2-devi-paxton-ben-ending-who%2F%27%2C+%27platformType%27%3A+%27web%27%7D&full_path=%2Ftv-film%2Fnever-have-i-ever%2Fseason-2-devi-paxton-ben-ending-who%2F"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N7KJ77');</script>
<!-- End Google Tag Manager -->



        <script type="text/javascript">document.body.className = document.body.className.replace('no-js', 'js');</script>

        <div id="fb-root"></div>
        
            
    
        <div id="ad-overlay" class="dac__overlay">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['overlay'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'overlay');
                            }
                            
                                
                                    window.GLOBALADVERTISING.push('overlay', ad_mapping, false);
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for overlay');
                    }
                })();
            </script>
        </div>
    


        
        
            


<header class="header header--with-contextual" id="header">

    <!-- BLOCK:0 USER STATUS HEADER -->
    <div class="header__section header__section--primary-bg header__user-status">
        <div class="header__container">
            <ul id="user_status" class="header-user-status"></ul>
        </div>
    </div>

    <!-- BLOCK:1 HEADER MAIN -->
    <div class="header__section header__main js-header-main">
        <div class="header__container">
            <a href="#primary" class="skip-nav js-skip-nav"><span>skip to navigation</span></a>
            


<p class="header__logo ">
    <a class="header__logo__link" href="/">PopBuzz</a>
</p>





        </div>
    </div>

    <!-- BLOCK:2 PRIMARY NAV -->
    <div class="header__section" id="nav_wrapper" >
        <nav id="primary" class="header__container standard">
            <ul>
                
                <li  class="nav-home "
                    
                     >

                    
                    <a href="/">Home</a>
                    
                </li>
                
                <li  class="nav-news "
                    
                    
                        data-id="101"
                     >

                    
                    <a href="/news/">News</a>
                    
                </li>
                
                <li  class="nav-quizzes "
                    
                    
                        data-id="70"
                     >

                    
                    <a href="/quizzes/">Quizzes</a>
                    
                </li>
                
                <li  class="nav-video "
                    
                    
                        data-id="111"
                     >

                    
                    <a href="/exclusives/">Video</a>
                    
                </li>
                
                <li  class="nav-music "
                    
                    
                        data-id="72"
                     >

                    
                    <a href="/music/">Music</a>
                    
                </li>
                
                <li  class="nav-tv-film "
                    
                    
                        data-id="109"
                     >

                    
                    <a href="/tv-film/">TV &amp; Film</a>
                    
                </li>
                
                <li  class="nav-internet "
                    
                    
                        data-id="106"
                     >

                    
                    <a href="/internet/">Internet</a>
                    
                </li>
                
                <li  class="nav-life "
                    
                    
                        data-id="108"
                     >

                    
                    <a href="/life/">Life</a>
                    
                </li>
                
                <li  class="nav-style "
                    
                    
                        data-id="110"
                     >

                    
                    <a href="/style/">Style</a>
                    
                </li>
                
                <li  class="nav-celeb "
                    
                    
                        data-id="404"
                     >

                    
                    <a href="/celeb/">Celeb</a>
                    
                </li>
                
                <li id="members_nav_link" class="nav-a-z "
                    
                    
                        data-id="418"
                     >

                    
                    <a href="/index/">A-Z</a>
                    
                </li>
                
                


    <li class="social-links util--hidden-on-desktop">
        <em class="social-links__label">Follow us on:</em>
        <div class="social-links__container">
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--twitter" 
                href="https://twitter.com/popbuzz" 
                title="Follow PopBuzz on Twitter" 
                target="_blank">Follow PopBuzz on Twitter</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--facebook" 
                href="https://www.facebook.com/popbuzz" 
                title="Follow PopBuzz on Facebook" 
                target="_blank">Follow PopBuzz on Facebook</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--instagram" 
                href="https://instagram.com/popbuzz" 
                title="Follow PopBuzz on Instagram" 
                target="_blank">Follow PopBuzz on Instagram</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--youtube" 
                href="https://www.youtube.com/user/popbuzz" 
                title="Follow PopBuzz on Youtube" 
                target="_blank">Follow PopBuzz on Youtube</a>
        </div>
    
 </div>
    </li>

            </ul>
        </nav>
    </div>

    <!-- BLOCK:3 TRENDING BAR/CONTEXT NAV -->
    <div class="header__section">
        
            <div class="contextual-nav__wrapper contextual-nav--pivot-available">
                <div class="contextual-nav js-contextual-nav">
                    

                    
                        
                        <p class="contextual-nav__header">
                        
                            TV &amp; Film
                            <a class="js-contextual-nav-toggle contextual-nav__nav-toggle" href="#" >
                                <span class="contextual-nav__nav-toggle__nav-button nav_button"></span>
                            </a>
                        
                        </p>
                        
                    

                    
                        <nav class="contextual-nav__nav">
                            <ul class="contextual-nav__nav__list">
                            
                                
                                    <li class="contextual-nav__nav__item" data-id=""><a href="/tv-film/">
            TV &amp; Film Home
        </a></li>

                                
                            
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="236"><a href="/tv-film/news/">
            News
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="227"><a href="/tv-film/quizzes/">
            Quizzes
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="317"><a href="/tv-film/american-horror-story/">
            American Horror Story
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="318"><a href="/tv-film/stranger-things/">
            Stranger Things
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="320"><a href="/tv-film/riverdale/">
            Riverdale
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="321"><a href="/tv-film/rupauls-drag-race/">
            RuPaul&#39;s Drag Race
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="357"><a href="/tv-film/elite-netflix/">
            Elite
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="381"><a href="/tv-film/sex-education/">
            Sex Education
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="401"><a href="/tv-film/marvel/">
            Marvel
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="431"><a href="/tv-film/after/">
            After
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="438"><a href="/tv-film/euphoria/">
            Euphoria
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="441"><a href="/tv-film/bridgerton/">
            Bridgerton
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="371"><a href="/tv-film/the-umbrella-academy/">
            The Umbrella Academy
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="406"><a href="/tv-film/netflix-you/">
            You
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="417"><a href="/tv-film/outer-banks/">
            Outer Banks
        </a></li>

                                
                            
                                
                                <li class="contextual-nav__nav__item contextual-nav__nav__contextual-parent">
                                    <a href="/">
                                        
                                            More PopBuzz
                                        
                                    </a>
                                </li>
                                
                            </ul>
                        </nav>
                    
                </div>
            </div>
        
    </div>

    <!-- BLOCK:4 MOBILE NOW PLAYING -->
    
</header>

        

        <script src="/dynamic/userContent.js"></script>

         <!-- NIELSEN (needs to be executed after userContent.js) -->
        
            <!-- START Nielsen interchange script -->
<script type="text/javascript">
if(gusto.sourcepoint.enabled) {
    window.gusto.nielsen = {
        userId: null,
        segments: "",
        callbacks: [],
        init: function() {
            var isNielsenOn = gusto.sourcepoint.checkIabVendorConsentById(gusto.sourcepoint.iabIds.vendors.nielsen) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectPersonalisedContent) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectPersonalisedAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectBasicAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.createPersonalisedAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.createPersonalisedContent) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.measureAdPerformance) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.measureContentPerformance) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.applyMarketResearch) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.developImproveProducts) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.accessInformationOnDevice);

            if (!window.gusto.sourcepoint.gdprApplies || isNielsenOn) {
                if (window.localStorage) {
                    window.gusto.nielsen.userId = window.localStorage.getItem('nmcUserId') || null;
                    window.gusto.nielsen.segments = window.localStorage.getItem('nmcSegments') || "";
                }
                //Fires GTM Tags
                dataLayer.push({
                    'event': 'nielsen_gtm_fire',
                });
            } else {
                window.gusto.nielsen.userId = null;
                window.gusto.nielsen.segments = "";
                if (window.localStorage) {
                    window.localStorage.removeItem('nmcUserId');
                    window.localStorage.removeItem('nmcSegments'); 
                }
            }
        },
        receive: function(data) {
            if (data.user) {
                window.gusto.nielsen.userId = data.user.uid;
                window.gusto.nielsen.segments = data.user.segments.split(',').slice(0, 200).join(',');
            }
            for(var index=0; index < window.gusto.nielsen.callbacks.length; index++) {
                var callback = window.gusto.nielsen.callbacks[index];
                callback.call();
            }
            if (window.localStorage) {
                window.localStorage.setItem('nmcUserId', window.gusto.nielsen.userId);
                window.localStorage.setItem('nmcSegments', window.gusto.nielsen.segments);
            }
            window.WaitForIt.trigger('nielsen_data_ready');
        }
    };          
} else {
    window.gusto.nielsen = {
        userId: null,
        segments: "",
        callbacks: [],
        init: function() {
            if (window.localStorage) {
                window.gusto.nielsen.userId = window.localStorage.getItem('nmcUserId') || null;
                window.gusto.nielsen.segments = window.localStorage.getItem('nmcSegments') || "";
            }
        },
        receive: function(data) {
            if (data.user) {
                window.gusto.nielsen.userId = data.user.uid;
                window.gusto.nielsen.segments = data.user.segments.split(',').slice(0, 200).join(',');
            }
            for(var index=0; index < window.gusto.nielsen.callbacks.length; index++) {
                var callback = window.gusto.nielsen.callbacks[index];
                callback.call();
            }
            if (window.localStorage) {
                window.localStorage.setItem('nmcUserId', window.gusto.nielsen.userId);
                window.localStorage.setItem('nmcSegments', window.gusto.nielsen.segments);
            }
            window.WaitForIt.trigger('nielsen_data_ready');
        }
    };
    window.gusto.nielsen.init();
}
</script>
<!-- END Nielsen interchange script -->

        
        
        <section role="main">
            
            
                <div class="dac__banner__wrapper">
                    
    
        <div id="ad-banner" class="dac__banner">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['banner'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'banner');
                            }
                            
                                
                                    var valid_breakpoint = true;
                                    if(gusto.breakpoints) {
                                        valid_breakpoint = gusto.breakpoints.check('large-up');
                                    }
                                    if(valid_breakpoint) {
                                        window.GLOBALADVERTISING.push('banner', ad_mapping, false);
                                    }
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for banner');
                    }
                })();
            </script>
        </div>
    


                </div>
            
            
<div class="row row21">

    
        <div class="level2_wrapper">
            
                <div class="

cardset
level2




">

    

    

        
            

<article id="cadmus-article_17297" class="editorial cadmus full article cadmus-article">
    <script type="application/ld+json">
        {"articleBody": "Never Have I Ever season 2 explores Devi&#39;s relationships with Paxton and Ben even further but who does she choose? Never Have I Ever season 2 is finally out on Netflix and this season we learn if Devi picks Paxton or Ben to be her boyfriend.The first season of Never Have I Ever introduces us to Devi (Maitreyi Ramakrishnan), a chaotic but loveable teenager who is hellbent on being normal and finding a boyfriend, as she processes the grief of losing her dad. At first, she has a crush on popular jock Paxton (Darren Barnet) but she also develops feelings for her academic rival Ben (Jaren Lewison).READ MORE: Never Have I Ever season 3: Release date, cast, plot and everything we know so farNever Have I Ever season 1 ends with Paxton realising that he&#x27;s in love with Devi but it also ends with Devi kissing Ben for the first time. Season 2 picks up right where we left off but there is a whole journey with the Devi, Paxton and Ben love triangle before we get to the ending. With that in mind, here&#x27;s your guide to who Devi ends up with.Who does Devi end up with in Never Have I Ever season 2? As soon as Never Have I Ever season 2 begins, we learn that Devi is completely confused as to who to pick between Paxton and Ben. As a result, she consults with her best friends, Fabiola and Eleanor. Devi confides in them that she has more of an emotional connection to Ben but obviously still fancies Paxton. The girls tell her to pick Paxton because he is so hot.However, Devi still can&#x27;t decide and, since she thinks that she is about to move to India with her family, she chooses to date them both without them each knowing. This is all comes to a head when Devi hosts a party and Ben and Paxton find out that she has been lying to them. They both break up with her, and Paxton storms into the street and is hit by a car.Paxton is fine. However, he&#x27;s unable to swim as usual due to injuries and has to focus on his academics to get into college. The school asks Devi to tutor him and she agrees out of guilt. In doing so, they start to form a friendship. Meanwhile, Ben begins dating a new girl, Aneesa, who joins the school and becomes friends with Devi and her crew. Paxton and Devi later start hooking up but Paxton doesn&#x27;t want anyone to know because he&#x27;s still so embarrassed by what Devi did to him. However, as the season ends, he realises that he&#x27;s in love with her and surprises her at the winter dance. The two slow dance happily.Ben spots them and says: &quot;You&#x27;ve got to be kidding me. Of course, it&#x27;s him. It&#x27;s always been him.&quot; Eleanor, who is next to him, then corrects him and lets slip that Devi originally wanted to be with him instead of Paxton and was jealous when he and Aneesa started dating.The season ends with Paxton and Devi becoming boyfriend and girlfriend. They kiss as Ben looks on bewildered. In other words, even though Devi and Paxton are together, it looks like Ben still has feelings for Devi and we doubt Devi&#x27;s have disappeared either.It looks like we&#x27;ll have to wait until season 3 to find out who Devi is actually endgame with.Are you team Ben or team Paxton?", "description": "Never Have I Ever season 2 explores Devi's relationships with Paxton and Ben even further but who does she choose?", "creator": [{"@type": "Person", "name": "Sam  Prance"}], "image": {"url": "https://images.popbuzz.com/images/250290?width=700&crop=16_9&signature=1fnKO9iY7v6fMmHCkpNjoHP50PM=", "width": 700, "@type": "ImageObject", "height": 394}, "datePublished": "2021-07-15T17:48:48+01:00", "publisher": {"logo": {"url": "", "@type": "ImageObject"}, "@type": "Organization", "name": "PopBuzz"}, "author": [{"@type": "Person", "name": "Sam  Prance"}], "headline": "Does Devi end up with Paxton or Ben? Never Have I Ever season 2 ending explained", "dateModified": "2021-07-15T17:50:36+01:00", "mainEntityOfPage": {"@id": "https://www.popbuzz.com/tv-film/never-have-i-ever/season-2-devi-paxton-ben-ending-who/", "@type": "WebPage"}, "@context": "http://schema.org", "@type": "Article"}
    </script>

    
        <script>
            var gusto = window.gusto || {};
            gusto.article = {
                'title': 'Does Devi end up with Paxton or Ben? Never Have I Ever season 2 ending explained',
                'publish_epoch': '1626367728',
                'slug': 'season-2-devi-paxton-ben-ending-who',
                'author': 'Sam  Prance',
                'category': 'Never Have I Ever'
            };
            gusto.related_content = [{"absolute_url": "http://www.popbuzz.com/tv-film/quizzes/who-is-your-never-have-i-ever-boyfriend-netflix/", "id": "15064", "title": "QUIZ: Would you end up with Paxton or Ben from Never Have I Ever?"}, {"absolute_url": "http://www.popbuzz.com/tv-film/news/never-have-i-ever-season-2-release-date-netflix/", "id": "15058", "title": "Never Have I Ever season 2: Release date, cast, spoilers and news"}, {"absolute_url": "http://www.popbuzz.com/tv-film/news/never-have-i-ever-season-2-release-time-when-netflix/", "id": "17293", "title": "Never Have I Ever season 2 release time: Here's when it comes out on Netflix in your country"}];
        </script>
    
     
    <h1>Does Devi end up with Paxton or Ben? Never Have I Ever season 2 ending explained</h1>
    
    
        <p class="publish_date">15 July 2021, 17:48</p>
    

    <div style="position:relative;padding-top:56.25%; margin-bottom:10px;">
<video-js id="bc_player_6259440399001" data-video-id="6259440399001" data-account="6057949401001" data-player="default" data-embed="default" class="video-js" style="position:absolute;top:0;left:0;width:100%;height:100%;" controls="controls"></video-js>
</div>
<script>
    (function () {
            window.WaitForIt.wait_for(['nielsen_data_ready', 'sourcepoint_data_ready'], function() {
                var player = bc('bc_player_6259440399001');
                
                if (window.gusto.ad_switch.enable_ads_preroll === true) {
                    var isPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(
                            gusto.sourcepoint.nonIabIds.vendors.googleAdManager
                        ),
                        bc_tag_url = 'https://pubads.g.doubleclick.net/gampad/ads?iu=/21824617191/popbuzz/video/brightcove_player&description_url={window.location.href}&tfcd=0&npa=1&sz=400x300%7C640x480&cmsid=2527446&vid={mediainfo.id}&ad_rule=1&gdfp_req=1&output=xml_vast&unviewed_position_start=1&env=vp&impl=s&correlator={random}';

                    // npa means non-personalised ads
                    if (isPersonalisedAds) {
                        bc_tag_url = bc_tag_url.replace('npa=1', 'npa=0');
                    }

                    if (window.GLOBALADVERTISING) {
                        bc_tag_url +=
                            '&cust_params=' +
                            encodeURIComponent('kvplayer=' + 'brightcove') +
                            encodeURIComponent(
                                '&pageid=' + window.GLOBALADVERTISING.pageid
                            ) +
                            encodeURIComponent('&local=' + window.GLOBALADVERTISING.local) +
                            encodeURIComponent(
                                '&adtest=' + window.GLOBALADVERTISING.adtest
                            ) +
                            encodeURIComponent('&section=' + gusto.CATEGORY_PATH) +
                            encodeURIComponent('&at=' + window.GLOBALADVERTISING.at) +
                            encodeURIComponent(
                                '&sensitive=' + window.GLOBALADVERTISING.sensitive
                            ) +
                            encodeURIComponent('&gdpr=' + window.GLOBALADVERTISING.gdpr) +
                            encodeURIComponent(
                                '&gdpr_pd=' + window.GLOBALADVERTISING.gdpr_pd
                            ) +
                            encodeURIComponent(
                                '&gdpr_consent=' + window.GLOBALADVERTISING.gdpr_consent
                            ) +
                            encodeURIComponent('&nmc=' + gusto.nielsen.segments);
                    }

                    player.ima3({
                        serverUrl: bc_tag_url,
                        requestMode: "onplay",
                    });
                }
            }, 10000);
    })();
</script>
<div class="author-details">
<p class="author-details__author">
        By Sam  Prance
    </p>
<a class="author-details__twitter_handle" href="https://twitter.com/samprance" target="_blank" title="Follow Sam  Prance on Twitter" rel="author">
@samprance</a>
</div>
<div class="social-share">
<a href="https://www.facebook.com/dialog/share?href=www.popbuzz.com%2Ftv-film%2Fnever-have-i-ever%2Fseason-2-devi-paxton-ben-ending-who%2F&amp;app_id=1590232324531551" target="_blank" onclick="gusto.tracking.social('facebook', 'share')">
<img alt="Facebook share" src="/assets_v4r/gusto/img/facebook-share.png" />
</a>
<a href="https://twitter.com/intent/tweet?url=www.popbuzz.com%2Ftv-film%2Fnever-have-i-ever%2Fseason-2-devi-paxton-ben-ending-who%2F&amp;text=Does+Devi+end+up+with+Paxton+or+Ben%3F+Never+Have+I+Ever+season+2+ending+explained+%40popbuzz" target="_blank" onclick="gusto.tracking.social('twitter', 'share')">
<img alt="Twitter share" src="/assets_v4r/gusto/img/twitter-share.png" />
</a>
</div>
<p class="standfirst">Never Have I Ever season 2 explores Devi&#39;s relationships with Paxton and Ben even further but who does she choose?</p>
<p><a href="https://www.popbuzz.com/tv-film/news/never-have-i-ever-season-2-release-time-when-netflix/" rel="noopener" target="_blank"><em>Never Have I Ever</em> season 2</a> is finally out on Netflix and this season we learn if Devi picks Paxton or Ben to be her boyfriend.</p><div id="Teads_ad1"></div><p>The first season of <a href="https://www.popbuzz.com/tv-film/never-have-i-ever/" rel="noopener" target="_blank"><em>Never Have I Ever</em></a><em> </em>introduces us to Devi (<a href="https://www.popbuzz.com/tv-film/features/maitreyi-ramakrishnan/" rel="noopener" target="_blank"><span class="underline">Maitreyi Ramakrishnan</span></a>), a chaotic but loveable teenager who is hellbent on being normal and finding a boyfriend, as she processes the grief of losing her dad. At first, she has a crush on popular jock Paxton (<a href="https://www.popbuzz.com/tv-film/features/darren-barnet/" rel="noopener" target="_blank"><span class="underline">Darren Barnet</span></a>) but she also develops feelings for her academic rival Ben (<a href="https://www.popbuzz.com/tv-film/features/jaren-lewison/" rel="noopener" target="_blank">Jaren Lewison</a>).</p><p><strong>READ MORE:</strong> <a href="https://www.popbuzz.com/tv-film/never-have-i-ever/season-3-release-date-cast-plot-trailer/" rel="noopener" target="_blank">Never Have I Ever season 3: Release date, cast, plot and everything we know so far</a></p><p><em>Never Have I Ever</em> season 1 ends with Paxton realising that he&#x27;s in love with Devi but it also ends with Devi kissing Ben for the first time. Season 2 picks up right where we left off but there is a whole journey with the Devi, Paxton and Ben love triangle before we get to the ending. With that in mind, here&#x27;s your guide to who Devi ends up with.</p><div class="adyoulike-article"></div><h2>Who does Devi end up with in <em>Never Have I Ever</em> season 2?</h2>
<figure>
<img alt="Never Have I Ever season 2: Does Devi choose Ben or Paxton? The ending explained" class="content-image" data-image-catalogue-id="250290" width="660" height="370" loading="lazy" src="https://images.popbuzz.com/images/250290?crop=16_9&amp;width=660&amp;relax=1&amp;signature=qLiO-J77xUYOnvYqIO2NahBs-fU=" srcset="
            https://images.popbuzz.com/images/250290?crop=16_9&amp;width=375&amp;relax=1&amp;signature=sKmxz6WW9SqRPJUGDgA5jvLFDjI= 375w,
            https://images.popbuzz.com/images/250290?crop=16_9&amp;width=420&amp;relax=1&amp;signature=0Ew3p1xGNhChhoQELd3tmR4YT80= 420w,
            https://images.popbuzz.com/images/250290?crop=16_9&amp;width=660&amp;relax=1&amp;signature=qLiO-J77xUYOnvYqIO2NahBs-fU= 660w" sizes="
            (max-width: 375px) 375px,
            (max-width: 420px) 420px,
            660px" />
<figcaption>
    Never Have I Ever season 2: Does Devi choose Ben or Paxton? The ending explained.
    <span class="attribution">
        Picture: 
Netflix


    </span>
</figcaption>
</figure>
<p>As soon as <em>Never Have I Ever</em> season 2 begins, we learn that Devi is completely confused as to who to pick between Paxton and Ben. As a result, she consults with her best friends, Fabiola and Eleanor. Devi confides in them that she has more of an emotional connection to Ben but obviously still fancies Paxton. The girls tell her to pick Paxton because he is so hot.</p><p>However, Devi still can&#x27;t decide and, since she thinks that she is about to move to India with her family, she chooses to date them both without them each knowing. This is all comes to a head when Devi hosts a party and Ben and Paxton find out that she has been lying to them. They both break up with her, and Paxton storms into the street and is hit by a car.</p><p>Paxton is fine. However, he&#x27;s unable to swim as usual due to injuries and has to focus on his academics to get into college. The school asks Devi to tutor him and she agrees out of guilt. In doing so, they start to form a friendship. Meanwhile, Ben begins dating a new girl, Aneesa, who joins the school and becomes friends with Devi and her crew.</p>
<div style="position:relative;padding-top:56.25%; margin-bottom:10px;">
<video-js id="bc_player_6263678723001" data-video-id="6263678723001" data-account="6057949401001" data-player="default" data-embed="default" class="video-js" style="position:absolute;top:0;left:0;width:100%;height:100%;" controls="controls"></video-js>
</div>
<script>
    (function () {
            window.WaitForIt.wait_for(['nielsen_data_ready', 'sourcepoint_data_ready'], function() {
                var player = bc('bc_player_6263678723001');
                
                if (window.gusto.ad_switch.enable_ads_preroll === true) {
                    var isPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(
                            gusto.sourcepoint.nonIabIds.vendors.googleAdManager
                        ),
                        bc_tag_url = 'https://pubads.g.doubleclick.net/gampad/ads?iu=/21824617191/popbuzz/video/brightcove_player&description_url={window.location.href}&tfcd=0&npa=1&sz=400x300%7C640x480&cmsid=2527446&vid={mediainfo.id}&ad_rule=1&gdfp_req=1&output=xml_vast&unviewed_position_start=1&env=vp&impl=s&correlator={random}';

                    // npa means non-personalised ads
                    if (isPersonalisedAds) {
                        bc_tag_url = bc_tag_url.replace('npa=1', 'npa=0');
                    }

                    if (window.GLOBALADVERTISING) {
                        bc_tag_url +=
                            '&cust_params=' +
                            encodeURIComponent('kvplayer=' + 'brightcove') +
                            encodeURIComponent(
                                '&pageid=' + window.GLOBALADVERTISING.pageid
                            ) +
                            encodeURIComponent('&local=' + window.GLOBALADVERTISING.local) +
                            encodeURIComponent(
                                '&adtest=' + window.GLOBALADVERTISING.adtest
                            ) +
                            encodeURIComponent('&section=' + gusto.CATEGORY_PATH) +
                            encodeURIComponent('&at=' + window.GLOBALADVERTISING.at) +
                            encodeURIComponent(
                                '&sensitive=' + window.GLOBALADVERTISING.sensitive
                            ) +
                            encodeURIComponent('&gdpr=' + window.GLOBALADVERTISING.gdpr) +
                            encodeURIComponent(
                                '&gdpr_pd=' + window.GLOBALADVERTISING.gdpr_pd
                            ) +
                            encodeURIComponent(
                                '&gdpr_consent=' + window.GLOBALADVERTISING.gdpr_consent
                            ) +
                            encodeURIComponent('&nmc=' + gusto.nielsen.segments);
                    }

                    player.ima3({
                        serverUrl: bc_tag_url,
                        requestMode: "onplay",
                    });
                }
            }, 10000);
    })();
</script>
<p>Paxton and Devi later start hooking up but Paxton doesn&#x27;t want anyone to know because he&#x27;s still so embarrassed by what Devi did to him. However, as the season ends, he realises that he&#x27;s in love with her and surprises her at the winter dance. The two slow dance happily.</p>
<div class="dac__article-mpu">
<div id="ad-mpu" class="dac__mpu">
<script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['mpu'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'mpu');
                            }
                            
                                
                                    var valid_breakpoint = true;
                                    if(gusto.breakpoints) {
                                        valid_breakpoint = gusto.breakpoints.check('medium-down');
                                    }
                                    if(valid_breakpoint) {
                                        window.GLOBALADVERTISING.push('mpu', ad_mapping, false);
                                    }
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for mpu');
                    }
                })();
            </script>
</div>
</div>
<p>Ben spots them and says: &quot;You&#x27;ve got to be kidding me. Of course, it&#x27;s him. It&#x27;s always been him.&quot; Eleanor, who is next to him, then corrects him and lets slip that Devi originally wanted to be with him instead of Paxton and was jealous when he and Aneesa started dating.</p><p>The season ends with Paxton and Devi becoming boyfriend and girlfriend. They kiss as Ben looks on bewildered. In other words, even though Devi and Paxton are together, it looks like Ben still has feelings for Devi and we doubt Devi&#x27;s have disappeared either.</p><p>It looks like we&#x27;ll have to wait until season 3 to find out who Devi is actually endgame with.</p><h2>Are you team Ben or team Paxton?</h2>
    
        
    
        <div id="ad-instream" class="dac__instream">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['instream'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'instream');
                            }
                            
                                
                                    window.GLOBALADVERTISING.push('instream', ad_mapping, false);
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for instream');
                    }
                })();
            </script>
        </div>
    


    

    
        <div id="ultimedia_wrapper"></div>

    

    

</article>

        
        
    
</div>

            
        </div>
    
        <div class="level1_wrapper">
            
                <div class="

cardset
level1




">

    

    

        
            

    <div class="dac__mpu-card">
    
        <div id="ad-mpu-desktop" class="dac__mpu-desktop">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['mpu-desktop'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'mpu-desktop');
                            }
                            
                                
                                    var valid_breakpoint = true;
                                    if(gusto.breakpoints) {
                                        valid_breakpoint = gusto.breakpoints.check('large-up');
                                    }
                                    if(valid_breakpoint) {
                                        window.GLOBALADVERTISING.push('mpu-desktop', ad_mapping, false);
                                    }
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for mpu-desktop');
                    }
                })();
            </script>
        </div>
    

</div>


        
        
    
</div>

            
                <div class="

cardset
level1


seemore

">

    
        <h2 class="cardset__title cardset__title--seemore">
            
                <a aria-label="Latest TV &amp; Film" href="/tv-film/news/">Latest TV &amp; Film</a>
            
        </h2>
        
            <p class="seemore"><a rel="nofollow" aria-label="More Latest TV &amp; Film" href="/tv-film/news/">See more<span> Latest TV &amp; Film</span></a></p>
        
    

    

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/never-have-i-ever/season-3-release-date-cast-plot-trailer/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/250271?width=105&amp;crop=1_1&amp;signature=BuNLyNN8nM68ZapG1NMjWkzrWFo="
    width="105"
    height="105"
    alt="Never Have I Ever season 3: Release date, news, plot and cast"
    srcset="https://images.popbuzz.com/images/250271?width=105&amp;crop=1_1&amp;signature=BuNLyNN8nM68ZapG1NMjWkzrWFo= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Never Have I Ever season 3: Release date, plot and</span><span class="truncated"> everything we know so far</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/never-have-i-ever/season-3-release-date-cast-plot-trailer/"></a>
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/news/never-have-i-ever-season-2-soundtrack-songs/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/250203?width=105&amp;crop=1_1&amp;signature=oCvKrK5U2luZJUAjhsiXWg6mqfc="
    width="105"
    height="105"
    alt="Never Have I Ever season 2 soundtrack: All the songs"
    srcset="https://images.popbuzz.com/images/250203?width=105&amp;crop=1_1&amp;signature=oCvKrK5U2luZJUAjhsiXWg6mqfc= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Never Have I Ever season 2 soundtrack: Every song from</span><span class="truncated"> the Netflix show</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/news/never-have-i-ever-season-2-soundtrack-songs/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/tv-film/news/">News</a></p>


        </div>
    </div>
</div>

        
            
<div class="gallery editorial promo short-form landscape gallery pivot">

    

    <a href="/tv-film/features/jaren-lewison/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://assets.popbuzz.com/2020/17/jaren-lewison-as-ben-gross---never-have-i-ever-1587997294-list-tablet-0.jpg" alt="Jaren Lewison Ben Gross Never Have I Ever" /></div><h3><span class="ellipsis">Jaren Lewison: 12 facts about Never Have I Ever star you</span><span class="truncated"> probably didn't know</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/features/jaren-lewison/"></a>
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
            
<div class="gallery editorial promo short-form landscape gallery pivot">

    

    <a href="/tv-film/features/never-have-i-ever-cast/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://assets.popbuzz.com/2020/17/never-have-i-ever-cast-1587985068-list-tablet-0.png" alt="Never Have I Ever cast" /></div><h3>
        
            
            Netflix&#39;s Never Have I Ever: Who is in the cast?
            
        
        </h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/features/never-have-i-ever-cast/"></a>
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
            
<div class="gallery editorial promo short-form landscape gallery pivot">

    

    <a href="/tv-film/features/never-have-i-ever-cast-how-old/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://assets.popbuzz.com/2020/17/never-have-i-ever-how-old-are-the-netflix-cast-and-characters-1588158445-list-tablet-0.jpg" alt="Never Have I Ever: How old are the Netflix cast an" /></div><h3><span class="ellipsis">Never Have I Ever: How old are the Netflix cast and</span><span class="truncated"> characters?</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/features/never-have-i-ever-cast-how-old/"></a>
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
        
    
</div>

            
                <div class="

cardset
level1




">

    
        <h2 class="cardset__title ">
            
                <span>Trending on PopBuzz</span>
            
        </h2>
        
    

    

        
            
<div class="gallery editorial promo short-form landscape gallery pivot">

    

    <a href="/music/features/damiano-david/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://assets.popbuzz.com/2021/28/damiano-david-16-facts-about-the-mneskin-singer-you-need-to-know-1626363282-list-tablet-0.jpg" alt="Damiano David: 16 facts about the Måneskin singer" /></div><h3><span class="ellipsis">Damiano David: 16 facts about the Måneskin singer you</span><span class="truncated"> need to know</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/music/features/damiano-david/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/music/features/">Features</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/celeb/jojo-siwa-gay-awakening-demi-lovato-jenna-dewan/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/250388?width=105&amp;crop=1_1&amp;signature=UPeR7C1AGqIX-joBqsM9G43CtlU="
    width="105"
    height="105"
    alt="JoJo Siwa opens up about her &quot;gay awakening&quot; with Demi Lovato"
    srcset="https://images.popbuzz.com/images/250388?width=105&amp;crop=1_1&amp;signature=UPeR7C1AGqIX-joBqsM9G43CtlU= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">JoJo Siwa says Demi Lovato and Jenna Dewan were her "gay</span><span class="truncated"> awakenings"</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/celeb/jojo-siwa-gay-awakening-demi-lovato-jenna-dewan/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/celeb/">Celeb</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/celeb/millie-bobby-brown-hunter-echo-tiktok-apology-video/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/250234?width=105&amp;crop=1_1&amp;signature=KYlzNQlf1OmXkZojWn7muLcdsNc="
    width="105"
    height="105"
    alt="Hunter Echo responds to backlash over &quot;hateful&quot; Millie Bobby Brown remarks in TikTok video"
    srcset="https://images.popbuzz.com/images/250234?width=105&amp;crop=1_1&amp;signature=KYlzNQlf1OmXkZojWn7muLcdsNc= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Hunter Echo fails to apologise to Millie Bobby Brown in</span><span class="truncated"> TikTok 'apology' video</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/celeb/millie-bobby-brown-hunter-echo-tiktok-apology-video/"></a>
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/celeb/">Celeb</a></p>


        </div>
    </div>
</div>

        
            
<div class="gallery editorial promo short-form landscape gallery pivot">

    

    <a href="/tv-film/features/darren-barnet/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://assets.popbuzz.com/2020/16/darren-barnet-11-facts-about-the-never-i-ever-actor-you-need-to-know-1587749959-list-tablet-0.jpg" alt="Darren Barnet: 11 facts Never Have I Ever actor" /></div><h3><span class="ellipsis">Darren Barnet: 11 facts about the Never I Ever actor you</span><span class="truncated"> need to know</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/features/darren-barnet/"></a>
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
            
<div class="gallery editorial promo short-form landscape gallery pivot">

    

    <a href="/tv-film/features/maitreyi-ramakrishnan/" ><div class="img_wrapper"><img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-lazy="https://assets.popbuzz.com/2020/16/maitreyi-ramakrishnan-11-facts-about-the-never-have-i-ever-actress-you-need-to-know-1587745421-list-tablet-0.jpg" alt="Maitreyi Ramakrishnan: 11 facts" /></div><h3><span class="ellipsis">Maitreyi Ramakrishnan: 11 facts about the Never Have I</span><span class="truncated"> Ever actress you need to know</span></h3></a>
    <div class="card__extra-content">
        <a class="card__extra-content__hitbox" href="/tv-film/features/maitreyi-ramakrishnan/"></a>
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
        
    
</div>

            
                <div class="

cardset
level1




">

    
        <h2 class="cardset__title ">
            
                <span>More TV &amp; Film</span>
            
        </h2>
        
    

    

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/the-umbrella-academy/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2019/03/the-umbrella-academy-logo-1548338060-editorial-short-form-0.jpg" alt="The Umbrella Academy" />
            
        </div>
        
            
        
        <h3>
            
                The Umbrella Academy
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/stranger-things/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2016/30/stranger-things-1469531493-editorial-short-form-0.png" alt="Stranger Things" />
            
        </div>
        
            
        
        <h3>
            
                Stranger Things
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/american-horror-story/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2018/41/american-horror-story-apocalypse-1539875977-editorial-short-form-0.png" alt="American Horror Story" />
            
        </div>
        
            
        
        <h3>
            
                American Horror Story
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/netflix-you/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2019/51/penn-badgley-as-joe-goldberg-in-netflixs-you-1577133905-editorial-short-form-0.jpg" alt="You" />
            
        </div>
        
            
        
        <h3>
            
                You
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/sex-education/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2019/01/otis---asa-butterfield---sex-education-neflix-1547203161-editorial-short-form-0.png" alt="Sex Education" />
            
        </div>
        
            
        
        <h3>
            
                Sex Education
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2018/41/rupauls-drag-race-1539874808-editorial-short-form-0.jpg" alt="RuPaul&#39;s Drag Race" />
            
        </div>
        
            
        
        <h3>
            
                RuPaul&#39;s Drag Race
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/on-my-block/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2018/12/netflix-on-my-block-season-2--1522164988-editorial-short-form-0.jpg" alt="On My Block" />
            
        </div>
        
            
        
        <h3>
            
                On My Block
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/riverdale/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2017/29/betty-riverdale--1500461450-editorial-short-form-0.jpg" alt="Riverdale" />
            
        </div>
        
            
        
        <h3>
            
                Riverdale
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
        
    
</div>

            
        </div>
    

</div>


        </section>
        


<footer class="footer">
    <div class="footer__section footer-back-to-top">
        <a href="#" id="go_to_top" class="footer-back-to-top__link" onclick="backToTop(e)" title="Back to top">Back to top</a>
    </div>
    <script type="application/javascript">
        function backToTop(e) {
            e.preventDefault();
            window.scrollTo(0, 0);
        }
    </script>
    <div class="footer__section">
        <div class="grid-row">
            <div class="grid-row__col--3">
                
    <h3 class="footer__heading">Also on PopBuzz</h3>
    <ul class="footer-hot-links">
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/sex-education/season-3-release-date-cast-trailer-netflix/" class="footer-hot-links__link">Sex Education season 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/quizzes/cheugy-quiz/" class="footer-hot-links__link">Cheugy</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/bella-poarch/" class="footer-hot-links__link">Bella Poarch</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/olivia-rodrigo/" class="footer-hot-links__link">Olivia Rodrigo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/high-school-musical-the-series/" class="footer-hot-links__link">High School Music: The Musical: The Series</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/taylor-swift/" class="footer-hot-links__link">Taylor Swift</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/dispo-invite-how-to-find/" class="footer-hot-links__link">Dispo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/to-all-the-boys-ive-loved-before/3-release-date-cast-always-and-forever-lara-jean/" class="footer-hot-links__link">To All the Boys 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race" class="footer-hot-links__link">Drag Race UK</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/american-horror-story/" class="footer-hot-links__link">American Horror Story</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/euphoria/" class="footer-hot-links__link">Euphoria</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/chilling-adventures-of-sabrina/" class="footer-hot-links__link">Chilling Adventures of Sabrina</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/greys-anatomy/" class="footer-hot-links__link">Grey&#39;s Anatomy</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/top-nine-instagram-2019-app/" class="footer-hot-links__link">Instagram Top Nine</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/news/spotify-stats-top-artists-songs-most-played-how/" class="footer-hot-links__link">Spotify</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/timothee-chalamet/" class="footer-hot-links__link">Timothée Chalamet</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/tiktok/" class="footer-hot-links__link">TikTok</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/josephine-langford/" class="footer-hot-links__link">Josephine Langford</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/hero-fiennes-tiffin/" class="footer-hot-links__link">Hero Fiennes Tiffin</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/louis-partridge/" class="footer-hot-links__link">Louis Partridge</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/quizzes/" class="footer-hot-links__link">Quizzes</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/louis-partridge/" class="footer-hot-links__link">Louis Partridge</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/bella-poarch/" class="footer-hot-links__link">Bella Poarch</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/haunting-of-bly-manor/" class="footer-hot-links__link">The Haunting of Bly Manor</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/the-kissing-booth/" class="footer-hot-links__link">The Kissing Booth</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/best-memes-2020/" class="footer-hot-links__link">Memes</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/the-umbrella-academy/season-3-release-date-cast-trailer-netflix/" class="footer-hot-links__link">The Umbrella Academy 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/best-tiktok-songs-2020-popular/" class="footer-hot-links__link">TikTok Songs</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/lizzo/" class="footer-hot-links__link">Lizzo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/billie-eilish/" class="footer-hot-links__link">Billie Eilish</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/elite-netflix/season-4-release-date-cast-trailer-spoilers-news/" class="footer-hot-links__link">Elite season 4</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/on-my-block/" class="footer-hot-links__link">On My Block</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race/" class="footer-hot-links__link">RuPaul&#39;s Drag Race</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/snapchat/" class="footer-hot-links__link">Snapchat</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/stranger-things/stranger-things-season-4-release-date-cast-trailer/" class="footer-hot-links__link">Stranger Things 4</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/millie-bobby-brown/" class="footer-hot-links__link">Millie Bobby Brown</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/addison-rae/" class="footer-hot-links__link">Addison Rae</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/outer-banks/" class="footer-hot-links__link">Outer Banks</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/nick-robinson/" class="footer-hot-links__link">Nick Robinson</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/charli-damelio/" class="footer-hot-links__link">Charli D&#39;Amelio</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/harry-styles/" class="footer-hot-links__link">Harry Styles</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/sex-education/" class="footer-hot-links__link">Sex Education</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/features/doja-cat/" class="footer-hot-links__link">Doja Cat</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/bts/" class="footer-hot-links__link">BTS</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/to-all-the-boys-ive-loved-before/" class="footer-hot-links__link">To All The Boys I&#39;ve Loved Before</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/tv-film/netflix/" class="footer-hot-links__link">Netflix</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/twenty-one-pilots/" class="footer-hot-links__link">Twenty One Pilots</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/halsey/" class="footer-hot-links__link">Halsey</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/" class="footer-hot-links__link">New Music</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/panic-at-the-disco/" class="footer-hot-links__link">Panic! At The Disco</a>
            </li>
        
    </ul>


            </div>
        </div>
    </div>

    <div class="footer__section--shaded">
        <div class="grid-row">
            <div class="grid-row__col--1">
                <h3 class="footer__heading">Useful Links</h3>
                <ul class="footer-useful-links">
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/about-us/" target="_blank">About Us</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/contact-us/" target="_blank">Contact Us</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="https://global.com/cookies/" target="_blank">Cookies</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="https://global.com/privacy-policy/" target="_blank">Privacy</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/terms-conditions/" target="_blank">Terms &amp; Conditions</a>
                        
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/advertise/" target="_blank">Advertise</a>
                        
                    
                    </li>
                
                </ul>
            </div>

            <div class="grid-row__col--1">
                
                    <h3 class="footer__heading">Latest From Twitter</h3>
                    <ul class="twitter-tweets">
<p class="twitter-tweets__user">PopBuzz &dash; <a href="http://twitter.com/popbuzz/" class="twitter-tweets__link" target="_blank">@popbuzz</a></p>

    <li class="twitter-tweets__item">
    	<p class="twitter-tweets__tweet">never forget the chaos when tom holland got starstruck by justin bieber on live😭😅

<a href="https://vm.tiktok.com/ZMdqvDQE6/" class="twitter-tweets__link" target="_blank">vm.tiktok.com/ZMdqvDQE6/</a> <a href="https://twitter.com/popbuzz/status/1415738222580207616/video/1" class="twitter-tweets__link" target="_blank">pic.twitter.com/F0D501lyst</a></p>
    </li>

</ul>

                
            </div>

            <div class="grid-row__col--1">
                <h3 class="footer__heading">Follow Us</h3>
                <div class="social-links__container">
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--twitter" 
                href="https://twitter.com/popbuzz" 
                title="Follow PopBuzz on Twitter" 
                target="_blank">Follow PopBuzz on Twitter</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--facebook" 
                href="https://www.facebook.com/popbuzz" 
                title="Follow PopBuzz on Facebook" 
                target="_blank">Follow PopBuzz on Facebook</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--instagram" 
                href="https://instagram.com/popbuzz" 
                title="Follow PopBuzz on Instagram" 
                target="_blank">Follow PopBuzz on Instagram</a>
        </div>
    
    
        <div class="social-links__item">
            <a  class="social-links__link social-links__link--youtube" 
                href="https://www.youtube.com/user/popbuzz" 
                title="Follow PopBuzz on Youtube" 
                target="_blank">Follow PopBuzz on Youtube</a>
        </div>
    
 </div>
            </div>
        </div>
    </div>

    <div class="footer__section">
        <div class="grid-row" itemscope itemtype="http://schema.org/Organization">
            <div class="grid-row__col--3 footer-footnote-section">
                &copy; <span itemprop="legalName">Global</span> 2021
            </div>
            <div class="grid-row__col--3 footer-footnote-section footer-footnote-section--end" itemprop="address">
                30 Leicester Square, London, WC2H 7LA
            </div>
            
                <a class="footer__section__privacy_manager_button" id="privacy_manager__button" href="#">
                    Privacy Manager
                </a>
            
        </div>
    </div>
</footer>
<script>
    var privacy_manager__button = document.getElementById('privacy_manager__button');
    if(privacy_manager__button) {
        privacy_manager__button.onclick = function(e) {
            e.preventDefault();
            if (window._sp_) {
                window._sp_.loadPrivacyManagerModal(
                    "173688"
                );
            }
        };
    }
</script>


        
        


    
        
            <script src="/assets_v4r/dist/combined/js/page_151299.min.js" defer></script>
        
    



        <!-- Global DAC Execution -->
        
            <script>
    // Enable Google Ad Services
    function googleAdManagerInit() {
        var isNonPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(gusto.sourcepoint.nonIabIds.vendors.googleAdManager) ? 0 : 1;
        googletag.cmd.push(function() {
            googletag.pubads()
                .setTargeting("section", String(window.GLOBALADVERTISING.section))
                .setTargeting("pageid", String(window.GLOBALADVERTISING.pageid))
                .setTargeting("contenttype", String(window.GLOBALADVERTISING.contenttype))
                .setTargeting("gdpr_consent", String(window.GLOBALADVERTISING.gdpr_consent))
                .setTargeting("adtest", String(window.GLOBALADVERTISING.adtest))
                .setTargeting("level", String(window.GLOBALADVERTISING.level))
                .setTargeting("at", String(window.GLOBALADVERTISING.at))
                .setTargeting("loginstate", String(window.GLOBALADVERTISING.loginstate))
                .setTargeting("pagecount", String(window.GLOBALADVERTISING.pagecount))
                .setTargeting("newslink", window.GLOBALADVERTISING.newslink ? String(window.GLOBALADVERTISING.newslink) : '')
                .setTargeting("sensitive", String(window.GLOBALADVERTISING.sensitive))
                .setTargeting("takeover", String(Math.floor(Math.random()*6) + 1));
            if(window.gusto.nielsen.segments) {
                googletag.pubads().setTargeting("nmc", String(window.gusto.nielsen.segments.split(":")));
            }
            googletag.pubads().setTargeting("npa", String(isNonPersonalisedAds));
    
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.pubads().disableInitialLoad();
            googletag.enableServices();

            // events
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot.getSlotElementId() === 'ad-banner') {
                    window.WaitForIt.trigger('ad_banner_rendered');
                }
            });
                
            googletag.pubads().refresh();
        });
    }
</script>

        
    </body>
</html>
