

<!DOCTYPE html>
<!--[if lte IE 9]><html lang="en" class="lteIE9"><![endif]-->
<!--[if !IE]><!--><html lang="en"><!--<![endif]-->
    <head>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge">

        
        
            
                <link rel="preload" href="/assets_v4r/dist/combined/css/page_98104c.min.css" as="style" />
            
                <link rel="preload" href="/assets_v4r/dist/combined/js/page_609eb4.min.js" as="script" />
            
                <link rel="preload" href="https://cf-images.eu-west-1.prod.boltdns.net/v1/static/6057949401001/c47352de-0f39-4add-a74d-294690b2cef6/f232ff0a-6543-4094-98dd-53ddb0d5fc83/640x360/match/image.jpg" as="image" />
            
                <link rel="preload" href="https://images.popbuzz.com/images/291120?crop=16_9&amp;width=660&amp;relax=1&amp;signature=-PMRTv7rooFhE63jQpiQ1BtvwEo=" as="image" />
            
        
        
            <link rel="preload" href="/assets_v4r/dist/combined/fonts/chevrons.woff" as="font" type="font/woff" crossorigin/>
        

        
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-16x16.png" sizes="16x16" />
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-32x32.png" sizes="32x32" />
        <link rel="icon" type="image/png" href="/assets_v4r/popbuzz/img/favicon-196x196.png" sizes="196x196" />
        <link rel="apple-touch-icon-precomposed" sizes="57x57" href="/assets_v4r/popbuzz/img/apple-touch-icon-57x57.png" />
        <link rel="apple-touch-icon-precomposed" sizes="60x60" href="/assets_v4r/popbuzz/img/apple-touch-icon-60x60.png" />
        <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/assets_v4r/popbuzz/img/apple-touch-icon-72x72.png" />
        <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/assets_v4r/popbuzz/img/apple-touch-icon-76x76.png" />
        <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/assets_v4r/popbuzz/img/apple-touch-icon-114x114.png" />
        <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/assets_v4r/popbuzz/img/apple-touch-icon-120x120.png" />
        <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/assets_v4r/popbuzz/img/apple-touch-icon-144x144.png" />
        <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/assets_v4r/popbuzz/img/apple-touch-icon-152x152.png" />

        
        <link rel="canonical" href="https://www.popbuzz.com/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/" />
        

        
        <link rel="amphtml" href="https://amp.popbuzz.com/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/" />
        

        <title>Euphoria fans notice Nate and Cassie editing mistake in season 2 finale - PopBuzz</title>

        <meta content="width=device-width, initial-scale=1.0" name="viewport" />

        <meta content="2022-03-02T12:13:27" name="pubdate" itemprop="datePublished" />
<meta content="2022-03-02T12:30:15" name="modified" itemprop="dateModified" />
<meta content="post" name="parsely-type" />
<meta content="euphoria, fans, notice, huge, nate, cassie, editing, mistake, season, finale, edited, boiiii" name="keywords" />
<meta content="Euphoria viewers have noticed Nate, Cassie and Suze all in the audience of Lexi&#39;s play despite Nate leaving, and the other two appearing on stage at the same time. Watch the viral Tikok video here." name="description" />
<meta content="Katie Louise-Smith" name="parsely-author" />
<meta content="https://www.popbuzz.com/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/" property="og:url" />
<meta content="PopBuzz" property="og:site_name" />
<meta content="www.popbuzz.com" property="og:domain" />
<meta content="article" property="og:type" />
<meta content="https://images.popbuzz.com/images/291120?width=641&crop=16_9&signature=DQ_0bK5jvS9HHuMwL4N6TYfgm2g=" property="og:image" />
<meta content="361" property="og:image:height" />
<meta content="641" property="og:image:width" />
<meta content="Euphoria viewers have noticed Nate, Cassie and Suze all in the audience of Lexi&#39;s play despite Nate leaving, and the other two appearing on stage at the same time. Watch the viral Tikok video here." property="og:description" />
<meta content="Euphoria fans notice huge Nate and Cassie editing mistake in season 2 finale" property="og:title" />
<meta content="@popbuzz" name="twitter:site" />
<meta content="https://www.popbuzz.com/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/" name="twitter:url" />
<meta content="summary_large_image" name="twitter:card" />
<meta content="https://images.popbuzz.com/images/291120?width=641&crop=16_9&signature=DQ_0bK5jvS9HHuMwL4N6TYfgm2g=" name="twitter:image" />
<meta content="Euphoria viewers have noticed Nate, Cassie and Suze all in the audience of Lexi&#39;s play despite Nate leaving, and the other two appearing on stage at the same time. Watch the viral Tikok video here." name="twitter:description" />
<meta content="Euphoria fans notice huge Nate and Cassie editing mistake in season 2 finale" name="twitter:title" />
<meta content="627792841,551351399,716836285,1547481361,837890453,661531116" property="fb:admins" />
<meta content="1590232324531551" property="fb:app_id" />
<meta content="1488952944702289" property="fb:page_id" />
<meta content="1488952944702289" property="fb:pages" />
<meta content="https://www.popbuzz.com/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/" name="parsely-link" />
<meta content="/tv-film/euphoria/" name="parsely-section" />
<meta content="Euphoria fans notice huge Nate and Cassie editing mistake in season 2 finale" name="parsely-title" />
<meta content="19469" name="parsely-post-id" />
<meta content="2022-03-02T12:13:27+00:00" name="parsely-pub-date" />
<meta content="https://images.popbuzz.com/images/291120?width=641&crop=16_9&signature=DQ_0bK5jvS9HHuMwL4N6TYfgm2g=" name="parsely-image-url" />
<meta content="Katie Louise Smith" name="parsely-author" />
        

        



	
		<link rel="stylesheet" href="/assets_v4r/dist/combined/css/page_98104c.min.css" />
	




        <script>
            var gusto = window.gusto || {};
            gusto.MAIN_CONTENT_TYPE = "cadmus-article";
            gusto.ROOT_URL = "https://www.popbuzz.com";
            gusto.SITE_NAME = "PopBuzz";
            gusto.STATIC_URL = "/assets_v4r/";
            gusto.STATIC_BRAND_URL = "/assets_v4r/popbuzz/";
            gusto.CATEGORY_PATH = "/tv-film/euphoria/";
            gusto.PROJECT_NAME = "popbuzz";
            gusto.PLAYER_INFO = {"localise_url": "/localise/", "play_overlay": false, "player_url_ukrp": null, "is_localised": true, "twin_stations": null, "player_url": null, "global_player_enabled": false, "localisation_light_enabled": false, "localisations_enabled": false, "player_url_template": ""};
            gusto.DEBUG = false;
            gusto.SETTINGS = {
                'COOKIE_STATION_MAX_AGE_SECONDS': 63072000
            };
            gusto.ad_settings = {
                'banner_visibility_delay': 3000,
            };
            gusto.ad_switch = {
                'enable_ads_dac': true,
                'enable_ads_related': true,
                'enable_ads_ukrp': true,
                'enable_ads_preroll': true,
                'enable_ads_related_videos': true,

            };
            gusto.STATION = {
                'name': "PopBuzz",
                'slug': ""
            };
            gusto.breakpoints = {
                limits: {
                    'small': [0, 640],
                    'medium': [641, 1023],
                    'large': [1024, 1440],
                    'xlarge': [1441, 1920],
                    'xxlarge': [1921, 9001]
                },
                check: function(target) {
                    
                    var target_bits = target.split('-'),
                        brkpoint = target_bits[0],
                        dir = target_bits[1],
                        win = window.innerWidth,
                        ref = this.limits[brkpoint];
                    if (!ref) return false;
                    if (dir == 'up') return (win >= ref[0]);
                    else if (dir == 'down') return (win <= ref[1]);
                    else return (win >= ref[0] && win <= ref[1]);
                }
            };

            gusto.ABSOLUTE_URL = "/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/";
            gusto.station_twitter = 'popbuzz';
            gusto.FACEBOOK_APP_ID = '1590232324531551';
            gusto.category_tree = {"1": {"full_slug": "/", "name": "popbuzz.com", "parent": null, "children": [101, 72, 109, 106, 108, 404, 111, 70, 418]}, "418": {"full_slug": "/index/", "name": "A-Z", "parent": 1}, "101": {"full_slug": "/news/", "name": "News", "parent": 1}, "70": {"full_slug": "/quizzes/", "name": "Quizzes", "parent": 1}, "231": {"full_slug": "/music/quizzes/", "name": "Quizzes", "parent": 72}, "72": {"full_slug": "/music/", "name": "Music", "parent": 1, "children": [105, 119, 239, 231, 102]}, "105": {"full_slug": "/music/artists/", "name": "Artists", "parent": 72}, "106": {"full_slug": "/internet/", "name": "Internet", "parent": 1}, "108": {"full_slug": "/life/", "name": "Life + Style", "parent": 1}, "109": {"full_slug": "/tv-film/", "name": "TV & Film", "parent": 1}, "111": {"full_slug": "/exclusives/", "name": "Video", "parent": 1}, "404": {"full_slug": "/celeb/", "name": "Celeb", "parent": 1}, "119": {"full_slug": "/music/news/", "name": "News", "parent": 72}, "239": {"full_slug": "/music/features/", "name": "Features", "parent": 72}, "102": {"full_slug": "/music/playlists/", "name": "Playlists", "parent": 72}};
            gusto.APP_INFO = {
                'android_download_url': "",
                'ios_download_url': "https://itunes.apple.com/gb/app/popbuzz/id1078206186?mt=8",
                'android_launch_url': ""
            };
            gusto.page_id = "19469";
            gusto.render_mode = "v4";
            gusto.lazy_ads = [];
            gusto.ooyala = {
                player_google_ad_tag: "https://pubads.g.doubleclick.net/gampad/ads?iu=/21824617191/",
                requireIsReady: false,
                ooyalaIsReady: false,
                initOoyalaVideos: function(){},
                // 
                initOoyalaPlayer: function () {
                    gusto.ooyala.ooyalaIsReady = true;
                    if (gusto.ooyala.requireIsReady) {
                        gusto.ooyala.initOoyalaVideos();
                    }
                }
            };
            gusto.udb_user = {
                'grid': null
            };
        </script>

        <!-- WaitForIt race condition resolver -->
        <script src="/assets_v4r/dist/gusto/js/app/lib/waitForIt.js"></script>

        <!-- Global DAC -->
        
            
<script>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</script>

        

        <!-- Global DAC Execution WITH SOURCEPOINT -->
        
            <script>
    // Enable Google Ad Services
    function googleAdManagerInit() {
        var isNonPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(gusto.sourcepoint.nonIabIds.vendors.googleAdManager) ? 0 : 1;
        googletag.cmd.push(function() {
            googletag.pubads()
                .setTargeting("section", String(window.GLOBALADVERTISING.section))
                .setTargeting("pageid", String(window.GLOBALADVERTISING.pageid))
                .setTargeting("contenttype", String(window.GLOBALADVERTISING.contenttype))
                .setTargeting("gdpr_consent", String(window.GLOBALADVERTISING.gdpr_consent))
                .setTargeting("adtest", String(window.GLOBALADVERTISING.adtest))
                .setTargeting("level", String(window.GLOBALADVERTISING.level))
                .setTargeting("at", String(window.GLOBALADVERTISING.at))
                .setTargeting("loginstate", String(window.GLOBALADVERTISING.loginstate))
                .setTargeting("pagecount", String(window.GLOBALADVERTISING.pagecount))
                .setTargeting("newslink", window.GLOBALADVERTISING.newslink ? String(window.GLOBALADVERTISING.newslink) : '')
                .setTargeting("sensitive", String(window.GLOBALADVERTISING.sensitive))
                .setTargeting("takeover", String(Math.floor(Math.random()*6) + 1));
            if(window.gusto.nielsen.segments) {
                googletag.pubads().setTargeting("nmc", String(window.gusto.nielsen.segments.split(":")));
            }
            googletag.pubads().setTargeting("npa", String(isNonPersonalisedAds));
    
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.pubads().disableInitialLoad();
            googletag.enableServices();

            // events
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot.getSlotElementId() === 'ad-banner') {
                    window.WaitForIt.trigger('ad_banner_rendered');
                }
            });
                
            googletag.pubads().refresh();
        });
    }
</script>

        
        
        <!-- SOURCEPOINT -->
        <script>
    gusto.sourcepoint = {
        'enabled': true,
        'gdprApplies': true,
        'baseEndpoint': "https://d.sourcepoint.popbuzz.com",
        'nonIabVendorConsents': [],
        'nonIabPurposeConsents': [],
        'iabVendorConsents': {},
        'iabPurposeConsents': {},

        'iabIds': {"vendors": {"googleAnalytics": 755, "nielsen": 373, "outbrain": 164, "adyoulike": 259, "remixd": 886, "digiteka": 343}, "purposes": {"accessInformationOnDevice": 1, "applyMarketResearch": 9, "measureAdPerformance": 7, "createPersonalisedAds": 3, "selectBasicAds": 2, "createPersonalisedContent": 5, "selectPersonalisedAds": 4, "selectPersonalisedContent": 6, "measureContentPerformance": 8, "developImproveProducts": 10}},
        'nonIabIds': {"vendors": {"gigya": "5e945f26b8e05c1c467daad8", "fbAudienceNetwork": "5ee91b9593fc094b59242e26", "parsely": "5efb47c3a86ed40d775a6693", "brightcove": "5ec796b4320b5a4efd764e0f", "googleAdManager": "5e74df5ff443bb795772df9c", "skimlinks": "5efb47d829507407f91c4d4e", "adobeAdvertising": "5ed7a9968c242d01c4a14072"}},

        'checkIabVendorConsentById': function (vendorId) {
            return this.iabVendorConsents[vendorId] == true;
        },

        'checkIabPurposeConsents': function (purposeId) {
            return this.iabPurposeConsents[purposeId] == true;
        },

        'checkNonIabVendorConsentById': function (vendorId) {
            for(var i=0; i<this.nonIabVendorConsents.length; i++) {
                if(this.nonIabVendorConsents[i]["_id"] === vendorId) {
                    return true;
                }
            }
            return false;
        },
    };
</script>

        
        <!-- Extra JS requested by cards (head) -->
        


        <!-- CMP -->
        
            <script type="text/javascript">
    !function () {
        var e = function () {
            var e, t = "__tcfapiLocator", a = [], n = window;
            for (; n;) {
                try {
                    if (n.frames[t]) {
                        e = n;
                        break
                    }
                } catch (e) {
                }
                if (n === window.top) break;
                n = n.parent
            }
            e || (!function e() {
                var a = n.document, r = !!n.frames[t];
                if (!r) if (a.body) {
                    var i = a.createElement("iframe");
                    i.style.cssText = "display:none", i.name = t, a.body.appendChild(i)
                } else setTimeout(e, 5);
                return !r
            }(), n.__tcfapi = function () {
                for (var e, t = arguments.length, n = new Array(t), r = 0; r < t; r++) n[r] = arguments[r];
                if (!n.length) return a;
                if ("setGdprApplies" === n[0]) n.length > 3 && 2 === parseInt(n[1], 10) && "boolean" == typeof n[3] && (e = n[3], "function" == typeof n[2] && n[2]("set", !0)); else if ("ping" === n[0]) {
                    var i = {gdprApplies: e, cmpLoaded: !1, cmpStatus: "stub"};
                    "function" == typeof n[2] && n[2](i)
                } else a.push(n)
            }, n.addEventListener("message", (function (e) {
                var t = "string" == typeof e.data, a = {};
                try {
                    a = t ? JSON.parse(e.data) : e.data
                } catch (e) {
                }
                var n = a.__tcfapiCall;
                n && window.__tcfapi(n.command, n.version, (function (a, r) {
                    var i = {__tcfapiReturn: {returnValue: a, success: r, callId: n.callId}};
                    t && (i = JSON.stringify(i)), e.source.postMessage(i, "*")
                }), n.parameter)
            }), !1))
        };
        "undefined" != typeof module ? module.exports = e : e()
    }();
</script>
<script type="text/javascript">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</script>
<script id="tcfV2Script"></script>
<script>
    document.getElementById('tcfV2Script').src = gusto.sourcepoint.baseEndpoint + '/wrapperMessagingWithoutDetection.js';
</script>

        

        <!-- Advertising -->
        
            <!-- DAC -->
            <script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
            <script>
                window.googletag = window.googletag || {cmd: []};
            </script>
        

        
            <link rel="stylesheet" type="text/css" href="https://players.brightcove.net/videojs-ima3/3/videojs.ima3.min.css" />
        
        
    </head>
    <body class="no-js">
        <!-- Extra Js requested by cards (body) -->
        
            <script src="https://players.brightcove.net/6057949401001/default_default/index.min.js"></script>
        
            <script src="https://players.brightcove.net/videojs-ima3/3/videojs.ima3.min.js"></script>
        

        


<!-- Google Tag Manager - Data Layer -->
<script>dataLayer = [{"render_mode": "v4", "brand": "popbuzz", "signals": ["remixd"], "ad_tools": {"digiteka_mdtk": "02018156"}, "content_type": "cadmus-article", "page": {"category1": "tv film", "category3": "tv film/euphoria/nate cassie mistake audience lexi play", "category2": "tv film/euphoria", "contentType": "cadmus-article", "cleanUrl": "https://www.popbuzz.com/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/", "title": "Euphoria fans notice Nate and Cassie editing mistake in season 2 finale - PopBuzz", "brand": "popbuzz", "path": "/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/", "platformType": "web"}, "full_path": "/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/"}];</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N7KJ77&render_mode=v4&brand=popbuzz&signals=%5B%27remixd%27%5D&ad_tools=%7B%27digiteka_mdtk%27%3A+%2702018156%27%7D&content_type=cadmus-article&page=%7B%27category1%27%3A+u%27tv+film%27%2C+%27category3%27%3A+u%27tv+film%2Feuphoria%2Fnate+cassie+mistake+audience+lexi+play%27%2C+%27category2%27%3A+u%27tv+film%2Feuphoria%27%2C+%27contentType%27%3A+%27cadmus-article%27%2C+%27cleanUrl%27%3A+%27https%3A%2F%2Fwww.popbuzz.com%2Ftv-film%2Feuphoria%2Fnate-cassie-mistake-audience-lexi-play%2F%27%2C+%27title%27%3A+u%27Euphoria+fans+notice+Nate+and+Cassie+editing+mistake+in+season+2+finale+-+PopBuzz%27%2C+%27brand%27%3A+%27popbuzz%27%2C+%27path%27%3A+u%27%2Ftv-film%2Feuphoria%2Fnate-cassie-mistake-audience-lexi-play%2F%27%2C+%27platformType%27%3A+%27web%27%7D&full_path=%2Ftv-film%2Feuphoria%2Fnate-cassie-mistake-audience-lexi-play%2F"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N7KJ77');</script>
<!-- End Google Tag Manager -->



        <script type="text/javascript">document.body.className = document.body.className.replace('no-js', 'js');</script>

        <div id="fb-root"></div>
        
            
    
        <div id="ad-overlay" class="dac__overlay">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['overlay'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'overlay');
                            }
                            
                                
                                    window.GLOBALADVERTISING.push('overlay', ad_mapping, false);
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for overlay');
                    }
                })();
            </script>
        </div>
    


        
        
            


<header class="header header--with-contextual" id="header">
    <!-- BLOCK:0 USER STATUS HEADER -->
    <div class="header__section header__section--primary-bg header__user-status">
        <div class="header__container">
            <ul id="user_status" class="header-user-status"></ul>
            <a tabindex="1" href="#main-content" id="skip-content" class="skip__content">Skip to content</a>
        </div>
    </div>

    <!-- BLOCK:1 HEADER MAIN -->
    <div class="header__section header__main js-header-main">
        <div id="top" class="header__container">
            <a href="#primary" class="skip-nav js-skip-nav"><span>skip to navigation</span></a>
            


<p tabindex="0" class="header__logo ">
    <a class="header__logo__link" href="/">PopBuzz</a>
</p>





        </div>
    </div>

    <!-- BLOCK:2 PRIMARY NAV -->
    <div class="header__section" id="nav_wrapper" >
        <nav tabindex="-1" id="primary" class="header__container standard">
            <ul>
                
                <li  class="nav-home "
                    
                     >

                    
                    <a href="/">Home</a>
                    
                </li>
                
                <li  class="nav-news "
                    
                    
                        data-id="101"
                     >

                    
                    <a href="/news/">News</a>
                    
                </li>
                
                <li  class="nav-music "
                    
                    
                        data-id="72"
                     >

                    
                    <a href="/music/">Music</a>
                    
                </li>
                
                <li  class="nav-tv-film "
                    
                    
                        data-id="109"
                     >

                    
                    <a href="/tv-film/">TV &amp; Film</a>
                    
                </li>
                
                <li  class="nav-internet "
                    
                    
                        data-id="106"
                     >

                    
                    <a href="/internet/">Internet</a>
                    
                </li>
                
                <li  class="nav-life-style "
                    
                    
                        data-id="108"
                     >

                    
                    <a href="/life/">Life + Style</a>
                    
                </li>
                
                <li  class="nav-celeb "
                    
                    
                        data-id="404"
                     >

                    
                    <a href="/celeb/">Celeb</a>
                    
                </li>
                
                <li  class="nav-video "
                    
                    
                        data-id="111"
                     >

                    
                    <a href="/exclusives/">Video</a>
                    
                </li>
                
                <li  class="nav-quizzes "
                    
                    
                        data-id="70"
                     >

                    
                    <a href="/quizzes/">Quizzes</a>
                    
                </li>
                
                <li id="members_nav_link" class="nav-a-z "
                    
                    
                        data-id="418"
                     >

                    
                    <a href="/index/">A-Z</a>
                    
                </li>
                
                


    <li class="social-links util--hidden-on-desktop">
        <em class="social-links__label">Follow us on:</em>
        <div class="social-links__container">
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--twitter"
                href="https://twitter.com/popbuzz"
                title="Follow PopBuzz on Twitter"
                target="_blank">Follow PopBuzz on Twitter</a>
        </div>
    
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--facebook"
                href="https://www.facebook.com/popbuzz"
                title="Follow PopBuzz on Facebook"
                target="_blank">Follow PopBuzz on Facebook</a>
        </div>
    
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--instagram"
                href="https://instagram.com/popbuzz"
                title="Follow PopBuzz on Instagram"
                target="_blank">Follow PopBuzz on Instagram</a>
        </div>
    
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--youtube"
                href="https://www.youtube.com/user/popbuzz"
                title="Follow PopBuzz on Youtube"
                target="_blank">Follow PopBuzz on Youtube</a>
        </div>
    
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--tiktok"
                href="https://www.tiktok.com/@popbuzz"
                title="Follow PopBuzz on TikTok"
                target="_blank">Follow PopBuzz on TikTok</a>
        </div>
    
 </div>

    </li>

            </ul>
        </nav>
    </div>

    <!-- BLOCK:3 TRENDING BAR/CONTEXT NAV -->
    <div id="main-content" class="header__section">
        
            <div class="contextual-nav__wrapper contextual-nav--pivot-available">
                <div class="contextual-nav js-contextual-nav">
                    

                    
                        
                        <p class="contextual-nav__header">
                        
                            TV &amp; Film
                            <a class="js-contextual-nav-toggle contextual-nav__nav-toggle" href="#" >
                                <span class="contextual-nav__nav-toggle__nav-button nav_button"></span>
                            </a>
                        
                        </p>
                        
                    

                    
                        <nav class="contextual-nav__nav">
                            <ul class="contextual-nav__nav__list">
                            
                                
                                    <li class="contextual-nav__nav__item" data-id=""><a href="/tv-film/">
            TV &amp; Film Home
        </a></li>

                                
                            
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="236"><a href="/tv-film/news/">
            News
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="227"><a href="/tv-film/quizzes/">
            Quizzes
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="317"><a href="/tv-film/american-horror-story/">
            American Horror Story
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="318"><a href="/tv-film/stranger-things/">
            Stranger Things
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="321"><a href="/tv-film/rupauls-drag-race/">
            RuPaul&#39;s Drag Race
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="357"><a href="/tv-film/elite-netflix/">
            Elite
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="381"><a href="/tv-film/sex-education/">
            Sex Education
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="401"><a href="/tv-film/marvel/">
            Marvel
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="431"><a href="/tv-film/after/">
            After
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="438"><a href="/tv-film/euphoria/">
            Euphoria
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="441"><a href="/tv-film/bridgerton/">
            Bridgerton
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="445"><a href="/tv-film/never-have-i-ever/">
            Never Have I Ever
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="371"><a href="/tv-film/the-umbrella-academy/">
            The Umbrella Academy
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="406"><a href="/tv-film/netflix-you/">
            You
        </a></li>

                                
                            
                                
                                    <li class="contextual-nav__nav__item" data-id="417"><a href="/tv-film/outer-banks/">
            Outer Banks
        </a></li>

                                
                            
                                
                                <li class="contextual-nav__nav__item contextual-nav__nav__contextual-parent">
                                    <a href="/">
                                        
                                            More PopBuzz
                                        
                                    </a>
                                </li>
                                
                            </ul>
                        </nav>
                    
                </div>
            </div>
        
    </div>

    <!-- BLOCK:4 MOBILE NOW PLAYING -->
    
</header>

        

        <script src="/dynamic/userContent.js"></script>

         <!-- NIELSEN (needs to be executed after userContent.js) -->
        
            <!-- START Nielsen interchange script -->
<script type="text/javascript">
if(gusto.sourcepoint.enabled) {
    window.gusto.nielsen = {
        userId: null,
        segments: "",
        callbacks: [],
        init: function() {
            var isNielsenOn = gusto.sourcepoint.checkIabVendorConsentById(gusto.sourcepoint.iabIds.vendors.nielsen) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectPersonalisedContent) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectPersonalisedAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.selectBasicAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.createPersonalisedAds) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.createPersonalisedContent) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.measureAdPerformance) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.measureContentPerformance) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.applyMarketResearch) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.developImproveProducts) &&
                gusto.sourcepoint.checkIabPurposeConsents(gusto.sourcepoint.iabIds.purposes.accessInformationOnDevice);

            if (!window.gusto.sourcepoint.gdprApplies || isNielsenOn) {
                if (window.localStorage) {
                    window.gusto.nielsen.userId = window.localStorage.getItem('nmcUserId') || null;
                    window.gusto.nielsen.segments = window.localStorage.getItem('nmcSegments') || "";
                }
                //Fires GTM Tags
                dataLayer.push({
                    'event': 'nielsen_gtm_fire',
                });
            } else {
                window.gusto.nielsen.userId = null;
                window.gusto.nielsen.segments = "";
                if (window.localStorage) {
                    window.localStorage.removeItem('nmcUserId');
                    window.localStorage.removeItem('nmcSegments'); 
                }
            }
        },
        receive: function(data) {
            if (data.user) {
                window.gusto.nielsen.userId = data.user.uid;
                window.gusto.nielsen.segments = data.user.segments.split(',').slice(0, 200).join(',');
            }
            for(var index=0; index < window.gusto.nielsen.callbacks.length; index++) {
                var callback = window.gusto.nielsen.callbacks[index];
                callback.call();
            }
            if (window.localStorage) {
                window.localStorage.setItem('nmcUserId', window.gusto.nielsen.userId);
                window.localStorage.setItem('nmcSegments', window.gusto.nielsen.segments);
            }
            window.WaitForIt.trigger('nielsen_data_ready');
        }
    };          
} else {
    window.gusto.nielsen = {
        userId: null,
        segments: "",
        callbacks: [],
        init: function() {
            if (window.localStorage) {
                window.gusto.nielsen.userId = window.localStorage.getItem('nmcUserId') || null;
                window.gusto.nielsen.segments = window.localStorage.getItem('nmcSegments') || "";
            }
        },
        receive: function(data) {
            if (data.user) {
                window.gusto.nielsen.userId = data.user.uid;
                window.gusto.nielsen.segments = data.user.segments.split(',').slice(0, 200).join(',');
            }
            for(var index=0; index < window.gusto.nielsen.callbacks.length; index++) {
                var callback = window.gusto.nielsen.callbacks[index];
                callback.call();
            }
            if (window.localStorage) {
                window.localStorage.setItem('nmcUserId', window.gusto.nielsen.userId);
                window.localStorage.setItem('nmcSegments', window.gusto.nielsen.segments);
            }
            window.WaitForIt.trigger('nielsen_data_ready');
        }
    };
    window.gusto.nielsen.init();
}
</script>
<!-- END Nielsen interchange script -->

        
        
        <section role="main">
            
            
                <div class="dac__banner__wrapper">
                    
    
        <div id="ad-banner" class="dac__banner">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['banner'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'banner');
                            }
                            
                                
                                    var valid_breakpoint = true;
                                    if(gusto.breakpoints) {
                                        valid_breakpoint = gusto.breakpoints.check('large-up');
                                    }
                                    if(valid_breakpoint) {
                                        window.GLOBALADVERTISING.push('banner', ad_mapping, false);
                                    }
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for banner');
                    }
                })();
            </script>
        </div>
    


                </div>
            
            
<div class="row row21">

    
        <div class="level2_wrapper">
            
                <div class="

cardset
level2




">

    

    

        
            

<article id="cadmus-article_18437" class="editorial cadmus full article  cadmus-article">
    <script type="application/ld+json">
        {"articleBody": "&quot;BOIIII THEY COULDNT HAVE EDITED THEM OUT OR SOMETHING???&quot; Continuity errors are often part and parcel of TV and film production \u2013 and Euphoria fans have just managed to spot a pretty big one involving Nate Jacobs and Cassie Howard in the Euphoria season 2 finale.The scene in question? Lexi&#x27;s play. The characters involved? Nate, Cassie and the legendary Ms Suze Howard, a.k.a. Cassie and Lexi&#x27;s mum. The continuity mistake? It happens shortly after Cassie storms the stage in front of a jam packed audience.At that point in the episode, Nate has already stormed out and is no longer sitting in the theatre. Both Cassie and Suze are also now on stage, with one trying to throw hands at Lexi and the other trying to calm the situation. But, as the camera pans over to the audience mid-Cassie meltdown, viewers can still see Suze screaming in her seat, and just over to the left of the screen, Cassie and Nate still sitting there watching on in horror. Oops. The continuity mistake was clocked and shared on TikTok by user @constancelangdonishot, with the clip gaining over 1.8 million views. The caption reads, &quot;BOIIII THEY COULDNT HAVE EDITED THEM OUT OR SOMETHING???&quot;In the comments, one user wrote, &quot;that&#x27;s Massie and Tate,&quot; with another joking, &quot;wow they look like they should have played Cassie and Nate&#x27;s lookalikes&quot;. Another fan wrote, &quot;this is their Khaleesi Starbucks cup moment,&quot; referring to Game of Thrones&#x27; absolutely massive f*ck up in the final season of the show.This one is decidedly less major than that one, but still noticeable enough for the audience to catch it. Due to the fact that Lexi&#x27;s play was filmed over a few weeks with countless different extras filling the seats in the theatre, there was bound to be continuity errors within some of those audience cut away shots. Throughout Lexi&#x27;s play, viewers have noticed a couple of errors regarding the extras who are sat near the main characters too. At one point, two completely different audience members are sat in front of and behind Maddy.It was also revealed in one viral TikTok, shared by an extra who appeared in the scene, that Dominic Fike was unable to return for some of the audience shots, and ended up being replaced by an Elliot lookalike. In this instance, it&#x27;s possible that a shot with Nate, Cassie and Suze not sat in their seats was not filmed, which meant editors were unable to use it. No one from Euphoria has addressed the editing mishap just yet.Read more about Euphoria here:Alexa Demie broke Sydney Sweeney\u2019s toe filming their fight in the Euphoria season 2 finaleAustin Abrams reveals Ethan&#x27;s dance was slightly different in the original script33 Euphoria memes about Lexi&#x27;s savage play in season 2, episode 7Jacob Elordi says he struggled to keep a straight face during Nate scene in Lexi&#x27;s playWATCH: Pangina Heals claps back at Jimbo and shock elimination decision on Drag Race UK vs The World", "description": "\"BOIIII THEY COULDNT HAVE EDITED THEM OUT OR SOMETHING???\"", "creator": [{"@type": "Person", "name": "Katie Louise Smith"}], "image": {"url": "https://images.popbuzz.com/images/291120?width=700&crop=16_9&signature=KasZX1qbQPNi8F2nZu7ld11jRNU=", "width": 700, "@type": "ImageObject", "height": 394}, "datePublished": "2022-03-02T12:13:27+00:00", "publisher": {"logo": {"url": "", "@type": "ImageObject"}, "@type": "Organization", "name": "PopBuzz"}, "author": [{"@type": "Person", "name": "Katie Louise Smith"}], "headline": "Euphoria fans notice huge Nate and Cassie editing mistake in season 2 finale", "dateModified": "2022-03-02T12:30:19+00:00", "mainEntityOfPage": {"@id": "https://www.popbuzz.com/tv-film/euphoria/nate-cassie-mistake-audience-lexi-play/", "@type": "WebPage"}, "@context": "http://schema.org", "@type": "Article"}
    </script>

    
        <script>
            var gusto = window.gusto || {};
            gusto.article = {
                'title': 'Euphoria fans notice huge Nate and Cassie editing mistake in season 2 finale',
                'publish_epoch': '1646223207',
                'slug': 'nate-cassie-mistake-audience-lexi-play',
                'author': 'Katie Louise Smith',
                'category': 'Euphoria'
            };
            gusto.related_content = [{"absolute_url": "http://www.popbuzz.com/tv-film/euphoria/dominic-fike-elliot-song-season-2-finale/", "id": "18427", "title": "Dominic Fike responds to fans hating Elliot\u2019s song in the Euphoria season 2 finale"}, {"absolute_url": "http://www.popbuzz.com/tv-film/euphoria/season-2-episode-6-trailer-maddy-cassie-nate/", "id": "18301", "title": "Maddy gets revenge on Cassie and Nate in shocking Euphoria season 2, episode 6 trailer"}, {"absolute_url": "http://www.popbuzz.com/tv-film/euphoria/season-2-finale-recap-what-happened-character/", "id": "18421", "title": "Euphoria season 2 finale: Here's what happened to each character"}];
        </script>
    
     
    
        <h1>Euphoria fans notice huge Nate and Cassie editing mistake in season 2 finale</h1>
    
    
    
        <p class="publish_date">2 March 2022, 12:13 | Updated: 2 March 2022, 12:30</p>
    

    <div style="position:relative;padding-top:56.25%; margin-bottom:10px;">
<video-js id="bc_player_6298472453001" data-video-id="6298472453001" data-account="6057949401001" data-player="default" data-embed="default" class="video-js" style="position:absolute;top:0;left:0;width:100%;height:100%;" controls="controls"></video-js>
</div>
<script>
    (function () {
            window.WaitForIt.wait_for(['nielsen_data_ready', 'sourcepoint_data_ready'], function() {
                var player = bc('bc_player_6298472453001');
                
                if (window.gusto.ad_switch.enable_ads_preroll === true) {
                    var isPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(
                            gusto.sourcepoint.nonIabIds.vendors.googleAdManager
                        ),
                        bc_tag_url = 'https://pubads.g.doubleclick.net/gampad/ads?iu=/21824617191/popbuzz/video/brightcove_player&description_url={window.location.href}&tfcd=0&npa=1&sz=400x300%7C640x480&cmsid=2527446&vid={mediainfo.id}&ad_rule=1&gdfp_req=1&output=xml_vast&unviewed_position_start=1&env=vp&impl=s&correlator={random}';

                    // npa means non-personalised ads
                    if (isPersonalisedAds) {
                        bc_tag_url = bc_tag_url.replace('npa=1', 'npa=0');
                    }

                    if (window.GLOBALADVERTISING) {
                        bc_tag_url +=
                            '&cust_params=' +
                            encodeURIComponent('kvplayer=' + 'brightcove') +
                            encodeURIComponent(
                                '&pageid=' + window.GLOBALADVERTISING.pageid
                            ) +
                            encodeURIComponent('&local=' + window.GLOBALADVERTISING.local) +
                            encodeURIComponent(
                                '&adtest=' + window.GLOBALADVERTISING.adtest
                            ) +
                            encodeURIComponent('&section=' + gusto.CATEGORY_PATH) +
                            encodeURIComponent('&at=' + window.GLOBALADVERTISING.at) +
                            encodeURIComponent(
                                '&sensitive=' + window.GLOBALADVERTISING.sensitive
                            ) +
                            encodeURIComponent('&gdpr=' + window.GLOBALADVERTISING.gdpr) +
                            encodeURIComponent(
                                '&gdpr_pd=' + window.GLOBALADVERTISING.gdpr_pd
                            ) +
                            encodeURIComponent(
                                '&gdpr_consent=' + window.GLOBALADVERTISING.gdpr_consent
                            ) +
                            encodeURIComponent('&nmc=' + gusto.nielsen.segments);
                    }

                    player.ima3({
                        serverUrl: bc_tag_url,
                        requestMode: "onplay",
                    });
                }
            }, 10000);
    })();
</script>
<div class="author-details">
<p class="author-details__author">
        By Katie Louise Smith
    </p>
<a class="author-details__twitter_handle" href="https://twitter.com/_katesss" target="_blank" title="Follow Katie Louise Smith on Twitter" rel="author">
@_katesss</a>
</div>
<div class="social-share">
<a href="https://www.facebook.com/dialog/share?href=www.popbuzz.com%2Ftv-film%2Feuphoria%2Fnate-cassie-mistake-audience-lexi-play%2F&amp;app_id=1590232324531551" target="_blank" onclick="gusto.tracking.social('facebook', 'share')">
<img alt="Facebook share" src="/assets_v4r/gusto/img/facebook-share.png" />
</a>
<a href="https://twitter.com/intent/tweet?url=www.popbuzz.com%2Ftv-film%2Feuphoria%2Fnate-cassie-mistake-audience-lexi-play%2F&amp;text=Euphoria+fans+notice+huge+Nate+and+Cassie+editing+mistake+in+season+2+finale+%40popbuzz" target="_blank" onclick="gusto.tracking.social('twitter', 'share')">
<img alt="Twitter share" src="/assets_v4r/gusto/img/twitter-share.png" />
</a>
</div>
<p class="standfirst">&quot;BOIIII THEY COULDNT HAVE EDITED THEM OUT OR SOMETHING???&quot;</p>
<div class="remixd-audio-player-wrapper">
<h4 class="remixd-audio-player-wrapper__header">
        Listen to this article
    </h4>
<div id="remixd-audio-player">
<div id="remixd-audio-loading">Loading audio...</div>
</div>
</div>
<p class="paragraph-text">Continuity errors are often part and parcel of TV and film production – and <a href="/tv-film/euphoria/"><em>Euphoria</em></a> fans have just managed to spot a pretty big one involving Nate Jacobs and Cassie Howard in the <a href="/tv-film/euphoria/season-2-finale-recap-what-happened-character/"><em>Euphoria</em> season 2 finale</a>.</p><div id="Teads_ad1"></div><p class="paragraph-text">The scene in question? <a href="/tv-film/euphoria/memes-lexi-play-season-2-episode-7/">Lexi&#x27;s play</a>. The characters involved? Nate, Cassie and the legendary Ms Suze Howard, a.k.a. Cassie and Lexi&#x27;s mum. The continuity mistake? It happens shortly after Cassie storms the stage in front of a jam packed audience.</p><p class="paragraph-text">At that point in the episode, Nate has already stormed out and is no longer sitting in the theatre. Both Cassie and Suze are also now on stage, with one trying to throw hands at Lexi and the other trying to calm the situation. </p><p class="paragraph-text">But, as the camera pans over to the audience mid-Cassie meltdown, viewers can still see Suze screaming in her seat, and just over to the left of the screen, Cassie and Nate still sitting there watching on in horror. Oops.</p><div class="adyoulike-article"></div>
<figure>
<img alt="Euphoria fans notice editing mistake with Nate and Cassie in season 2 finale" class="content-image" data-image-catalogue-id="291120" width="660" height="370" loading="lazy" src="https://images.popbuzz.com/images/291120?crop=16_9&amp;width=660&amp;relax=1&amp;signature=-PMRTv7rooFhE63jQpiQ1BtvwEo=" srcset="
                https://images.popbuzz.com/images/291120?crop=16_9&amp;width=375&amp;relax=1&amp;signature=Ym-o00F83hSrf9flRowgawtHllw= 375w,
                https://images.popbuzz.com/images/291120?crop=16_9&amp;width=420&amp;relax=1&amp;signature=iRAvmzL0C4SlFNTcdiatsY6T5-M= 420w,
                https://images.popbuzz.com/images/291120?crop=16_9&amp;width=660&amp;relax=1&amp;signature=-PMRTv7rooFhE63jQpiQ1BtvwEo= 660w" sizes="
                (max-width: 375px) 375px,
                (max-width: 420px) 420px,
                660px" />
<figcaption>
    Euphoria fans notice editing mistake with Nate and Cassie in season 2 finale.
    <span class="attribution">
        Picture: 
HBO, @constancelangdonishot via TikTok


    </span>
</figcaption>
</figure>
<p class="paragraph-text">The continuity mistake was clocked and shared on TikTok by user <a href="https://www.tiktok.com/@constancelangdonishot" rel="noopener" target="_blank">@constancelangdonishot</a>, with the clip gaining over 1.8 million views. The caption reads, &quot;BOIIII THEY COULDNT HAVE EDITED THEM OUT OR SOMETHING???&quot;</p><p class="paragraph-text">In the comments, one user wrote, &quot;that&#x27;s Massie and Tate,&quot; with another joking, &quot;wow they look like they should have played Cassie and Nate&#x27;s lookalikes&quot;. </p><p class="paragraph-text">Another fan wrote, &quot;this is their Khaleesi Starbucks cup moment,&quot; referring to <em>Game of Thrones</em>&#x27; <a href="/tv-film/game-of-thrones/starbucks-cup/">absolutely massive f*ck up</a> in the final season of the show.</p><p class="paragraph-text">This one is <em>decidedly</em> less major than that one, but still noticeable enough for the audience to catch it.</p>
<div class="dac__article-mpu">
<div id="ad-mpu" class="dac__mpu">
<script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['mpu'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'mpu');
                            }
                            
                                
                                    var valid_breakpoint = true;
                                    if(gusto.breakpoints) {
                                        valid_breakpoint = gusto.breakpoints.check('medium-down');
                                    }
                                    if(valid_breakpoint) {
                                        window.GLOBALADVERTISING.push('mpu', ad_mapping, false);
                                    }
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for mpu');
                    }
                })();
            </script>
</div>
</div>
<div class="tiktok-container">
<iframe width="340" height="700" src="https://www.tiktok.com/embed/7069620754735746347" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe>
</div>
<p class="paragraph-text">Due to the fact that Lexi&#x27;s play was <a href="/tv-film/euphoria/austin-abrams-ethan-dance-nate-season-2-episode-7/">filmed over a few weeks</a> with countless different extras filling the seats in the theatre, there was bound to be continuity errors within some of those audience cut away shots. </p><p class="paragraph-text">Throughout Lexi&#x27;s play, viewers have noticed a couple of errors regarding the extras who are sat near the main characters too. At one point, two completely different audience members are sat in front of and behind Maddy.</p><p class="paragraph-text">It was also revealed in one viral TikTok, <a href="https://www.popbuzz.com/tv-film/euphoria/season-2-episode-7-filming-set-tiktok/" rel="noopener" target="_blank">shared by an extra</a> who appeared in the scene, that Dominic Fike was unable to return for some of the audience shots, and ended up being replaced by an Elliot lookalike. </p><p class="paragraph-text">In this instance, it&#x27;s possible that a shot with Nate, Cassie and Suze not sat in their seats was not filmed, which meant editors were unable to use it. No one from <em>Euphoria</em> has addressed the editing mishap just yet.</p><h2 class="heading-subtitle">Read more about <em>Euphoria</em> here:</h2><ul><li><a href="https://www.popbuzz.com/tv-film/euphoria/sydney-sweeney-alexa-demie-toe-cassie-maddy/" rel="noopener" target="_blank">Alexa Demie broke Sydney Sweeney’s toe</a> filming their fight in the Euphoria season 2 finale</li><li>Austin Abrams reveals <a href="https://www.popbuzz.com/tv-film/euphoria/austin-abrams-ethan-dance-scene-script/" rel="noopener" target="_blank">Ethan&#x27;s dance was slightly different in the original script</a></li><li><a href="https://www.popbuzz.com/tv-film/euphoria/memes-lexi-play-season-2-episode-7/" rel="noopener" target="_blank">33 Euphoria memes about Lexi&#x27;s savage play</a> in season 2, episode 7</li><li>Jacob Elordi says he <a href="https://www.popbuzz.com/tv-film/euphoria/jacob-elordi-nate-lexi-play-dance-scene/" rel="noopener" target="_blank">struggled to keep a straight face during Nate scene</a> in Lexi&#x27;s play</li></ul><h2 class="heading-subtitle"><strong>WATCH: </strong><a href="https://www.popbuzz.com/tv-film/rupauls-drag-race/pangina-heals-blu-hydrangea-jimbo-elimination/" rel="noopener" target="_blank"><strong>Pangina Heals claps back at Jimbo and shock elimination decision on Drag Race UK vs The World</strong></a></h2>
<div class="embed_container">
<iframe class="js_youtube_embed" allowfullscreen="" frameborder="0" height="113" src="https://www.youtube.com/embed/tLxNt2D9N_Y?enablejsapi=1" allowfullscreen="allowfullscreen" class="js_youtube_embed" width="200"></iframe>
</div>

    
        
    
        <div id="ad-instream" class="dac__instream">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['instream'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'instream');
                            }
                            
                                
                                    window.GLOBALADVERTISING.push('instream', ad_mapping, false);
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for instream');
                    }
                })();
            </script>
        </div>
    


    

    
        <div id="ultimedia_wrapper"></div>

    

    

</article>

        
        
    
</div>

            
        </div>
    
        <div class="level1_wrapper">
            
                <div class="

cardset
level1




">

    

    

        
            

    <div class="dac__mpu-card">
    
        <div id="ad-mpu-desktop" class="dac__mpu-desktop">
            <script>
                (function(){
                    var ua_string = window.navigator.userAgent;
                    var disable_ads = ua_string.indexOf('NOGUSTOADS') > -1;
                    var log_ads = ua_string.indexOf('LOGGUSTOADS') > -1;
                    var ad_mapping =  window.GLOBALADVERTISING.mappings['mpu-desktop'];

                    if(ad_mapping) {
                        if (disable_ads) {
                            document.querySelectorAll('.dac__mpu-card, .dac__stream-mpu-card').forEach(e => e.parentNode.removeChild(e));
                        }
                        else {
                            if(log_ads) {
                                console.log('Ad position defined', 'mpu-desktop');
                            }
                            
                                
                                    var valid_breakpoint = true;
                                    if(gusto.breakpoints) {
                                        valid_breakpoint = gusto.breakpoints.check('large-up');
                                    }
                                    if(valid_breakpoint) {
                                        window.GLOBALADVERTISING.push('mpu-desktop', ad_mapping, false);
                                    }
                                
                            
                        }
                    }
                    else {
                        console.error('No mapping defined for mpu-desktop');
                    }
                })();
            </script>
        </div>
    

</div>


        
        
    
</div>

            
                <div class="

cardset
level1


seemore

">

    
        <h2 class="cardset__title cardset__title--seemore">
            
                <a aria-label="Latest TV &amp; Film" href="/tv-film/news/">Latest TV &amp; Film</a>
            
        </h2>
        
            <p class="seemore"><a rel="nofollow" aria-label="More Latest TV &amp; Film" href="/tv-film/news/">See more<span> Latest TV &amp; Film</span></a></p>
        
    

    

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/euphoria/hbo-most-watched-viewership/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/291154?width=105&amp;crop=1_1&amp;signature=9-fZrCSS7mzmYLFkhrDIcYanxgk="
    width="105"
    height="105"
    alt="Euphoria is now HBO&#39;s second most-watched show of all time."
    srcset="https://images.popbuzz.com/images/291154?width=105&amp;crop=1_1&amp;signature=9-fZrCSS7mzmYLFkhrDIcYanxgk= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3>
        
            
            Euphoria is now HBO&#39;s second most-watched show of all time
            
        
        </h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/news/zoe-kravitz-catwoman-bisexual-batman-selina-kyle/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/291134?width=105&amp;crop=1_1&amp;signature=GR4JQqpTLSIqN35pbFp565JRIxI="
    width="105"
    height="105"
    alt="Zoë Kravitz says her Catwoman is bisexual in The Batman"
    srcset="https://images.popbuzz.com/images/291134?width=105&amp;crop=1_1&amp;signature=GR4JQqpTLSIqN35pbFp565JRIxI= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3>
        
            
            Zoë Kravitz says her Catwoman is bisexual in The Batman
            
        
        </h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/tv-film/news/">News</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/euphoria/fez-lexi-letter-angus-cloud/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/291006?width=105&amp;crop=1_1&amp;signature=vrCpF8T_kgnuAsMngiADVkS6vO4="
    width="105"
    height="105"
    alt="Angus Cloud reveals what Fez&#39;s letter to Lexi says"
    srcset="https://images.popbuzz.com/images/291006?width=105&amp;crop=1_1&amp;signature=vrCpF8T_kgnuAsMngiADVkS6vO4= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Euphoria's Angus Cloud reveals what Fez's letter to Lexi</span><span class="truncated"> says</span></h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/music/news/machine-gun-kelly-emo-girl-jennifers-body/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/290963?width=105&amp;crop=1_1&amp;signature=CrZkZzMG13DNsmL_5bLql9bFt_w="
    width="105"
    height="105"
    alt="Machine Gun Kelly says his song Emo Girl is based on Jennifer&#39;s Body"
    srcset="https://images.popbuzz.com/images/290963?width=105&amp;crop=1_1&amp;signature=CrZkZzMG13DNsmL_5bLql9bFt_w= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Machine Gun Kelly says Emo Girl is inspired by Megan Fox</span><span class="truncated"> in Jennifer's Body</span></h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/music/news/">News</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/euphoria/javon-walton-robin-batman-robert-pattinson/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/290953?width=105&amp;crop=1_1&amp;signature=tp075uMxWIw-6gymboYlNX2_ePQ="
    width="105"
    height="105"
    alt="Euphoria&#39;s Javon Walton wants to play Robin in the next Batman with Robert Pattinson"
    srcset="https://images.popbuzz.com/images/290953?width=105&amp;crop=1_1&amp;signature=tp075uMxWIw-6gymboYlNX2_ePQ= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Euphoria's Javon Walton wants to play Robin in the next</span><span class="truncated"> Batman with Robert Pattinson</span></h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
        
    
</div>

            
                <div class="

cardset
level1




">

    
        <h2 class="cardset__title ">
            
                <span tabindex="0">Trending on PopBuzz</span>
            
        </h2>
        
    

    

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/music/artists/harry-styles/news/tiktok-account-suemonella/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/291130?width=105&amp;crop=1_1&amp;signature=OMqNZYXZElZAVyMJ33VyCDtJrO4="
    width="105"
    height="105"
    alt="Harry Styles fans think they&#39;ve discovered his secret TikTok account"
    srcset="https://images.popbuzz.com/images/291130?width=105&amp;crop=1_1&amp;signature=OMqNZYXZElZAVyMJ33VyCDtJrO4= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Harry Styles fans think they've discovered his secret</span><span class="truncated"> TikTok account</span></h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/music/artists/harry-styles/">Harry Styles</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/celeb/joey-king-engaged-boyfriend-steven-piet/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/291086?width=105&amp;crop=1_1&amp;signature=0oJseLwwA5hHAKlLDvlcSMAJppo="
    width="105"
    height="105"
    alt="Joey King gets engaged to boyfriend Steven Piat"
    srcset="https://images.popbuzz.com/images/291086?width=105&amp;crop=1_1&amp;signature=0oJseLwwA5hHAKlLDvlcSMAJppo= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3>
        
            
            Joey King gets engaged to boyfriend Steven Piet
            
        
        </h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/celeb/">Celeb</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/internet/tiktok/addison-rae-euphoria-season-3-cast-twitter/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/290928?width=105&amp;crop=1_1&amp;signature=WwwJCB9L_PnPDcKTFBxx51-9aYw="
    width="105"
    height="105"
    alt="Is Addison Rae going to be in Euphoria?"
    srcset="https://images.popbuzz.com/images/290928?width=105&amp;crop=1_1&amp;signature=WwwJCB9L_PnPDcKTFBxx51-9aYw= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3>
        
            
            Addison Rae addresses backlash to Euphoria social media post
            
        
        </h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            
<p class="topic pivot-point"><a class="pivot-point__title" href="/internet/tiktok/">TikTok</a></p>


        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/euphoria/nate-jacobs-gay-sexuality-jacob-elordi/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/290927?width=105&amp;crop=1_1&amp;signature=Qo5dP2SSgp-IspPdy7jEqih9GRU="
    width="105"
    height="105"
    alt="Jacob Elordi addresses Nate&#39;s sexuality in Euphoria"
    srcset="https://images.popbuzz.com/images/290927?width=105&amp;crop=1_1&amp;signature=Qo5dP2SSgp-IspPdy7jEqih9GRU= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Euphoria's Jacob Elordi addresses speculation about</span><span class="truncated"> Nate’s sexuality</span></h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
            
<div class="article editorial promo short-form landscape pivot">

    

    <a href="/tv-film/euphoria/season-3-cal-jail-nate-eric-dane/" ><div class="img_wrapper"><img
    src="https://images.popbuzz.com/images/290877?width=105&amp;crop=1_1&amp;signature=I-yQN9HmUsE2qRMeFmRXLReDdC4="
    width="105"
    height="105"
    alt="Eric Dane says Cal is going to get a redemption arc in Euphoria season 3"
    srcset="https://images.popbuzz.com/images/290877?width=105&amp;crop=1_1&amp;signature=I-yQN9HmUsE2qRMeFmRXLReDdC4= 105w"
    sizes="(min-width: 1024px) 105px, (max-width: 1024px) and (min-width: 485px) 105px, 100vw"
     loading="lazy"
/></div><h3><span class="ellipsis">Eric Dane says Cal is going to get a redemption arc in</span><span class="truncated"> Euphoria season 3</span></h3></a>
    <div class="card__extra-content">
        <div class="card__extra-content__content">
            
                
            
            

        </div>
    </div>
</div>

        
        
    
</div>

            
                <div class="

cardset
level1




">

    
        <h2 class="cardset__title ">
            
                <span tabindex="0">More TV &amp; Film</span>
            
        </h2>
        
    

    

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/the-umbrella-academy/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2019/03/the-umbrella-academy-logo-1548338060-editorial-short-form-0.jpg" alt=""/>
            
        </div>
        
            
        
        <h3>
            
                The Umbrella Academy
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/stranger-things/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2016/30/stranger-things-1469531493-editorial-short-form-0.png" alt=""/>
            
        </div>
        
            
        
        <h3>
            
                Stranger Things
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/american-horror-story/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2018/41/american-horror-story-apocalypse-1539875977-editorial-short-form-0.png" alt=""/>
            
        </div>
        
            
        
        <h3>
            
                American Horror Story
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/netflix-you/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2019/51/penn-badgley-as-joe-goldberg-in-netflixs-you-1577133905-editorial-short-form-0.jpg" alt=""/>
            
        </div>
        
            
        
        <h3>
            
                You
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/sex-education/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2019/01/otis---asa-butterfield---sex-education-neflix-1547203161-editorial-short-form-0.png" alt=""/>
            
        </div>
        
            
        
        <h3>
            
                Sex Education
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2018/41/rupauls-drag-race-1539874808-editorial-short-form-0.jpg" alt=""/>
            
        </div>
        
            
        
        <h3>
            
                RuPaul&#39;s Drag Race
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/on-my-block/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2018/12/netflix-on-my-block-season-2--1522164988-editorial-short-form-0.jpg" alt=""/>
            
        </div>
        
            
        
        <h3>
            
                On My Block
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
            

<div class="
    editorial
    editorial_card
    promo
    short-form portrait
    
    
    
    
    
">
    
    <a href="https://www.popbuzz.com/tv-film/riverdale/" >
    
        
        <div class="img_wrapper">
            <img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABkAQMAAABKLAcXAAAABGdBTUEAALGPC/xhBQAAAANQTFRF2NjY5QlMowAAABNJREFUGBljGAWjYBSMglFAVwAABXgAAdxFAhsAAAAASUVORK5CYII=" data-src="https://assets.popbuzz.com/2017/29/betty-riverdale--1500461450-editorial-short-form-0.jpg" alt=""/>
            
        </div>
        
            
        
        <h3>
            
                Riverdale
            
        </h3>
        
    </a>

    <div class="card__extra-content">
        
    </div>

</div>

        
        
    
</div>

            
        </div>
    

</div>


        </section>
        


<footer class="footer">
    <div class="footer__section footer-back-to-top">
        <a href="#top" id="go_to_top" class="footer-back-to-top__link" title="Back to top">Back to top</a>
    </div>
    <div class="footer__section">
        <div class="grid-row">
            <div class="grid-row__col--3">
                
    <h3 class="footer__heading">Also on PopBuzz</h3>
    <ul class="footer-hot-links">
        
            <li class="footer-hot-links__item">
                <a href="https://www.globalplayer.com/" class="footer-hot-links__link">Listen to Global Player</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race/uk-season-3-cast-out-of-drag/" class="footer-hot-links__link">Drag Race UK Season 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/the-kissing-booth/" class="footer-hot-links__link">The Kissing Booth 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/sex-education/season-3-release-date-cast-trailer-netflix/" class="footer-hot-links__link">Sex Education season 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/quizzes/cheugy-quiz/" class="footer-hot-links__link">Cheugy</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/bella-poarch/" class="footer-hot-links__link">Bella Poarch</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/olivia-rodrigo/" class="footer-hot-links__link">Olivia Rodrigo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/high-school-musical-the-series/" class="footer-hot-links__link">High School Music: The Musical: The Series</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/taylor-swift/" class="footer-hot-links__link">Taylor Swift</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/dispo-invite-how-to-find/" class="footer-hot-links__link">Dispo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/to-all-the-boys-ive-loved-before/3-release-date-cast-always-and-forever-lara-jean/" class="footer-hot-links__link">To All the Boys 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race" class="footer-hot-links__link">Drag Race UK</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/american-horror-story/" class="footer-hot-links__link">American Horror Story</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/euphoria/" class="footer-hot-links__link">Euphoria</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/chilling-adventures-of-sabrina/" class="footer-hot-links__link">Chilling Adventures of Sabrina</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/greys-anatomy/" class="footer-hot-links__link">Grey&#39;s Anatomy</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://globalacademy.com/" class="footer-hot-links__link">Global Academy</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/top-nine-instagram-2019-app/" class="footer-hot-links__link">Instagram Top Nine</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/news/spotify-stats-top-artists-songs-most-played-how/" class="footer-hot-links__link">Spotify</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/timothee-chalamet/" class="footer-hot-links__link">Timothée Chalamet</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/tiktok/" class="footer-hot-links__link">TikTok</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/josephine-langford/" class="footer-hot-links__link">Josephine Langford</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/hero-fiennes-tiffin/" class="footer-hot-links__link">Hero Fiennes Tiffin</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/louis-partridge/" class="footer-hot-links__link">Louis Partridge</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/quizzes/" class="footer-hot-links__link">Quizzes</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/louis-partridge/" class="footer-hot-links__link">Louis Partridge</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/bella-poarch/" class="footer-hot-links__link">Bella Poarch</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/haunting-of-bly-manor/" class="footer-hot-links__link">The Haunting of Bly Manor</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/the-kissing-booth/" class="footer-hot-links__link">The Kissing Booth</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/best-memes-2020/" class="footer-hot-links__link">Memes</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/the-umbrella-academy/season-3-release-date-cast-trailer-netflix/" class="footer-hot-links__link">The Umbrella Academy 3</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/best-tiktok-songs-2020-popular/" class="footer-hot-links__link">TikTok Songs</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/lizzo/" class="footer-hot-links__link">Lizzo</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/billie-eilish/" class="footer-hot-links__link">Billie Eilish</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/elite-netflix/season-4-release-date-cast-trailer-spoilers-news/" class="footer-hot-links__link">Elite season 4</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/on-my-block/" class="footer-hot-links__link">On My Block</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/rupauls-drag-race/" class="footer-hot-links__link">RuPaul&#39;s Drag Race</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/social-media/snapchat/" class="footer-hot-links__link">Snapchat</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/stranger-things/stranger-things-season-4-release-date-cast-trailer/" class="footer-hot-links__link">Stranger Things 4</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/features/millie-bobby-brown/" class="footer-hot-links__link">Millie Bobby Brown</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/addison-rae/" class="footer-hot-links__link">Addison Rae</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/outer-banks/" class="footer-hot-links__link">Outer Banks</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/nick-robinson/" class="footer-hot-links__link">Nick Robinson</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/internet/viral/charli-damelio/" class="footer-hot-links__link">Charli D&#39;Amelio</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/harry-styles/" class="footer-hot-links__link">Harry Styles</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/sex-education/" class="footer-hot-links__link">Sex Education</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/features/doja-cat/" class="footer-hot-links__link">Doja Cat</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/music/artists/bts/" class="footer-hot-links__link">BTS</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="https://www.popbuzz.com/tv-film/to-all-the-boys-ive-loved-before/" class="footer-hot-links__link">To All The Boys I&#39;ve Loved Before</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/tv-film/netflix/" class="footer-hot-links__link">Netflix</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/twenty-one-pilots/" class="footer-hot-links__link">Twenty One Pilots</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/halsey/" class="footer-hot-links__link">Halsey</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/" class="footer-hot-links__link">New Music</a>
            </li>
        
            <li class="footer-hot-links__item">
                <a href="/music/artists/panic-at-the-disco/" class="footer-hot-links__link">Panic! At The Disco</a>
            </li>
        
    </ul>


            </div>
        </div>
    </div>

    <div class="footer__section--shaded">
        <div class="grid-row">
            <div class="grid-row__col--1">
                <h3 class="footer__heading">Useful Links</h3>
                <ul class="footer-useful-links">
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/about-us/" target="_blank">About Us</a>
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/contact-us/" target="_blank">Contact Us</a>
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="https://global.com/cookies/" target="_blank">Cookies</a>
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="https://global.com/privacy-policy/" target="_blank">Privacy</a>
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/terms-conditions/" target="_blank">Terms &amp; Conditions</a>
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="/advertise/" target="_blank">Advertise</a>
                    
                    </li>
                
                    <li class="footer-useful-links__item">
                    
                        <a class="footer-useful-links__link" href="https://jobs.global.com" target="_blank">Global Jobs</a>
                    
                    </li>
                
                </ul>
            </div>

            <div class="grid-row__col--1">
                
            </div>

            <div class="grid-row__col--1">
                <h3 class="footer__heading">Follow Us</h3>
                <div class="social-links__container">
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--twitter"
                href="https://twitter.com/popbuzz"
                title="Follow PopBuzz on Twitter"
                target="_blank">Follow PopBuzz on Twitter</a>
        </div>
    
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--facebook"
                href="https://www.facebook.com/popbuzz"
                title="Follow PopBuzz on Facebook"
                target="_blank">Follow PopBuzz on Facebook</a>
        </div>
    
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--instagram"
                href="https://instagram.com/popbuzz"
                title="Follow PopBuzz on Instagram"
                target="_blank">Follow PopBuzz on Instagram</a>
        </div>
    
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--youtube"
                href="https://www.youtube.com/user/popbuzz"
                title="Follow PopBuzz on Youtube"
                target="_blank">Follow PopBuzz on Youtube</a>
        </div>
    
    
        <div class="social-links__item">
            <a class="social-links__link social-links__link--tiktok"
                href="https://www.tiktok.com/@popbuzz"
                title="Follow PopBuzz on TikTok"
                target="_blank">Follow PopBuzz on TikTok</a>
        </div>
    
 </div>

            </div>
        </div>
    </div>

    <div class="footer__section">
        <div class="grid-row" itemscope itemtype="http://schema.org/Organization">
            <div class="grid-row__col--3 footer-footnote-section">
                &copy; <span itemprop="legalName">Global</span> 2022
            </div>
            <div class="grid-row__col--3 footer-footnote-section footer-footnote-section--end" itemprop="address">
                30 Leicester Square, London, WC2H 7LA
            </div>
            
                <a class="footer__section__privacy_manager_button" id="privacy_manager__button" href="#">
                    Privacy Manager
                </a>
            
        </div>
    </div>
</footer>
<script>
    var privacy_manager__button = document.getElementById('privacy_manager__button');
    if(privacy_manager__button) {
        privacy_manager__button.onclick = function(e) {
            e.preventDefault();
            if (window._sp_) {
                window._sp_.loadPrivacyManagerModal(
                    "173688"
                );
            }
        };
    }
</script>


        
        


    
        
            <script src="/assets_v4r/dist/combined/js/page_609eb4.min.js" defer></script>
        
    



        <!-- Global DAC Execution -->
        
            <script>
    // Enable Google Ad Services
    function googleAdManagerInit() {
        var isNonPersonalisedAds = gusto.sourcepoint.checkNonIabVendorConsentById(gusto.sourcepoint.nonIabIds.vendors.googleAdManager) ? 0 : 1;
        googletag.cmd.push(function() {
            googletag.pubads()
                .setTargeting("section", String(window.GLOBALADVERTISING.section))
                .setTargeting("pageid", String(window.GLOBALADVERTISING.pageid))
                .setTargeting("contenttype", String(window.GLOBALADVERTISING.contenttype))
                .setTargeting("gdpr_consent", String(window.GLOBALADVERTISING.gdpr_consent))
                .setTargeting("adtest", String(window.GLOBALADVERTISING.adtest))
                .setTargeting("level", String(window.GLOBALADVERTISING.level))
                .setTargeting("at", String(window.GLOBALADVERTISING.at))
                .setTargeting("loginstate", String(window.GLOBALADVERTISING.loginstate))
                .setTargeting("pagecount", String(window.GLOBALADVERTISING.pagecount))
                .setTargeting("newslink", window.GLOBALADVERTISING.newslink ? String(window.GLOBALADVERTISING.newslink) : '')
                .setTargeting("sensitive", String(window.GLOBALADVERTISING.sensitive))
                .setTargeting("takeover", String(Math.floor(Math.random()*6) + 1));
            if(window.gusto.nielsen.segments) {
                googletag.pubads().setTargeting("nmc", String(window.gusto.nielsen.segments.split(":")));
            }
            googletag.pubads().setTargeting("npa", String(isNonPersonalisedAds));
    
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.pubads().disableInitialLoad();
            googletag.enableServices();

            // events
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot.getSlotElementId() === 'ad-banner') {
                    window.WaitForIt.trigger('ad_banner_rendered');
                }
            });
                
            googletag.pubads().refresh();
        });
    }
</script>

        
    </body>
</html>
